HDU 1017 直接暴力。

C - 3

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status Practice HDU 1017

Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input

1

10 1
20 3
30 4
0 0

Sample Output

Case 1: 2
Case 2: 4
Case 3: 5

代码:
#include<stdio.h>
#include<string.h>
#include<math.h>

#define N 110

int main()
{
    int i, j, t, n, m, f = 0;

    scanf("%d", &t);

    while(t--)
    {
        int k = 1;

        if(f == 1)
            printf("\n");

        while(scanf("%d%d", &n, &m), n+m)
        {
            int ans=0;

            for(i = 1; i < n; i++)
            {
                for(j = 1; j < n; j++)
                {
                    if((i*i+j*j+m) % (i*j) == 0 && (i < j))
                        ans++;
                }

            }
            printf("Case %d: %d\n", k++,ans);
        }

        f = 1;
    }
    return 0;
}
时间: 2024-10-13 18:26:00

HDU 1017 直接暴力。的相关文章

HDU 1017 A Mathematical Curiosity (输出格式,穷举)

#include<stdio.h> int main() { int N; int n,m; int a,b; int cas; scanf("%d",&N); while(N--) { cas=1;//必须在这儿初始化cas,坑 while(scanf("%d%d",&n,&m),n||m) { int count=0; for(a = 1; a < n; a++)//穷举法 { for(b = a + 1; b <

Hdu 1017 A Mathematical Curiosity

 A Mathematical Curiosity Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 41387    Accepted Submission(s): 13311 Problem Description Given two integers n and m, count the number of pairs of inte

HDU 1017 A Mathematical Curiosity【看懂题意+穷举法】

//2014.10.17    01:19 //题意: //先输入一个数N,然后分块输入,每块输入每次2个数,n,m,直到n,m同一时候为零时 //结束,当a和b满足题目要求时那么这对a和b就是一组 //注意: //每一块的输出中间有一个回车 A Mathematical Curiosity Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s)

HDU 1017 A Mathematical Curiosity (数学)

A Mathematical Curiosity Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 25871    Accepted Submission(s): 8174 Problem Description Given two integers n and m, count the number of pairs of integ

HDU 1017

题目:HDU1017  A Mathmatical Curiosity 题目分析:水题.重点是输入输出格式. #include<stdio.h> #include<string.h> #include<iostream> using namespace std; int main() { int n,m,N; scanf("%d",&N); while(N--){ int Case=0; while (scanf("%d%d&quo

HDU 1017 A Mathematical Curiosity (枚举水题)

Problem Description Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer. This problem contains multiple test cases! The first line of a multiple input is an integer N

【HDU】5247-找连续数(直接暴力)

ORZ,这道题想复杂了,原来直接暴力就可以了复杂度为 n * n * logn #include<cstdio> #include<set> #include<algorithm> using namespace std; typedef long long LL; const int maxn = 10005; set<LL>s; set<LL>::iterator it1,it2; int n,m; int num[maxn] = {0};

Hdu oj 1017 A Mathematical Curiosity

题目:点击打开链接 #include<stdio.h> int main() { int t; scanf("%d",&t); while(t--) { int a=0; int m,n; while(scanf("%d%d",&n,&m)) { if(m==0&&n==0) break; a++; int i,j,k,z=0; for(i=1;i<n;i++) for(j=i+1;j<n;j++)//

(HDU)1017 --A Mathematical Curiosity(数学好奇心)

描述 给定两个整数n和m,计数整数对(a,b)的数目,使得0 <a <b <n,并且(a ^ 2 + b ^ 2 + m)/(ab)是一个整数. 这个问题包含多个测试用例! 输入的第一行是整数N,然后是空白行,后跟N个输入块. 每个输入块采用问题说明中指示的格式. 输入块之间有空行. 输出格式由N个输出块组成. 输出块之间有一个空行. 输入 您将在输入中获得多个样例. 每个情况由包含整数n和m的行指定. 输入结束由n = m = 0的情况表示.您可以假设0 <n <= 100