POJ3164 Command Network 【最小树形图】

Command Network

Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 12648   Accepted: 3656

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must
be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The
nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all
pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between
which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between
1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy

POJ真奇怪,这题用G++提交WA,用C++就AC了。

题意:给定n个顶点和m条有向边,求最小树形图。

题解:这题是最小树形图的模板题了,大致总结一下最小树形图的朱刘算法:

1、求最短弧集,对于除了根之外的每个节点,找出它的最短入边,放入in[]数组,然后判断是否有除根外的顶点没有入边即是否有孤立点,若有则不存在最小树形图;

2、将每个顶点的最短入边权值加入ans中,检查有向回路,若没有回路则当前ans即为最小树形图的权值,算法结束,否则将有向回路缩成一个点并重新构图,每个点的编号要重新哈希,对应边的权值若不在环中要减去入点的的最短入边值,因为之前已经将它加入ans中,重复步骤一直到无环为止。

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <limits.h>
#define maxn 102
#define maxm 10002
#define inf INT_MAX

struct Node{
	double x, y;
} ver[maxn];
struct Node2{
	int u, v;
	double cost;
} edge[maxm];
double ans;
int pre[maxn], hash[maxn], vis[maxn];
double in[maxn];

bool ZL_MST(int root, int nv, int ne)
{
	ans = 0;
	int i, u, v, cntnode;
	while(true){
		for(i = 0; i < nv; ++i) in[i] = inf;
		for(i = 0; i < ne; ++i){
			u = edge[i].u; v = edge[i].v;
			if(edge[i].cost < in[v] && u != v){
				pre[v] = u; in[v] = edge[i].cost;
			}
		}
		for(i = 0; i < nv; ++i)
			if(i != root && in[i] == inf) return false;
		memset(hash, -1, sizeof(hash));
		memset(vis, -1, sizeof(vis));
		in[root] = cntnode = 0;
		for(i = 0; i < nv; ++i){
			ans += in[i];
			v = i;
			while(vis[v] != i && hash[v] == -1 && v != root){
				vis[v] = i; v = pre[v];
			}
			if(v != root && hash[v] == -1){
				for(u = pre[v]; u != v; u = pre[u]){
					hash[u] = cntnode;
				}
				hash[v] = cntnode++;
			}
		}
		if(cntnode == 0) break;
		for(i = 0; i < nv; ++i)
			if(hash[i] == -1) hash[i] = cntnode++;

		for(i = 0; i < ne; ++i){
			v = edge[i].v;
			edge[i].u = hash[edge[i].u];
			edge[i].v = hash[edge[i].v];
			if(edge[i].u != edge[i].v){
				edge[i].cost -= in[v];
			}
		}

		nv = cntnode;
		root = hash[root];
	}
	return true;
}

int main()
{
	int n, m, a, b, i;
	double x, y;
	while(scanf("%d%d", &n, &m) == 2){
		for(i = 0; i < n; ++i)
			scanf("%lf%lf", &ver[i].x, &ver[i].y);
		for(i = 0; i < m; ++i){
			scanf("%d%d", &a, &b);
			x = ver[--a].x - ver[--b].x;
			y = ver[a].y - ver[b].y;
			edge[i].cost = sqrt(x * x + y * y);
			edge[i].u = a; edge[i].v = b;
		}
		if(ZL_MST(0, n, m)) printf("%.2lf\n", ans);
		else printf("poor snoopy\n");
	}
	return 0;
}

POJ3164 Command Network 【最小树形图】

时间: 2024-08-10 12:16:05

POJ3164 Command Network 【最小树形图】的相关文章

POJ3164 Command Network 最小树形图

最小树形图,就是给有向带权图中指定一个特殊的点root,求一棵以root为根的有向生成树T,并且T中所有边的总权值最小. 朱刘算法模板题 #include <iostream> #include <algorithm> #include <cstdio> #include <cstdlib> #include <cstring> #include <string> #include <stack> #include <

poj Command Network 最小树形图

规定根节点,求一颗生成树使得权值最小,但由于是有向图,所以最小生成树算法失效. 查资料后得知此类问题叫做最小树形图. 解决最小树形图问题的朱刘算法,算法核心基于找 [最小弧集->找环,消环缩点] 的思想,来慢慢构造树形图. 所有的灵魂都在这张图上.0.0 注意缩点后的弧权值的处理 #include<iostream> #include<cstdio> #include<cstring> #include<string> #include<algo

poj3134 Command Network --- 最小树形图

新单词unidirectional get T T 求有向图上,以某点为根的,最小生成树 参考别人的模板 #include<cstdio> #include<cstring> #include<vector> #include<queue> #include<iostream> #include<algorithm> #include<cmath> #define inf 2000000000 using namespac

POJ 3164 Command Network 最小树形图-朱刘算法裸题

题目来源:POJ 3164 Command Network 题意:求以1为根的最小树形图 没有输出字符串 思路:直接高朱刘算法 不懂的可以百度 学会了就是直接套模板的事情 其实就是不断消圈而已 不构成圈就有解 无法从根到达其他点就无解 #include <cstdio> #include <cstring> #include <cmath> const int maxn = 110; const int maxm = 50010; const double INF =

【POJ3164】Command Network 最小树形图模板题 重修版

链接: #include <stdio.h> int main() { puts("转载请注明出处[vmurder]谢谢"); puts("网址:blog.csdn.net/vmurder/article/details/44935891"); } 我以前的版本 算法构造过程以及傻叉代码+弱版注释见以前博客 http://blog.csdn.net/vmurder/article/details/38819711 最小树形图: 名词解释: 其实就是有向图

POJ 3164 Command Network(最小树形图)

Command Network Time Limit: 1000MS   Memory Limit: 131072K Total Submissions: 13817   Accepted: 3973 Description After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent a

POJ 3164 Command Network (最小树形图-朱刘算法)

题目地址:POJ 3164 最小树形图第一发. 把一个v写成u了.....TLE了一晚上...(虽说今晚出去玩了..) 刚开始看这个算法的时看模板以为又是一个isap....吓得一个哆嗦.但是仔细看了看之后发现还是挺好理解的.写下自己的理解. 朱刘算法其实只有3步,然后不断循环. 1:找到每个点的最小入边.既然是生成树,那么对于每个点来说,只要选一个权值最小的入边就可以了.贪心思想.因为如果不是最小入边,那么它肯定不是最小树形图的一条边,考虑它是没有意义的. 2:找环.找环找的是最小入边构成的新

POJ3164 Command Network【最小树形图】【朱刘算法】

Command Network Time Limit: 1000MS Memory Limit: 131072K Total Submissions: 13398 Accepted: 3868 Description After a long lasting war on words, a war on arms finally breaks out between littleken's and KnuthOcean's kingdoms. A sudden and violent assau

POJ - 3164-Command Network 最小树形图——朱刘算法

POJ - 3164 题意: 一个有向图,存在从某个点为根的,可以到达所有点的一个最小生成树,则它就是最小树形图. 题目就是求这个最小的树形图. 参考资料:https://blog.csdn.net/txl199106/article/details/62045479 #include <iostream> #include <cstdio> #include <algorithm> #include <cstring> #include <strin