周赛 POJ 2245 Lotto


Description

In the German Lotto you have to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn‘t increase your chance of winning - is to select a subset S containing k (k > 6) of these 49 numbers, and then play several games
with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34].

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.

Input

The input will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will
follow in ascending order. Input will be terminated by a value of zero (0) for k.

Output

For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted
by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.

Sample Input

7 1 2 3 4 5 6 7
8 1 2 3 5 8 13 21 34
0

Sample Output

1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7

1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34

Source

Ulm Local 1996

简单的DFS。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
using namespace std;
int num[15],a[15],k;
int visit[15];
void dfs(int l,int s)
{
    if(s==6)
    {
        for(int i=0;i<6;i++)
            printf(i==5?"%d\n":"%d ",num[i]);
    }
    for(int i=l;i<k;i++)
    {
        if(!visit[i])
        {
            visit[i]=1;
            num[s]=a[i];
            dfs(i,s+1);
            visit[i]=0;
        }
    }
}
int main()
{
    while(cin>>k&&k)
    {
        for(int i=0;i<k;i++)
            cin>>a[i];
        for(int i=0;i<=k-6;i++)
        {
            memset(visit,0,sizeof(visit));
            visit[i]=1;
            num[0]=a[i];
            dfs(i+1,1);
        }
            cout<<endl;

    }
    return 0;
}

周赛 POJ 2245 Lotto

时间: 2024-08-05 17:57:44

周赛 POJ 2245 Lotto的相关文章

POJ 2245 Lotto

Lotto Description In the German Lotto you have to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k > 6) of these 49 numbers, a

hdu1342 &amp;&amp; poj 2245 Lotto

Lotto Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 1755    Accepted Submission(s): 860 Problem Description In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49

POJ 2245 Lotto dfs

给出最多13个数,从中选出6个数(升序) 给出所有方案(升序输出) DFS水题 #include <cstring> #include <cstdio> #include <algorithm> using namespace std; const int N = 10; const int M = 16; int ans[N]; int a[M]; int n; void dfs(int id, int pre){ if(id == 6) { for(int i =

周赛 POJ 2250 Compromise

Description In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germa

周赛 POJ 3934 Queue

Description Linda is a teacher in ACM kindergarten. She is in charge of n kids. Because the dinning hall is a little bit far away from the classroom, those n kids have to walk in line to the dinning hall every day. When they are walking in line, if a

周赛 POJ 3546 The Dragon of Loowater

Description Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem. The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese populati

POJ 题目2245 Lotto(DFS水)

Lotto Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 6549   Accepted: 4153 Description In the German Lotto you have to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chan

poj 2245

Lotto Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 6375   Accepted: 4050 Description In the German Lotto you have to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chan

poj 2245 水题

求组合数,dfs即可 1 #include<cstdio> 2 #include<iostream> 3 #include<algorithm> 4 #include<cstring> 5 #include<cmath> 6 #include<queue> 7 using namespace std; 8 int N,m,t; 9 int a[15],vis[15]; 10 void dfs(int st,int n) 11 { 12