hdoj-1505-City Game【动态规划】1506的加强版

1506的加强版

City Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5587 Accepted Submission(s): 2412

Problem Description

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in
the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the
biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you‘re building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied
units are marked with the symbol F.

Input

The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000
and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.

Output

For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output

45
0

Source

Southeastern Europe 2004

Recommend

zl | We have carefully selected several similar problems for you:
1506 2870 1058 2830 2159

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
char map[1100][1100];
int dp[1100][1100];
int r[1100],l[1100];
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n,m,i,j;
		char s;
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;++i){
			for(j=1;j<=m;++j){
				while(scanf("%c",&s),!(s>='R'||s=='F'));
				map[i][j]=s;
			}
		}
		memset(dp,0,sizeof(dp)) ;
		//for(i=0;i<=n;++i) map[i][0]='R';
		//for(j=0;j<=m;++j) map[0][j]='R';
		for(i=1;i<=n;++i){
			for(j=1;j<=m;++j){
				if(map[i][j]=='F'){
					dp[i][j]=dp[i-1][j]+1;
				}
				else dp[i][j]=0;
			}
		}
		int maxn=0;
        for(i=1;i<=n;++i){
        	r[m+1]=0;l[0]=0;
        	dp[i][0]=-1;dp[i][m+1]=-1;
        	for(j=1;j<=m;++j){
        		l[j]=j;
        		while(dp[i][l[j]-1]>=dp[i][j])
        		l[j]=l[l[j]-1];
        	}
        	for(j=m;j>=1;--j){
        		r[j]=j;
        		while(dp[i][r[j]+1]>=dp[i][j])
        		r[j]=r[r[j]+1];
        	}
        	for(j=1;j<=m;++j){
        		maxn=max(maxn,(r[j]-l[j]+1)*dp[i][j]);
        	}
        }
        printf("%d\n",maxn*3);
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-12 21:02:29

hdoj-1505-City Game【动态规划】1506的加强版的相关文章

hdu 1505 City Game (动态规划)

City Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4838    Accepted Submission(s): 2071 Problem Description Bob is a strategy game programming specialist. In his new city building game t

HDU 1505 City Game (hdu1506 dp二维加强版)

F - City Game Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1505 Appoint description: Description Bob is a strategy game programming specialist. In his new city building game the gaming enviro

hdu 1505 City Game (hdu1506加强版)

# include <stdio.h> # include <algorithm> # include <string.h> # include <iostream> using namespace std; char a[1010][1010]; int dd[1010][1010];///宽度 int r[1010],l[1010]; int main() { int t,i,j,n,m,max1; while(~scanf("%d"

HDU - 1505 City Game(dp)

题意:求由R和F组成的矩阵中,最大的由F组成的矩阵面积. 分析: 1.hdu1506http://www.cnblogs.com/tyty-Somnuspoppy/p/7341431.html与此题相似. 2.将矩阵的每行看成1506中的坐标轴分别处理. 3.算出以该行为坐标轴,坐标轴上,每个由F组成的矩形的高度,与1506的区别是,1506中每个矩形高度已知. 4.按照1506的方法分别算出每个矩形最左边和最右边连续比其高的矩形的下标,通过(r[i][j] - l[i][j] + 1) * h

hdu 1505 City Game 最大矩形面积 单调队列

City Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5106    Accepted Submission(s): 2197 Problem Description Bob is a strategy game programming specialist. In his new city building game t

HDU 1505 City Game(01矩阵 dp)

Problem Description Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space i

hdu 1505 City Game(hdu1506的二维推广)

1.输入的时候数据的时候要注意 2.1506的二维推广 代码: #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int INF=1<<30; int a[1005][1005]; int L[1005]; int R[1005]; int main() { int t; int m,n; int ans; char s[10]; scanf(&

HDU 1505 City Game【DP】

题意:是二维的1506,即在1506的基础上,再加一个for循环,即从第一行到最后一行再扫一遍--- 自己写的时候,输入的方法不对---发现输不出结果,后来看了别人的[email protected][email protected]发现是将字母和空格当成一个字符串来输入的. #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> using namespace st

HDU 1505 City Game-dp-(最大子矩阵模型)

题意:求最大的子矩阵 分析:直接用最大字矩阵的公式做超时了.换个思路,这题跟上一题1506有关系,先以每层为底算出每个元素能到达的最大的高度,然后就跟1506一样了.这里求高度和求面积两处地方用到了dp暂存数据.求高度用二重循环,然后每层为底求面积要二重循环加上外层就是三重循环,但是由于用了dp保存中间结果,所以这个三重循环不会超时.dp[j]表示当前层第j列能到达的最大的高度,状态转移:1.a[i][j]=='R'时,dp[j]=0:2.否则,若a[i-1][j]=='F',则dp[j]++(