poj1942--Paths on a Grid(组合篇4)

Paths on a Grid

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 22336   Accepted: 5483

Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he‘s explaining that (a+b)2=a2+2ab+b2).
So you decide to waste your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let‘s call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner,
taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:

Really a masterpiece, isn‘t it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension.
Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit
to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4
1 1
0 0

Sample Output

126
2

Source

题目大意:问从左下角走到右上角的方法数,只能向上或向右。

对于一条路径来说,一共有n+m部分,n个向上的,m个向右的,所以只要找出在这n+m个部分中,n或m的分布方式,就可以得到总数。

也就是结果就是C(n+m,m) ;

数据范围中的32位无符号整数。。。。sad。。就当是空气吧。。。。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
#define LL __int64
LL c[200][200] ;
//void init()
//{
//    int i , j ;
//    memset(c,0,sizeof(c)) ;
//    for(i = 1 ; i < 200 ; i++)
//    {
//        c[i][0] = 1 ;
//        for(j = 1 ; j < i ; j++)
//            c[i][j] = c[i-1][j-1] + c[i-1][j] ;
//        c[i][j] = 1 ;
//    }
//    return ;
//}

//LL dfs(LL n,LL m)
//{
//    if( n == m || m == 0 || n == 0 ) return 1 ;
//    return dfs(n-1,m-1)+dfs(n-1,m) ;
//}

LL solve(LL n,LL m)
{
    double ans = 1.0 ;
    while( m )
    {
        ans *= (n*1.0)/m ;
        n-- ;
        m-- ;
    }
    LL k = ans + 0.5 ;
    return k ;
}
int main()
{
    LL n , m , x , y ;
    //init() ;
    while( scanf("%I64d %I64d", &n, &m) != EOF )
    {
        if( n == 0 && m == 0 ) break ;
        x = min(n,m) ;
        printf("%I64d\n", solve(n+m,x) );
    }
    return 0;
}
时间: 2024-11-09 03:01:47

poj1942--Paths on a Grid(组合篇4)的相关文章

poj1942 Paths on a Grid 【排列组合】

关于这个题想说一下,刚开始准备按照有一个含有n个数的非递减序列,每个数最大值为m,数字可以重复,有多少种这样的序列,像是一个蛮复杂的排列组合 其实这道题,从left bottom到right up只能向右或者向上,也就是m+n个格子里面取m个格子写右,n个格子写上,就成了个很2的排列组合问题 值得强调的是,这个题求组合数是用分数相乘来求的,怕double丢精度可以末尾+0.5然后转化为longlong来进行四舍五入 这个题int好像过不了 说个蛮逗比的...最近不是写了个交题的脚本么,本来是一水

poj1942(Paths on a Grid)

题目地址:Paths on a Grid 题目大意: 给你一个矩形的格子,让你从左下角走到右上角,每次移动只能向上或者向右,问你有多少种可能的路径. 解题思路: 水题,排列组合.推出公式C(m+n,较小的那个数) 代码: 1 #include <algorithm> 2 #include <iostream> 3 #include <sstream> 4 #include <cstdlib> 5 #include <cstring> 6 #inc

POJ1942——Paths on a Grid(组合数学)

Paths on a Grid DescriptionImagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2). So you decide to waste

[ACM] POJ 1942 Paths on a Grid (组合)

Paths on a Grid Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 21297   Accepted: 5212 Description Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastere

Paths on a Grid(规律)

Paths on a Grid Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 23270   Accepted: 5735 Description Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastere

POJ 1942 Paths on a Grid(简单组合数学)

Paths on a Grid Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 22836   Accepted: 5622 Description Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastere

关于grid++report篇

QQ:1187362408 欢迎技术交流和学习 关于grid++report篇(grid++report): 问题: 读入报表模板失败,请检查网络连接,URL及读取选项错误提示:网络服务器响应不成功, 221<发布:6061端口>:报表不能显示[请检查网络连接,URL及读取权限] TODO: 1,iis管理控制台(MMC),右键单击本地计算机名称,然后单击属性 2,添加mime类型名称 3,添加扩展名名称和扩展名类型名称(value,name) 4,应用新设置,重启iis服务

Paths on a Grid POJ 1942 (组合数学 || 暴力)

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b) 2=a 2+2ab+b 2). So you decide to waste your time with drawing

POJ 1942 Paths on a Grid (组合数学)

题目地址:POJ 1942 这题就是求组合数c(n,n+m),高中的时候做过这种组合题,现在居然推不出来了..sad...时光催人老.... 代码如下: #include <iostream> #include <string.h> #include <math.h> #include <queue> #include <algorithm> #include <stdlib.h> #include <map> #incl