题目地址:?http://acm.nyist.net/JudgeOnline/problem.php?pid=41?
?
描述
现在要写一个程序,实现给三个数排序的功能
输入
输入三个正整数
输出
给输入的三个正整数排序
样例输入
20 7 33
样例输出
7 20 33
?
代码:
#include <stdio.h>
static void swap(int *left,int *right);
int main()
{
???? int a=0,b=0,c=0;
???? scanf("%d %d %d",&a,&b,&c);
????
???? if(a>b)
???? {
????????? swap(&a,&b);
???? }
????
???? if(a>c)
???? {
????????? swap(&a,&c);
???? }
????
???? if(b>c)
???? {
????????? swap(&b,&c);
???? }
????
???? printf("%d %d %d\n",a,b,c);
????
???? return 0;
}
static void swap(int *left,int *right)
{
???? int tmp = *left;
???? *left = *right;
???? *right = tmp;
}
?
练手题。
?
?
?
时间: 2024-10-27 19:31:44