南阳acm-97-兄弟郊游问题(水题)

兄弟郊游问题

时间限制:3000 ms  |  内存限制:65535 KB

难度:2

描述
兄弟俩骑车郊游,弟弟先出发,每分钟X米,M分钟后,哥哥带一条狗出发。以每分钟Y米的速度去追弟弟,而狗则以每分钟Z米的速度向弟弟跑去,追上弟弟后又立即返回,直到哥哥追上弟弟时,狗跑了多少米?
输入
第一行输入一个整数N,表示测试数据的组数(N<100)
每组测试数据占一行,是四个正整数,分别为M,X,Y,Z(数据保证X<Y<Z)
输出
输出狗跑的路径,结果保留小数点后两位。
样例输入
1
5 10 15 20
样例输出
200.00

解题:

#include<stdio.h>
int main()
{
int N;
scanf("%d",&N);
while(N--)
{
float s,M,X,Y,Z,x;
scanf("%f %f %f %f",&M,&X,&Y,&Z);
x=X*M/(Y-X);
s=x*Z;
printf("%.2f\n",s);
}

}

时间: 2024-11-06 11:43:59

南阳acm-97-兄弟郊游问题(水题)的相关文章

2015南阳CCPC L - Huatuo&#39;s Medicine 水题

L - Huatuo's Medicine Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Huatuo was a famous doctor. He use identical bottles to carry the medicine. There are different types of medicine. Huatuo put medicines into the bottles and chain these b

HDU ACM 1017 A Mathematical Curiosity 水题

分析:水题,但要注意格式. #include<iostream> using namespace std; int core(int n,int m) { int i,j,ans=0; for(i=1;i<n;i++) for(j=i+1;j<n;j++) if((i*i+j*j+m)%(i*j)==0) ans++; return ans; } int main() { int T,t,n,m; bool fg=false; scanf("%d",&T

HDU ACM 1073 Online Judge -&gt;字符串水题

分析:水题. #include<iostream> using namespace std; #define N 5050 char a[N],b[N],tmp[N]; void Read(char p[]) { getchar(); gets(tmp); while(gets(tmp)) { if(strcmp(tmp,"END")==0) break; if(strlen(tmp)!=0) strcat(p,tmp); strcat(p,"\n");

NYOJ题目97兄弟郊游问题

--------------------------- 这种问题就是列方程,然后求解就可以了. 哥哥追上弟弟的时间: (弟弟先跑的路程/哥哥比弟弟快出来的速度) (哥哥追上弟弟的时间*狗的速度) AC代码: 1 import java.util.Scanner; 2 3 public class Main { 4 5 public static void main(String[] args) { 6 7 Scanner sc=new Scanner(System.in); 8 9 int ti

南阳acm-206-矩形的个数(水题)

矩形的个数 时间限制:1000 ms  |  内存限制:65535 KB 难度:1 描述 在一个3*2的矩形中,可以找到6个1*1的矩形,4个2*1的矩形3个1*2的矩形,2个2*2的矩形,2个3*1的矩形和1个3*2的矩形,总共18个矩形. 给出A,B,计算可以从中找到多少个矩形. 输入 本题有多组输入数据(<10000),你必须处理到EOF为止 输入2个整数A,B(1<=A,B<=1000) 输出 输出找到的矩形数.  样例输入 1 2 3 2 样例输出 3 18 AC代码: #in

2015南阳CCPC A - Secrete Master Plan 水题

D. Duff in Beach Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, w

[ACM] ZOJ 3819 Average Score (水题)

Average Score Time Limit: 2 Seconds      Memory Limit: 65536 KB Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis. After a mid-term exam, Bob was anxious about his

HDU ACM 5224 Tom and paper 水题+暴力枚举

分析:因为长和宽都是整数,所以枚举判断是不是整数,再取最小的即可. #include<iostream> #include<cmath> using namespace std; int main() { int min; int a,i,T; ios::sync_with_stdio(false); cin>>T; while(T--) { cin>>a; min=1000000000; for(i=1;i<=sqrt(a);i++) if(a%i=

ytu 2558: 游起来吧!超妹!(水题,趣味数学题)

2558: 游起来吧!超妹!Time Limit: 1 Sec  Memory Limit: 128 MBSubmit: 7  Solved: 3[Submit][Status][Web Board] Description 夏天到了,无聊的超妹跑到了落雪湖里抓鱼吃.结果,游到湖的正中 央时被湖边保安看到了,保安要抓住超妹.我们假设落雪湖是一个半径为r的圆形,超妹在圆形的正中心,速度为1.保安由于不会游泳所以只能沿着湖的边缘奔 跑,速度为n.因为超妹在陆地上的速度是很快的,所以我们假设只要超妹到

字符串解密--水题

传纸条 Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^ 题目描述 传纸条是一种在课堂上传递信息的老方法,虽然现在手机短信和QQ聊天越来越普及,但是手写的信息会让人感到一种亲切感.对许多学生而言,在学校里传递一些私秘性的信息是一种令人兴奋的打发时光的方式,特别是在一些令人厌烦的课堂上. XX 和 YY 经常在自习课的时候传纸条来传递一些私密性的信息.但是他们的座位相隔比较远,传纸条要通过其他人才能到达对方.在传递过程中,难免会有一些好奇心