HDU 1312 Red and Black (BFS)

Red and Black

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u

Submit Status

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move
only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile

‘#‘ - a red tile

‘@‘ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

 6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#[email protected]#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
[email protected]
###.###
..#.#..
..#.#..
0 0 

Sample Output

 45
59
6
13 

题目大意:

问最多能走‘.’多少步,‘#’是墙,不能走。

解题思路:

BFS.

代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>

using namespace std;

const int maxN=25;
int dirI[4]={1,0,-1,0},n,m,is,js;;
int dirJ[4]={0,1,0,-1},visited[maxN][maxN];
string str[maxN];

struct node{
    int i,j;
    node(int i0=0,int j0=0){
    i=i0,j=j0;
    }
};

void bfs(){
    queue <node> path;
    visited[is][js]=1;
    path.push(node(is,js));
    int cnt=1;
    while(!path.empty()){
        node s=path.front();
        path.pop();
        for(int i=0;i<4;i++){
            int di=s.i+dirI[i],dj=s.j+dirJ[i];
            if(di<0||dj<0||di>=n||dj>=m||str[di][dj]=='#') continue;
            if(visited[di][dj]==1) continue;
            visited[di][dj]=1;
            path.push(node(di,dj));
            cnt++;
        }
    }
    printf("%d\n",cnt);
}

int main(){
    while(scanf("%d%d",&m,&n)!=EOF&&n&&m){
        memset(visited,-1,sizeof(visited));
        for(int i=0;i<n;i++){
            cin>>str[i];
            for(int j=0;j<m;j++){
                if(str[i][j]=='@'){
                    is=i,js=j;
                }
            }
        }
        bfs();
    }
    return 0;
}
时间: 2024-11-06 14:01:57

HDU 1312 Red and Black (BFS)的相关文章

HDU 1312 Red and Black(bfs)

Red and Black Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, h

hdu 1312 Red and Black(BFS水题)

Red and Black Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9684    Accepted Submission(s): 6021 Problem Description There is a rectangular room, covered with square tiles. Each tile is colore

HDU 1312 Red and Black(bfs,dfs均可,个人倾向bfs)

题目代号:HDU 1312 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1312 Red and Black Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 20820    Accepted Submission(s): 12673 Problem Description There i

HDU 1312 Red and Black (dfs)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1312 Red and Black Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 17773    Accepted Submission(s): 10826 Problem Description There is a rectangula

HDU 1180——诡异的楼梯( BFS)

诡异的楼梯 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others) Total Submission(s): 8717    Accepted Submission(s): 2148 Problem Description Hogwarts正式开学以后,Harry发现在Hogwarts里,某些楼梯并不是静止不动的,相反,他们每隔一分钟就变动一次方向. 比如下面的例子里,一开始楼梯在竖

HDU 1312:Red and Black(DFS搜索)

HDU 1312:Red and Black Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From

Red and Black (BFS)poj 1979

Red and Black Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 26181   Accepted: 14213 Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a

hdu 1312 Red and Black(深搜)

Red and Black Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10286    Accepted Submission(s): 6426 Problem Description There is a rectangular room, covered with square tiles. Each tile is colo

杭电 HDU 1312 Red and Black(超级简单dfs)

Red and Black Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12907    Accepted Submission(s): 7983 Problem Description There is a rectangular room, covered with square tiles. Each tile is colo