hdu1020Encoding

Problem Description

Given a string containing only ‘A‘ - ‘Z‘, we could encode it using the following method:
1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, ‘1‘ should be ignored.

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A‘ - ‘Z‘ and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2
ABC
ABBCCC

Sample Output

ABC
A2B3C

Author

ZHANG Zheng

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>

using namespace std;

char s[1100000];

int main()
{
    int z;
    cin>>z;
    getchar();
    while(z--)
    {
        int i,j,k,l;
        gets(s);
        l = strlen(s);
        int t = 1;
        for(i = 1;i<=l;i++)
        {
            if(s[i]!=s[i-1])
            {
                if(t!=1) printf("%d",t);
                putchar(s[i-1]);
                t = 1;
            }
            else t++;
        }
        puts("");
    }
    return 0;
}
时间: 2024-10-06 19:49:09

hdu1020Encoding的相关文章

HDU-1020-Encoding(Java &amp;&amp; 弱水三千)

Encoding Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 31603    Accepted Submission(s): 14020 Problem Description Given a string containing only 'A' - 'Z', we could encode it using the follow