Hdoj 1064 Financial Management

题目描述

Problem Description

Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42

Source

Mid-Atlantic USA 2001

解题思路

其实就是求平均值啦....

Code

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cctype>
#include<cstring>
#include<cstdlib>
using namespace std;
int main()
{
    double ans,a,t;
    int n=12;
    while(n--)
    {
        cin>>t;
        ans+=t;
    }
    printf("$%.2lf\n",ans/12);
    return 0;
}

原文地址:https://www.cnblogs.com/MartinLwx/p/9570747.html

时间: 2024-08-12 18:04:25

Hdoj 1064 Financial Management的相关文章

1064 Financial Management

http://acm.hdu.edu.cn/showproblem.php?pid=1064 思路:看懂英文就很简单,就是12个数相加求平均数就ok了. 扩展: C++ 标准输入输出流的控制符 1 #include<stdio.h> 2 #include<iostream> 3 #include<string> 4 #include<iomanip> 5 using namespace std; 6 7 int main() { 8 double array

HDU 1064 Financial Management

很简单 附代码 1 #include <iostream> 2 #include <cstdio> 3 using namespace std; 4 5 6 int main() 7 { 8 double a=0; 9 double sum=0; 10 //freopen("C:\\CODE\\in.txt", "r", stdin); 11 12 for(int i=0;i<12;i++){ 13 scanf("%lf&qu

(HDU)1064 --Financial Management( 财务管理)

题目链接:http://vjudge.net/problem/HDU-1064 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 using namespace std; 5 6 int main() 7 { 8 int i; 9 double a,sum=0.0; 10 for(i=1;i<=12;i++) 11 { 12 scanf("%lf",&a);

UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Management

Regionals 2001 >> North America - Mid-Atlantic USA 问题链接:UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Management. 题意简述:输入12个数,计算其平均值. 编写程序时,考虑到C++处理输入比较方便,所以使用C++语言编程.然而,输出需要指定格式是还是C语言方便,所以就用函数printf()来处理输出. AC的C语言程序如下: /* UVALive2362 POJ1004 HDU106

[POJ] Financial Management

Financial Management Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 182193   Accepted: 68783 Description Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has deci

UVA 11945 Financial Management 水题

Financial Management Time Limit: 1 Sec  Memory Limit: 256 MB 题目连接 acm.hust.edu.cn/vjudge/problem/visitOriginUrl.action?id=20184 Description Michael graduated of ITESO this year and finally has a job. He's making a lot of money, but somehow never seem

UVA11945 Financial Management

问题链接:UVA11945 Financial Management. 题意简述:输入12个数,计算其平均值. 编写程序时,考虑到C++处理输入比较方便,所以使用C++语言编程.然而,输出稍微麻烦一些,对于金额,每3位需要加一个逗号,而C和C++的函数库中,没有相应的解决办法. 程序中专门编写函数output_result()处理输出,使用的是有限状态自动机的工作方式来处理的. 这个问题与UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Manageme

POJ 1004 Financial Management 水

 Financial Management Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 165700   Accepted: 61629 Description Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has d

HDU1064 Financial Management 【water】

Financial Management Time Limit: 400/200 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9188    Accepted Submission(s): 5747 Problem Description Larry graduated this year and finally has a job. He's making a lot of