POJ-3522 Slim Span(最小生成树)

Slim Span

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 8633   Accepted: 4608

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (VE), where V is a set of vertices {v1v2, …, vn} and E is a set of undirected edges {e1e2, …, em}. Each edge e ∈ E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.


Figure 5: A graph G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1v2v3v4} and five undirected edges {e1e2e3e4e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).


Figure 6: Examples of the spanning trees of G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees TbTc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

n m  
a1 b1 w1
  ?  
am bm wm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ekwk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (VE) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50

Source

Japan 2007

题目大意:条件给你n个点,m条边,求n-1条边图连通的情况下最大边与最小边的差的最小值。

解题思路:根据条件先建图,然后按边排序,直接枚举,从第x小的边开始建树,(此处需要注意每次从x小的边开始建立一棵树后直接x++进行下次简树,因为已经按边排序好了,每次得到的肯定是x情况下差最小的情况),没有太多技巧,枚举+建树就行了。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=105;
int f[10002];
int n,m;
struct Edge
{
    int u,v,w;
};
Edge edge[100000];

bool cmp(Edge a,Edge b)
{
    return a.w<b.w;
}

int Find(int x)
{
    int r = x;
    while(r!=f[r])
    {
        r = f[r];
    }
    while(x!=f[x])
    {
        int j = f[x];
        f[x] = f[r];
        x = j;
    }
    return x;
}

void merge2(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx!=fy)
    {
        f[fy] = fx;
    }
}

int Cal(int x)
{
    int i;
    for(i=1;i<=n;i++)
    {
        f[i] = i;
    }
    int mind=INF,maxd=-1;
    int cnt=0;
    for(i=x;i<m;i++)
    {
        int u=edge[i].u , v=edge[i].v , w=edge[i].w;
        int fu=Find(u),fv=Find(v);
        if(fu!=fv)
        {
            f[fu] = fv;
            cnt++;
            mind = min(mind,w);
            maxd = max(maxd,w);
            merge2(u,v);
        }
        if(cnt==n-1)
            break;
    }
    if(cnt == n-1)
    {
        int ans = maxd-mind;
        return ans;
    }
    return -1;
}

int main()
{
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
        {
            break;
        }
        int i,a,b,w;
        for(i=0;i<m;i++)
        {
            scanf("%d %d %d",&a,&b,&w);
            edge[i].u=a;
            edge[i].v=b;
            edge[i].w=w;
        }
        sort(edge,edge+m,cmp);
        int ans=INF;
        for(i=0;i<m;i++)
        {
            if(m-i<n-1)
            {
                break;
            }
            int d = Cal(i);
            if(d!=-1 && d<ans)
            {
                ans = d;
            }
        }
        if(ans == INF)
            printf("-1\n");
        else
            printf("%d\n",ans);
    }
}
时间: 2024-11-10 07:50:59

POJ-3522 Slim Span(最小生成树)的相关文章

POJ 3522 Slim Span 最小生成树,暴力 难度:0

kruskal思想,排序后暴力枚举从任意边开始能够组成的最小生成树 #include <cstdio> #include <algorithm> using namespace std; const int maxn = 101; const int maxe = maxn * maxn / 2; struct edge{ int f,t,c; bool operator <(edge e2)const { return c<e2.c; } }e[maxe]; int

POJ 3522 Slim Span(最小生成树)

题意:给定一个n个点m条边的无向图,找一颗苗条度(最大边减最小边)最小的生成树. 思路:假设苗条度最小的这棵树的最小边为a,若要使苗条度最小,答案一定是以a为最小边的一颗最小生成树,所以可以考虑枚举最小边,计算出苗条度并更新答案. #include<cstdio> #include<cstring> #include<cmath> #include<cstdlib> #include<iostream> #include<algorithm

poj 3522 Slim Span 最大边减最小边最小的生成树

枚举最小边进行kruskal. #include <cstdio> #include <algorithm> using namespace std; #define maxn 120 #define maxm 10000 struct edge { int u,v,w; }e[maxm]; int p[maxn],n,m; int find(int x) { if(x==p[x]) return x; return p[x]=find(p[x]); } void link(int

POJ 3522 ——Slim Span——————【最小生成树、最大边与最小边最小】

Slim Span Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 7102   Accepted: 3761 Description Given an undirected weighted graph G, you should find one of spanning trees specified as follows. The graph G is an ordered pair (V, E), where V 

POJ 3522 Slim Span【枚举+克鲁斯卡尔求最小生成树】

Slim Span Time Limit: 5000MS Memory Limit: 65536K Total Submissions: 7365 Accepted: 3909 Description Given an undirected weighted graph G, you should find one of spanning trees specified as follows. The graph G is an ordered pair (V, E), where V is a

POJ 3522 Slim Span (Kruskal +枚举 边权差最小的生成树)

Slim Span Time Limit: 5000MS Memory Limit: 65536K Total Submissions: 6685 Accepted: 3544 Description Given an undirected weighted graph G, you should find one of spanning trees specified as follows. The graph G is an ordered pair (V, E), where V is a

uva 1395 - Slim Span poj 3522 Slim Span(最小生成树算法)

最近学习了一下 最小生成树 算法. 所谓最小生成树算法,就是给出一个连通图g[ maxn ][ maxn  ], 找出这个连通图的边权和最小的生成图(树). 可以实现这个目的的算法,我叫它最小生成树算法.kruskal算法就是我学到的一种实现这种功能的算法. 对于kruskal算法的描述以及简单的证明在刘汝佳第二版上已经说得够明白 本题就是求 最小生成树 里面的 最大边权和最小边权 相差最小的最小生成树. #include<cstdio> #include<cstring> #in

UVA 1359 POJ 3522 Slim Span(最小生成树kruskal)

Given an undirected weighted graph G, you should find one of spanning trees specified as follows. The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge e ∈ E 

(极差最小生成树)POJ 3522 - Slim Span

题意: 给定一张无向图,求出一个最长边减最短边最小的生成树. 分析: 这题之前做过一模一样的(应该是...),跑kruskal算法,维护一个subset,一旦出现了环,就删除这条环上最轻的边,不断更新subset,subset中存当前生成树的边,一旦边的个数m=点数n-1,就更新ans. 这个复杂度是O(m*n).但是在这里样例都过不去,应该是写搓了...鲁棒性不够. 还有一个解法是用动态树link-cut-tree,可以再把复杂度降成O(m*logn).但是我还不会.. 这题因为点的数量只有1

UVa1395 &amp;&amp; POJ 3522 Slim Span

UVa POJ Description 求苗条度最小的生成树 苗条度指该生成树的最大边 - 最小边 Algorithm Kruskal变形 先sort 然后枚举最小边 构建最小生成树 Hint UVa JAVA的RE 不知道为何= = POJ的JAVA才1.5 λ表达式是JAVA 1.8才有的 然后本人才疏学浅 除了λ表达式以外不会写自定义sort比较 所以CE = = C++就过了 会了C++ 的INF写法 #include <climits> 这样就有 INT_MAX这个常量了 Code