PAT 1036 Boys vs Girls[简单]

1036 Boys vs Girls (25 分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student‘s namegenderID and grade, separated by a space, where nameand ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade?F???grade?M??. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

题目大意:给出m个女孩和男孩的名字课程分数信息,求女孩中分数最高与男孩中分数最低的。

//这道题真的老简单了。。。一次过。。都不想写博客来着。。

#include <iostream>
#include <algorithm>
#include <vector>
#include<cstdio>
using namespace std;

int main()
{
    int n;
    cin>>n;
    string name,s,task;
    int sco;
    string fn,mn;//最终的名字
    string ft,mt;//最终的科目
    int fs=-1,ms=101;//最终的得分。
    for(int i=0;i<n;i++){
        cin>>name>>s>>task>>sco;
        if(s=="F"&&sco>fs){
            fn=name;
            ft=task;
            fs=sco;
        }else if(s=="M"&&sco<ms){
            mn=name;
            mt=task;
            ms=sco;
        }
    }
    if(fs==-1){//如果没有女性
        cout<<"Absent\n";
    }else {
        cout<<fn<<" "<<ft<<"\n";
    }
    if(ms==101){
        cout<<"Absent\n";
    }else{
        cout<<mn<<" "<<mt<<"\n";
    }
    if(fs==-1||ms==101){
        cout<<"NA";
    }else{
        cout<<fs-ms;
    }

    return 0;
}

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9912284.html

时间: 2024-11-10 02:03:39

PAT 1036 Boys vs Girls[简单]的相关文章

PAT 1036. Boys vs Girls (25)

1036. Boys vs Girls (25) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contain

PAT 1036 Boys vs Girls (25 分)

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai

PAT 1036 Boys vs Girls

#include <cstdio> #include <iostream> #include <cstdlib> #include <algorithm> using namespace std; class Stu { public: char name[12]; char id[12]; int grade; char gender; }; bool my_cmp(const Stu* a, const Stu* b) { return a->gr

PAT 甲级 1036 Boys vs Girls (25 分)(简单题)

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai

1036. Boys vs Girls (25)

1036. Boys vs Girls (25) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contain

1036 Boys vs Girls (25 分)

1036 Boys vs Girls (25 分) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contai

PAT (Advanced Level) 1036. Boys vs Girls (25)

简单题. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<map> #include<queue> #include<vector> using namespace std; const int maxn=100000; struct X { string nam

PAT甲题题解-1036. Boys vs Girls (25)-找最大最小,大水题

题意:给出n个人的姓名.性别.ID.分数,让你找出其中哪个妹纸分数最高.哪个汉子分数最低.以及他们的差如果没有妹纸或者汉子,则对应输出Absent,差用NA代替. 就是for一遍找最大最小值,水题 #include <iostream> #include <cstdio> #include <algorithm> #include <string.h> #include <cmath> #include <vector> #defin

PTA(Advanced Level)1036.Boys vs Girls

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students. Input Specification: Each input file contains one test case. Each case contains a positive integer N, f