Round
and Round We Go
Time
Limit: 2000/1000 MS (Java/Others) Memory Limit:
65536/32768 K (Java/Others) Total Submission(s):
623 Accepted Submission(s): 343
Problem Description
A cyclic number is an integer n digits in length which,
when multiplied by any integer from 1 to n, yields a ~{!0~}cycle~{!1~} of the
digits of the original number. That is, if you consider the number after the
last digit to ~{!0~}wrap around~{!1~} back to the first digit, the sequence of
digits in both numbers will be the same, though they may start at different
positions.
For example, the number 142857 is cyclic, as illustrated by the
following table:
142857*1=142857
142857*2=285714
142857*3=428571
142857*4=571428
142857*5=714285
142857*6=857142
Write
a program which will determine whether or not numbers are cyclic. The input file
is a list of integers from 2 to 60 digits in length. (Note that preceding zeros
should not be removed, they are considered part of the number and count in
determining n. Thus, ~{!0~}01~{!1~} is a two-digit number, distinct from
~{!0~}1~{!1~} which is a one-digit number.)
Output
For each input integer, write a line in the output
indicating whether or not it is cyclic.
Sample Input
142857 142856
142858 01 0588235294117647
Sample Output
142857 is cyclic
142856 is not cyclic 142858 is not cyclic 01 is not cyclic 0588235294117647 is
cyclic
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <map>
using namespace std;
const int maxn=500;
const int base=1000000;
const int INF=99999999;
const int MIN=-INF;
int main()
{
int n,m,i,j,k,t;
char a[maxn],a1[maxn];
while(cin>>a)
{
strcpy(a1,a);//做一个备份
int lena=strlen(a);
int b[maxn];
for(i=0;i<lena;i++)
b[i]=a[i]-‘0‘;
int ok=1;
for(i=1;i<=lena;i++)
{
int c=0;
for(j=lena-1;j>=0;j--)//大数乘法
{
k=b[j]*i+c;
b[j]=k%10;
c=k/10;
}
sort(b,b+lena);
// for(k=0;k<lena;k++)
//cout<<b[k];cout<<endl;
sort(a,a+lena);
//cout<<a<<endl;
for(k=0;k<lena;k++)
if(b[k]!=a[k]-‘0‘){ok=0;break;}if
(ok==0)break;
//再次初始化
for(k=0;k<lena;k++)
b[k]=a1[k]-‘0‘;
}
if(ok==0)
printf("%s is not cyclic\n",a1);
else
printf("%s is cyclic\n",a1);
}
return 0;
}
杭电1313