杭电1313

Round
and Round We Go


Time
Limit: 2000/1000 MS (Java/Others)    Memory Limit:
65536/32768 K (Java/Others) Total Submission(s):
623    Accepted Submission(s): 343

Problem Description

A cyclic number is an integer n digits in length which,
when multiplied by any integer from 1 to n, yields a ~{!0~}cycle~{!1~} of the
digits of the original number. That is, if you consider the number after the
last digit to ~{!0~}wrap around~{!1~} back to the first digit, the sequence of
digits in both numbers will be the same, though they may start at different
positions.
For example, the number 142857 is cyclic, as illustrated by the
following table: 
142857*1=142857
142857*2=285714
142857*3=428571
142857*4=571428
142857*5=714285
142857*6=857142
Write
a program which will determine whether or not numbers are cyclic. The input file
is a list of integers from 2 to 60 digits in length. (Note that preceding zeros
should not be removed, they are considered part of the number and count in
determining n. Thus, ~{!0~}01~{!1~} is a two-digit number, distinct from
~{!0~}1~{!1~} which is a one-digit number.)

Output

For each input integer, write a line in the output
indicating whether or not it is cyclic.

Sample Input

142857 142856
142858 01 0588235294117647

Sample Output

142857 is cyclic
142856 is not cyclic 142858 is not cyclic 01 is not cyclic 0588235294117647 is
cyclic



#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <map>
using namespace std;
const
int maxn=500;
const
int base=1000000;
const
int INF=99999999;
const
int MIN=-INF;
int
main()
{

int
n,m,i,j,k,t;
char
a[maxn],a1[maxn];
while
(cin>>a)
{

strcpy(a1,a);//做一个备份
int lena=strlen(a);
int
b[maxn];
for
(i=0;i<lena;i++)
b[i]=a[i]-‘0‘;
int
ok=1;
for
(i=1;i<=lena;i++)
{

int
c=0;
for
(j=lena-1;j>=0;j--)//大数乘法
{

k=b[j]*i+c;
b[j]=k%10;
c=k/10;
}

sort(b,b+lena);
// for(k=0;k<lena;k++)
//cout<<b[k];cout<<endl;
sort(a,a+lena);
//cout<<a<<endl;
for(k=0;k<lena;k++)
if
(b[k]!=a[k]-‘0‘){ok=0;break;}

if(ok==0)break;
//再次初始化
for
(k=0;k<lena;k++)
b[k]=a1[k]-‘0‘;
}

if
(ok==0)
printf("%s is not cyclic\n",a1);
else

printf("%s is cyclic\n",a1);
}

return
0;
}

杭电1313

时间: 2024-10-11 04:48:03

杭电1313的相关文章

杭电ACM分类

杭电ACM分类: 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDIATE DECODABILITY

【转】对于杭电OJ题目的分类

[好像博客园不能直接转载,所以我复制过来了..] 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDI

杭电 HDU 1164 Eddy&#39;s research I

Eddy's research I Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7117    Accepted Submission(s): 4268 Problem Description Eddy's interest is very extensive, recently  he is interested in prime

hdu 1016 Prime Ring Problem DFS解法 纪念我在杭电的第一百题

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 29577    Accepted Submission(s): 13188 Problem Description A ring is compose of n circles as shown in diagram. Put natural num

一个人的旅行 HDU杭电2066【dijkstra算法】

http://acm.hdu.edu.cn/showproblem.php?pid=2066 Problem Description 虽然草儿是个路痴(就是在杭电待了一年多,居然还会在校园里迷路的人,汗~),但是草儿仍然很喜欢旅行,因为在旅途中 会遇见很多人(白马王子,^0^),很多事,还能丰富自己的阅历,还可以看美丽的风景--草儿想去很多地方,她想要去东京铁塔看夜景,去威尼斯看电影,去阳明山上看海芋,去纽约纯粹看雪景,去巴黎喝咖啡写信,去北京探望孟姜女--眼看寒假就快到了,这么一大段时间,可不

杭电1162--Eddy&#39;s picture(Prim()算法)

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8070    Accepted Submission(s): 4084 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to b

杭电1276--士兵队列训练问题

士兵队列训练问题 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4605    Accepted Submission(s): 2148 Problem Description 某部队进行新兵队列训练,将新兵从一开始按顺序依次编号,并排成一行横队,训练的规则如下:从头开始一至二报数,凡报到二的出列,剩下的向小序号方向靠拢,再从头开始进行

杭电1272 并查集找环+判断连通

杭电1272 并查集找环+判断连通 E - E Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1272 Description 上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走.但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B

杭电ACM Java实现样例

若使用Java求解杭电ACM,答案提交必须注意两点: 1.类名一定得是Main,否则服务器无法编译: 2.必须用while进行输入判断. 以1000题测试题为例,代码如下: import java.util.Scanner; public class Main { public static void main(String[] args) { Scanner scan=new Scanner(System.in); while(scan.hasNextInt()) { int a=scan.n