PAT 1004

1004. Counting Leaves (30)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID‘s of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

解析:通过给你每一个家庭成员的孩子关系,叫你列出每一层的叶子节点的数目,也就是说列出同一辈份没有子女的成员的个数。

Codes:
/*************************************************************************
    > File Name: 1004.cpp
    > Author:
    > Mail:
    > Created Time: 2015年12月08日 星期二 13时14分33秒
 ************************************************************************/

#include<iostream>
#include<queue>
#include<vector>
#include<string>
#include<map>
using namespace std;

struct node{
    string id;
    vector<node*> children;
    node(string x){
        id = x;
    }
};

int main(){
    int n,m;
    cin>>n>>m;
    if(m == 0){
        cout<<n;
        return 0;
    }

    // map store nodes
    map<string, node*> cache;

    string id;
    int k;
    while(m--){
        cin>>id>>k;
        if(cache.count(id) <= 0){
            cache[id] = new node(id);
        }
        string idi;
        int index = 0;
        while(k--){
            cin>>idi;
            node *tmp = NULL;
            if(cache.count(idi) <= 0){
                tmp = new node(idi);
                cache[idi] = tmp;
            }
            else{
                tmp = cache[idi];
            }
            cache[id]->children.push_back(tmp);
            index++;
        }
    }

    string rootid = "01";
    queue<node*> qu;
    qu.push(cache[rootid]);
    while(!qu.empty()){
        int nums = 0;
        int size = qu.size();
        for(int i=0; i<size; i++){
            node *tmp2 = qu.front();
            qu.pop();
            if(tmp2->children.size() == 0){
                nums++;
            }
            else{
                for(int i=0; i<tmp2->children.size(); i++){
                    qu.push(tmp2->children[i]);
                }
            }
        }

        cout<<nums;
        if(!qu.empty()){
            cout<<" ";
        }
    }

    return 0;
}

注:一开始总是有segmentation fault,就仔细得检查,后面才发现原来是没有考虑m=0的情况,也就是说,所有的家庭成员都是同一辈份的人员,所以就只有一层,输出n即可。

时间: 2024-11-03 22:04:57

PAT 1004的相关文章

PAT 1004. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree.  Your job is to count those family members who have no child. Input Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tre

PAT 1004 To Fill or Not to Fill (25)

题目描写叙述 With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are

PAT 1004. Counting Leaves (30) C#实现

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child. Input Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree

PAT 1004. 成绩排名 (20) JAVA

读入n名学生的姓名.学号.成绩,分别输出成绩最高和成绩最低学生的姓名和学号. 输入格式:每个测试输入包含1个测试用例,格式为 第1行:正整数n 第2行:第1个学生的姓名 学号 成绩 第3行:第2个学生的姓名 学号 成绩 ... ... ... 第n+1行:第n个学生的姓名 学号 成绩 其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的. 输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低

pat 1004. 成绩排名 (20)

读入n名学生的姓名.学号.成绩,分别输出成绩最高和成绩最低学生的姓名和学号. 输入格式:每个测试输入包含1个测试用例,格式为 第1行:正整数n 第2行:第1个学生的姓名 学号 成绩 第3行:第2个学生的姓名 学号 成绩 ... ... ... 第n+1行:第n个学生的姓名 学号 成绩 其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的. 输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低

PAT 1004 Counting Leaves(结构体)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child. Input Specification: Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of node

pat 1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child. Input Specification: Each input file contains one test case. Each case starts with a line containing 0, the number of nodes in a

PAT 1004 成绩排名

读入 n(>)名学生的姓名.学号.成绩,分别输出成绩最高和成绩最低学生的姓名和学号. 输入格式: 每个测试输入包含 1 个测试用例,格式为 第 1 行:正整数 n 第 2 行:第 1 个学生的姓名 学号 成绩 第 3 行:第 2 个学生的姓名 学号 成绩 ... ... ... 第 n+1 行:第 n 个学生的姓名 学号 成绩 其中姓名和学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的. 输出格式: 对每个测试用例输

3.PAT 1004 成绩排名

题目: 读入 n(>)名学生的姓名.学号.成绩,分别输出成绩最高和成绩最低学生的姓名和学号. 输入格式: 每个测试输入包含 1 个测试用例,格式为 第 1 行:正整数 n 第 2 行:第 1 个学生的姓名 学号 成绩 第 3 行:第 2 个学生的姓名 学号 成绩 ... ... ... 第 n+1 行:第 n 个学生的姓名 学号 成绩 其中姓名和学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的. 输出格式: 对每个测