POJ 3279 Fliptile (二进制枚举+模拟)

Fliptile

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 3992   Accepted: 1518

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an
M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face
up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they
have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical
ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:
M and N

Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with
N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains
N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source

USACO 2007 Open Silver

题目链接:http://poj.org/problem?id=3279

题目大意:给一个m * n的0 1矩阵,1表示开灯,0表示关灯,按其中一个按钮,则其自身及上下左右都变成相反的状态,现在问最少需要按几次能把所有的灯都关上,若不可能输出IMPOSSIBLE,若多种情况,输出答案字典序最小的

题目分析:对于同一个点,最多操作一次,因为两次的话等于是重复操作,当一行的状态确定了,则其下面的状态全部可以递推出来,因此我们只需要枚举第一行的所有状态,然后推出全部的状态,只要最后一行都为0,则说明有解,我们只需要取解的最小值就行了

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 16;
int const INF = 0x3fffffff;

int a[MAX][MAX], b[MAX][MAX];
int tmp[MAX][MAX], ans[MAX][MAX];
int m, n, cnt;

int ok(int st)
{
    for(int i = 0; i < n; i++)
    {
        if((st & (1 << i)))
        {
            tmp[0][i] = 1;
            cnt ++;
            b[0][i] ^= 1;
            if(i + 1 < n)
                b[0][i + 1] ^= 1;
            if(i - 1 >= 0)
                b[0][i - 1] ^= 1;
            if(m > 1)
                b[1][i] ^= 1;
        }
    }
    for(int i = 1; i < m; i++)
    {
        for(int j = 0; j < n; j++)
        {
            if(b[i - 1][j])
            {
                tmp[i][j] = 1;
                b[i - 1][j] = 0;
                cnt ++;
                b[i][j] ^= 1;
                if(i + 1 < m)
                    b[i + 1][j] ^= 1;
                if(j + 1 < n)
                    b[i][j + 1] ^= 1;
                if(j - 1 >= 0)
                    b[i][j - 1] ^= 1;
            }
        }
    }
    for(int i = 0; i < n; i++)
        if(b[m - 1][i])
            return INF;
    return cnt;
}

int main()
{
    int mi = INF;
    bool flag = false;
    memset(a, 0, sizeof(a));
    memset(b, 0, sizeof(b));
    memset(ans, 0, sizeof(ans));
    scanf("%d %d", &m, &n);
    for(int i = 0; i < m; i++)
        for(int j = 0; j < n; j++)
            scanf("%d", &a[i][j]);
    for(int i = 0; i < (1 << n); i++)
    {
        cnt = 0;
        memset(tmp, 0, sizeof(tmp));
        memcpy(b, a, sizeof(a));
        int get = ok(i);
        if(get != INF)
        {
            flag = true;
            if(get < mi)
            {
                mi = get;
                memset(ans, 0, sizeof(ans));
                memcpy(ans, tmp, sizeof(tmp));
            }
        }
    }
    if(flag)
    {
        for(int i = 0; i < m; i++)
        {
            for(int j = 0; j < n - 1; j++)
                printf("%d ", ans[i][j]);
            printf("%d\n", ans[i][n - 1]);
        }
    }
    else
        printf("IMPOSSIBLE\n");
}
时间: 2024-08-04 23:00:47

POJ 3279 Fliptile (二进制枚举+模拟)的相关文章

poj 3279 Fliptile(二进制)

http://poj.org/problem?id=3279 在n*N的矩阵上,0代表白色,1代表黑色,每次选取一个点可以其颜色换过来,即白色变成黑色,黑色变成白色,而且其上下左右的点颜色也要交换,求最少交换多少点能把全部换成颜色0 输出所需要换的点,用1表示,如果有多种方案,输出字典序足最小的方案 但是这题的数据里没有字典序的情况,所以没有比较字典序也可以过,我一开始就不知道这个怎么按字典序排 用二进制枚举第一行所有的情况,第一行的情况确定了,下面的就确定了 1 #include<cstdio

poj 3279 Fliptile(二进制暴力)

Fliptile Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 3629   Accepted: 1400 Description Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which

Poj 3279 Fliptile 【枚举】

Fliptile Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 4161 Accepted: 1585 Description Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which the

状态压缩+枚举 POJ 3279 Fliptile

题目传送门 1 /* 2 题意:问最少翻转几次使得棋子都变白,输出翻转的位置 3 状态压缩+枚举:和之前UVA_11464差不多,枚举第一行,可以从上一行的状态知道当前是否必须翻转 4 */ 5 #include <cstdio> 6 #include <cstring> 7 #include <algorithm> 8 using namespace std; 9 10 const int MAXN = 20; 11 const int INF = 0x3f3f3f3

POJ 3279(Fliptile)题解

以防万一,题目原文和链接均附在文末.那么先是题目分析: [一句话题意] 给定长宽的黑白棋棋盘摆满棋子,每次操作可以反转一个位置和其上下左右共五个位置的棋子的颜色,求要使用最少翻转次数将所有棋子反转为黑色所需翻转的是哪些棋子(这句话好长...). [题目分析] 盯着奇怪的题目看了半天发现和奶牛没什么卵关系..奶牛智商高了产奶高是什么鬼说法... 这题刚开始被放到搜索的分类下了..然而这和搜索有什么关系..没经验所以想了各种和搜索沾边的方法,结果没想出解法,直到看了网上的题解,压根不是搜索啊有木有.

CUGBACM_Summer_Tranning1 二进制枚举+模拟+离散化

整体感觉:这个组队赛收获还挺多的.自从期末考试以后已经有一个多月没有 做过组队赛了吧,可是这暑假第一次组队赛就找回了曾经的感觉.还挺不错的!继续努力!! 改进的地方:这次组队赛開始的时候题目比較难读懂,然后就感觉题目应该比較难吧,认为应该是区域赛难度的题目.尽管A题和B题自己都感觉能自己A的.可是可能对自己不太自信,所以让队友大帝敲了.要是当时自己敢敲一下的话,后续会更快的A掉吧. A题:二进制枚举 题目链接:https://icpcarchive.ecs.baylor.edu/external

【POJ 3279 Fliptile】开关问题,模拟

题目链接:http://poj.org/problem?id=3279 题意:给定一个n*m的坐标方格,每个位置为黑色或白色.现有如下翻转规则:每翻转一个位置的颜色,与其四连通的位置都会被翻转,但注意只扩散一圈,不是连锁反应. 求最少翻转几个位置能够使所有n*m个位置都变为白色.若有解,求字典序最小的翻转方案(给出每个位置的翻转次数). 数据范围:n, m 属于 [1, 15] 思路:我们把翻转方案中的翻转称为“主动翻转”,翻转过程中受邻居影响而发生的翻转称为“被动翻转”.观察例子可得出如下几个

POJ 3279 Fliptile (二进制+搜索)

[题目链接]click here~~ [题目大意]: 农夫约翰知道聪明的牛产奶多.于是为了提高牛的智商他准备了如下游戏.有一个M×N 的格子,每个格子可以翻转正反面,它们一面是黑色,另一面是白色.黑色的格子翻转后就是白色,白色的格子翻转过来则是黑色.游戏要做的就是把所有的格子都翻转成白色.不过因为牛蹄很大,所以每次翻转一个格子时,与它上下左右相邻接的格子也会被翻转.因为翻格子太麻烦了,所以牛都想通过尽可能少的次数把所有格子都翻成白色.现在给定了每个格子的颜色,请求出用最小步数完成时每个格子翻转的

(简单) POJ 3279 Fliptile,集合枚举。

Description Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is co