POJ2431 Expedition

Expedition

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7349   Accepted: 2179

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck‘s fuel tank. The truck now leaks one unit of fuel every unit of distance
it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows
can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that
there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply
up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

USACO 2005 U S Open Gold

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>

#define maxn 10010

struct Node {
	int pos, val;
} A[maxn];

bool cmp(Node a, Node b) {
	return a.pos > b.pos;
}

int main() {
	// freopen("stdin.txt", "r", stdin);
	int N, L, P, i, cnt;
	while(scanf("%d", &N) == 1) {
		for(i = 0; i < N; ++i)
			scanf("%d%d", &A[i].pos, &A[i].val);
		scanf("%d%d", &L, &P);
		std::sort(A, A + N, cmp);

		std::priority_queue<int> pq;
		cnt = i = 0;

		while(i < N && P >= L - A[i].pos)
			pq.push(A[i++].val);
		while(P < L && !pq.empty()) {
			++cnt;
			P += pq.top(); pq.pop();
			while(i < N && P >= L - A[i].pos)
				pq.push(A[i++].val);
		}

		if(P < L) cnt = -1;
		printf("%d\n", cnt);
	}
	return 0;
}

无语的WA:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>

#define maxn 10010

struct Node {
	int pos, val;
} A[maxn];

bool cmp(Node a, Node b) {
	return a.pos > b.pos;
}

int main() {
	// freopen("stdin.txt", "r", stdin);
	int N, L, P, i, cnt;
	while(scanf("%d", &N) == 1) {
		for(i = 0; i < N; ++i)
			scanf("%d%d", &A[i].pos, &A[i].val);
		scanf("%d%d", &L, &P);
		std::sort(A, A + N, cmp);

		std::priority_queue<int> pq;
		cnt = 0;

		for(i = 0; P < L && i < N; ++i) {
			if(L - A[i].pos <= P) {
				pq.push(A[i].val);
			} else if(!pq.empty()) {
				P += pq.top(); pq.pop();
				++cnt; --i;
			} else break;
		}
		// int k = 0;
		// while(k < N && L - A[k].pos <= P)
		// 	pq.push(A[k++].val);
		// while(P < L && !pq.empty()){
		// 	++cnt;
		// 	P += pq.top(); pq.pop();
		// 	while(k < N && L - A[k].pos <= P)
		// 		pq.push(A[k++].val);
		// }

		if(P < L) cnt = -1;
		printf("%d\n", cnt);
	}
	return 0;
}
时间: 2024-08-09 19:18:07

POJ2431 Expedition的相关文章

poj2431 Expedition优先队列

Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel ever

poj2431 Expedition (优先队列) 挑战程序设计竞赛

题目链接:http://poj.org/problem?id=2431 Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9148   Accepted: 2673 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor driver

POJ2431 Expedition(排序+优先队列)

思路:先把加油站按升序排列. 在经过加油站时,往优先队列里加入B[i].(每经过一个加油站时,预存储一下油量) 当油箱空时:1.如果队列为空(可以理解成预存储的油量),则无法到达下一个加油站,更无法到达目的地. 2.否则就取出队列里的最大元素,来给汽车加油(贪心思想) #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> #include<queue>

POJ2431 Expedition (优先队列)

题目链接: http://poj.org/problem?id=2431 题意: 一条路上有n个加油站,终点离起点的距离为L,然n个加油站离终点的距离为a[i],每个加油站可以给汽车加b[i]的油, 问最少加多少次可以到达终点,不能到达终点输出-1. 分析: 要想最少我们肯定是在马上要没有的时候加油,然后每次加的应该是最多的油. 因此我们走过第i个加油站的时候,把b[i]放入优先队列里,然后不能到达的时候 每次取出一个直到可以到达当前的位置,如果队列为空而且还不能动到达当前 位置则永远不可达.

【POJ2431】Expedition

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8434   Accepted: 2474 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to

H - Expedition 优先队列 贪心

来源poj2431 A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every

【POJ - 2431】Expedition(优先队列)

Expedition 直接中文 Descriptions 一群奶牛抓起一辆卡车,冒险进入丛林深处的探险队.作为相当差的司机,不幸的是,奶牛设法跑过一块岩石并刺破卡车的油箱.卡车现在每运行一个单位的距离泄漏一个燃料单位. 为了修理卡车,奶牛需要沿着一条蜿蜒的长路行驶到最近的城镇(距离不超过1,000,000个单位).在这条路上,在城镇和卡车的当前位置之间,有N(1 <= N <= 10,000)燃料站,奶牛可以停下来获得额外的燃料(每站1..100个单位). 丛林对人类来说是一个危险的地方,对奶

poj2431优先队列

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of di

POJ 2431 Expedition(探险)

Time Limit: 1000MS   Memory Limit: 65536K [Description] [题目描述] A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's f