win7中用MinGW编译x264出现"No working C compiler found."错误

Description

Given a n × n matrix A and a positive integer k, find the sum S = A + A2 + A3 + … + Ak.

Input

The input contains exactly one test case. The first line of input contains three positive integers n (n ≤ 30), k (k ≤ 109) and m (m < 104). Then follow n lines each containing n nonnegative
integers below 32,768, giving A’s elements in row-major order.

Output

Output the elements of S modulo m in the same way as A is given.

Sample Input

2 2 4
0 1
1 1

Sample Output

1 2
2 3
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

struct mat
{
    int t[65][65];
    void set()
    {
        memset(t,0,sizeof(t));
    }
} a,b;

mat multiple(mat a,mat b,int n,int p)
{
    int i,j,k;
    mat temp;
    temp.set();
    for(i=0; i<n; i++)
        for(j=0; j<n; j++)
        {
            if(a.t[i][j]>0)
                for(k=0; k<n; k++)
                    temp.t[i][k]=(temp.t[i][k]+a.t[i][j]*b.t[j][k])%p;
        }
    return temp;
}

mat quick_mod(mat b,int n,int m,int p)
{
    mat t;
    t.set();
    for(int i=0;i<n;i++) t.t[i][i]=1;
    while(m)
    {
        if(m&1)
        {
            t=multiple(t,b,n,p);
        }
        m>>=1;
        b=multiple(b,b,n,p);
    }
    return t;
}
void init(int n,int m,int p)
{
    a.set();
    b.set();
    for(int i=0;i<n;i++)
    for(int j=0;j<n;j++)
    {
        scanf("%d",&b.t[i][j]);
        b.t[i][j+n]=b.t[i][j];
        a.t[i][j]=b.t[i][j];
    }
    for(int i=n;i<2*n;i++)
    for(int j=n;j<2*n;j++)
    if(i==j) b.t[i][j]=1;

    for(int i=n;i<2*n;i++)
    for(int j=0;j<n;j++)
    if(j+n==i) a.t[i][j]=1;

    b=quick_mod(b,2*n,m-1,p);

    mat temp;
    temp.set();
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
        {
                for(int k=0; k<2*n; k++)
                    temp.t[i][j]=(temp.t[i][j]+b.t[i][k]*a.t[k][j])%p;   //错误一点,无限WA
        }
   for(int i=0;i<n;i++)
   {
       for(int j=0;j<n;j++)
       printf("%d ",temp.t[i][j]);
       puts("");
   }
}
int main()
{
    int n,m,p;
    while(cin>>n>>m>>p)
    {
        init(n,m,p);
    }
    return 0;
}

win7中用MinGW编译x264出现"No working C compiler found."错误,布布扣,bubuko.com

时间: 2024-10-11 22:39:45

win7中用MinGW编译x264出现"No working C compiler found."错误的相关文章

[X264] MinGW编译x264,VC中调用libx264.dll-------------&lt;参考转&gt;

1. 下载并按照MinGW,最好就缺省按照    http://sourceforge.net/projects/ ... ler/mingw-get-inst/    把C:\MinGW\bin添加到PATH中 (dos命令行 PATH %PATH%;新目录;)2. 下载nasm,    http://www.nasm.us/pub/nasm/releasebuilds/    解压后把nasm.exe拷贝到C:\MinGW\bin中3. 下载最新的x264    http://www.vid

在Windows中使用MinGW编译X264

转自:http://www.cnblogs.com/xiongjiaji/archive/2012/06/08/2541265.html 参考:http://ayobamiadewole.com/Blog/Others/x264compilation.aspx 注意:安装完MinGW后,要把“安装路径\MinGW\bin”加到PATH环境变量中.否则在./configure的时候会“No working C compiler found”. 具体步骤如下: For someone coming

MinGW和MSYS区别和关系以及MinGW&amp;MSYS在Win7中安装并编译x264

1 简介   MinGW,是Minimalist GNUfor Windows的缩写.它是一个可自由使用和自由发布的Windows特定头文件和使用GNU工具集导入库的集合,允许你在GNU/Linux和Windows平台生成本地的Windows程序而不需要第三方C运行时(C Runtime)库.MinGW 是一组包含文件和端口库,其功能是允许控制台模式的程序使用微软的标准C运行时(C Runtime)库(MSVCRT.DLL),该库在所有的 NT OS 上有效,在所有的 Windows 95发行版

手把手教你在Windows下使用MinGW编译libav(参考libx264的编入)

转自:http://www.th7.cn/Program/cp/201407/242762.shtml 手把手教你在Windows下使用MinGW编译libav libav是在Linux下使用纯c语言开发的,不可避免的,libav源码使用了一些gcc的特性,那么在Windows下很难使用VC编译,但是使用MinGW编译却简单多了,下面我将根据自己的经历逐步介绍使用MinGW编译libav的过程以及在此过程中遇到的问题及其解决方法. 1      安装MinGW编译环境 1.1    安装MinG

mingw编译ffmpeg+x265过程记录

mingw编译ffmpeg+x265过程记录 email: [email protected] 工作环境 OS:windows 7 1.相关资源下载 Ffmpeg-2.3     http://ffmpeg.org/releases/ffmpeg-2.3.3.tar.bz2 X265-1.3下载  https://bitbucket.org/multicoreware/x265/wiki/Home http://ffmpeg.zeranoe.com/builds/source/external_

Mesa10.2在Win7上的编译

Mesa10仍然支持Windwos/linux,但是编译方式已经不提供makefile或者workspace Building on windows requires several open-source packages. These aresteps that work as of this writing. - install python 2.7- install scons (latest)- install mingw, flex, and bison- install pywin

专题:Windows编译x264、SDL、faac、ffmpeg过程

Windows上编译ffmpeg完整过程,包括编译x264.SDL.faac.在Windows上编译ffmpeg需要用MinGW+msys,本专题用于记录编译过程中遇到的各种问题及解决方法,转载请注明出处: 一.下载准备 准备编译过程所需的工具和源码. (1). MinGW http://sourceforge.net/projects/mingw/files/  MSYS http://downloads.sourceforge.net/mingw/MSYS-1.0.11.exe (2). Y

在windows下编译x264

最近因为各种原因,对流媒体的学习,突然中断在了编码这块.今天难得静下心来,从新拿起了代码. 对encode这边,因为之前虽然也接触了,也找了两个例子,但目前还没真正开始,所以先从编译x264这个库开始吧. 找到之前下载的x264源码库(x264-snapshot-20130922-2245),然后将源码复制到D:\msys\1.0\home\x264-20130922目录下. 接着按照网上的教程,首先运行MINGW,然后切换到X264源码路径下: 再然后输入: $ ./configure --e

MingW编译virt-viewer

在http://www.spice-space.org/download.html可以下载到windows版本的virt viewer virt-viewer-x86-0.5.7.msi和virt-viewer-x64-0.5.7.msi是使用MingW编译出来的,源码就是使用virt-viewer-0.5.7.tar.gz 如果需要定制virt viewer,就需要从源码编译出可执行的二进制码,本文就是描述编译windows版virt viewer的过程. MinGW 在使用MinGw编译vi