HDU1202 The calculation of GPA

The calculation of GPA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19000    Accepted Submission(s): 4391

Problem Description

每学期的期末,大家都会忙于计算自己的平均成绩,这个成绩对于评奖学金是直接有关的。国外大学都是计算GPA(grade point average) 又称GPR(grade point ratio),即成绩点数与学分的加权平均值来代表一个学生的成绩的。那么如何来计算GPA呢?

一般大学采用之计分法

A90 - 100 4 点

B80 - 89 3 点

C70 - 79 2 点

D60 - 69 1 点

E0 - 59 0 点

例如:某位学生修习三门课,其课目、学分及成绩分别为:

英文:三学分、92 分;化学:五学分、80 分;数学:二学分、60分,则GPA的算法如下:

科目 学分 分数 点数 分数×点数

英文  3    92    4     12

化学  5    80    3     15

数学  2    60    1      2

合计  10   29

29/10=2.9

2.9即为某生的GPA

下面有请你写一个用于计算GPA的程序。

Input

包含多组数据,每组数据的第一行有一个数N,接下来N行每行表示一门成绩。每行有两个实型的数 s,p,s表示这门课的学分,p表示该学生的成绩(百分制)。如果p=-1则说明该学生这门课缺考,是不应该计算在内的。

Output

对每组数据输出一行,表示该学生的GPA,保留两位小数。如果GPA不存在,输出-1。

Sample Input

3
3 92
5 80
2 60

Sample Output

2.90

water

#include <stdio.h>

double f(double p)
{
    if(p >= 90) return 4;
    if(p >= 80) return 3;
    if(p >= 70) return 2;
    if(p >= 60) return 1;
    return 0;
}

int main()
{
    int n;
    double s, p, sums, sump;
    while(scanf("%d", &n) != EOF){
        sums = sump = 0;
        while(n--){
            scanf("%lf%lf", &s, &p);
            if(p < 0) continue;
            sums += s; sump += f(p) * s;
        }
        if(sump <= 0) printf("-1\n");
        else printf("%.2lf\n", sump / sums);
    }
    return 0;
}

HDU1202 The calculation of GPA

时间: 2024-10-06 02:09:51

HDU1202 The calculation of GPA的相关文章

1411052107-hd-The calculation of GPA

 The calculation of GPA Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 19932    Accepted Submission(s): 4576 Problem Description 每学期的期末,大家都会忙于计算自己的平均成绩,这个成绩对于评奖学金是直接有关的.国外大学都是计算GPA(grade poi

HDU-1202-The calculation of GPA(恶心水题)

The calculation of GPA Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21967    Accepted Submission(s): 5046 Problem Description 每学期的期末,大家都会忙于计算自己的平均成绩,这个成绩对于评奖学金是直接有关的.国外大学都是计算GPA(grade point

杭电 HDU 1202 The calculation of GPA

The calculation of GPA Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21897    Accepted Submission(s): 5028 Problem Description 每学期的期末,大家都会忙于计算自己的平均成绩,这个成绩对于评奖学金是直接有关的.国外大学都是计算GPA(grade point

hdu 1202The calculation of GPA (简单题+坑)

The calculation of GPA Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 18748    Accepted Submission(s): 4331 Problem Description 每学期的期末,大家都会忙于计算自己的平均成绩,这个成绩对于评奖学金是直接有关的.国外大学都是计算GPA(grade point a

The calculation of GPA

Problem Description 每学期的期末,大家都会忙于计算自己的平均成绩,这个成绩对于评奖学金是直接有关的.国外大学都是计算GPA(grade point average) 又称GPR(grade point ratio),即成绩点数与学分的加权平均值来代表一个学生的成绩的.那么如何来计算GPA呢? 一般大学采用之计分法 A90 - 100 4 点 B80 - 89 3 点 C70 - 79 2 点 D60 - 69 1 点 E0 - 59 0 点 例如:某位学生修习三门课,其课目.

HDOJ 1202 The calculation of GPA

[思路]:模拟. [注意]:题目要求的是实型.并且题目有没说清楚的地方,全部缺考和学分*点数为0这两种情况都算GPA不存在! 参考:http://blog.csdn.net/liuzhushiqiang/article/details/8603798 [AC代码]: #include <iostream> #include <cstdlib> #include <cstdio> #include <cstring> #include <algorith

(HDU)1202 -- The calculation of GPA (计算GPA)

题目:http://vjudge.net/problem/HDU-1202 分析:这题好坑爹啊,80 - 89 4点,让人情不自禁设置成80<=i<=89,那么89.5算不算呢?还有就是全部缺考的情况也需要考虑,除法要有意义. 1 #include <cstdio> 2 #include <cstring> 3 #include <cmath> 4 #include <iostream> 5 #include <algorithm>

hdu 1202 The calculation of GPA

#include <stdio.h> int f(double x) { if(x>=90)return 4; else if(x>=80)return 3; else if(x>=70)return 2; else if(x>=60)return 1; else return 0; } int main(void) { int n;double cj,zjd,xf,zxf; while(scanf("%d",&n)!=EOF) { zxf=

题解报告:hdu1202The calculation of GPA

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1202 水题!!!数据类型要用对,WA了三次 AC代码: #include<bits/stdc++.h> using namespace std; int main() { int N; double s,p,sp,st;//要用double,不然老wa while(cin>>N){ st=sp=0; while(N--){ cin>>s>>p; if(p==-1