BZOJ 1024 [SCOI2009]生日快乐 (搜索)

1024: [SCOI2009]生日快乐

Time Limit: 1 Sec  Memory Limit: 162 MB
Submit: 3025  Solved: 2201
[Submit][Status][Discuss]

Description

  windy的生日到了,为了庆祝生日,他的朋友们帮他买了一个边长分别为 X 和 Y 的矩形蛋糕。现在包括windy
,一共有 N 个人来分这块大蛋糕,要求每个人必须获得相同面积的蛋糕。windy主刀,每一切只能平行于一块蛋糕
的一边(任意一边),并且必须把这块蛋糕切成两块。这样,要切成 N 块蛋糕,windy必须切 N-1 次。为了使得
每块蛋糕看起来漂亮,我们要求 N块蛋糕的长边与短边的比值的最大值最小。你能帮助windy求出这个比值么?

Input

  包含三个整数,X Y N。1 <= X,Y <= 10000 ; 1 <= N <= 10

Output

  包含一个浮点数,保留6位小数。

Sample Input

5 5 5

Sample Output

1.800000

HINT

Source

析:竟然是一个搜索题,我都想成二分。。。,但是没想到有什么好的办法来实现判定。

搜索,对每次切的位置都搜索,因为 n 比较小,所以是完全可以的。

代码如下:

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include <string>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <cstring>
#include <set>
#include <queue>
#include <algorithm>
#include <vector>
#include <map>
#include <cctype>
#include <cmath>
#include <stack>
#include <sstream>
#include <list>
#include <assert.h>
#include <bitset>
#include <numeric>
#define debug() puts("++++")
#define gcd(a, b) __gcd(a, b)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define fi first
#define se second
#define pb push_back
#define sqr(x) ((x)*(x))
#define ms(a,b) memset(a, b, sizeof a)
#define sz size()
#define pu push_up
#define pd push_down
#define cl clear()
//#define all 1,n,1
#define FOR(i,x,n)  for(int i = (x); i < (n); ++i)
#define freopenr freopen("in.txt", "r", stdin)
#define freopenw freopen("out.txt", "w", stdout)
using namespace std;

typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int, int> P;
const int INF = 0x3f3f3f3f;
const LL LNF = 1e17;
const double inf = 1e20;
const double PI = acos(-1.0);
const double eps = 1e-8;
const int maxn = 400 + 10;
const int maxm = 3e5 + 10;
const ULL mod = 3;
const int dr[] = {-1, 0, 1, 0};
const int dc[] = {0, -1, 0, 1};
const char *de[] = {"0000", "0001", "0010", "0011", "0100", "0101", "0110", "0111", "1000", "1001", "1010", "1011", "1100", "1101", "1110", "1111"};
int n, m;
const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
inline bool is_in(int r, int c) {
  return r >= 0 && r < n && c >= 0 && c < m;
}

double dfs(double r, double c, int n){
  if(n == 1)  return max(r, c) / min(r, c);
  double rx = r / n, cx = c / n;
  double ans = inf;
  for(int i = 1; i <= n / 2; ++i){
    ans = min(ans, max(dfs(rx * i, c, i), dfs(r - rx * i, c, n - i)));
    ans = min(ans, max(dfs(r, cx * i, i), dfs(r, c - cx * i, n - i)));
  }
  return ans;
}

int main(){
  int K;
  scanf("%d %d %d", &n, &m, &K);
  printf("%.6f\n", dfs(n, m, K));
  return 0;
}

  

时间: 2024-11-03 00:22:11

BZOJ 1024 [SCOI2009]生日快乐 (搜索)的相关文章

BZOJ 1024: [SCOI2009]生日快乐 dfs

1024: [SCOI2009]生日快乐 Time Limit: 20 Sec Memory Limit: 256 MB 题目连接 http://www.lydsy.com/JudgeOnline/problem.php?id=1024 Description windy的生日到了,为了庆祝生日,他的朋友们帮他买了一个边长分别为 X 和 Y 的矩形蛋糕.现在包括windy,一共有 N 个人来分这块大蛋糕,要求每个人必须获得相同面积的蛋糕. windy主刀,每一切只能平行于一块蛋糕的一边(任意一边

bzoj 1024 SCOI2009 生日快乐

一上来没思路…… 但是由于每块蛋糕面积相等,又因为每次切必须切成两半,所以每半的面积都是每块蛋糕面积的倍数. 枚举切下来的蛋糕应该还被分为多少块蛋糕,计算切割的地方,分X 和 Y, 递归搜索. 上代码: #include <cstdio> #include <cstring> #include <cstdlib> #include <iostream> #include <algorithm> #include <cmath> #de

[BZOJ 1024][SCOI2009]生日快乐(DFS)

Description windy的生日到了,为了庆祝生日,他的朋友们帮他买了一个边长分别为 X 和 Y 的矩形蛋糕.现在包括windy ,一共有 N 个人来分这块大蛋糕,要求每个人必须获得相同面积的蛋糕.windy主刀,每一切只能平行于一块蛋糕 的一边(任意一边),并且必须把这块蛋糕切成两块.这样,要切成 N 块蛋糕,windy必须切 N-1 次.为了使得 每块蛋糕看起来漂亮,我们要求 N块蛋糕的长边与短边的比值的最大值最小.你能帮助windy求出这个比值么? Solution 爆搜可过 #i

1024: [SCOI2009]生日快乐——爆搜

http://www.lydsy.com/JudgeOnline/problem.php?id=1024 对于一个矩形要么横着切,要么竖着切,对于竖着切的时候,枚举左半矩形的块数,横着也一样. #include <iostream> #include <cstring> #include <cstdio> #include <algorithm> const int maxn = 11000; const double INF = 0x3f3f3f3f; u

[BZOJ1024] [SCOI2009] 生日快乐 (搜索)

Description windy的生日到了,为了庆祝生日,他的朋友们帮他买了一个边长分别为 X 和 Y 的矩形蛋糕.现在包括windy,一共有 N 个人来分这块大蛋糕,要求每个人必须获得相同面积的蛋糕.windy主刀,每一切只能平行于一块蛋糕的一边(任意一边),并且必须把这块蛋糕切成两块.这样,要切成 N 块蛋糕,windy必须切 N-1 次.为了使得每块蛋糕看起来漂亮,我们要求 N块蛋糕的长边与短边的比值的最大值最小.你能帮助windy求出这个比值么? Input 包含三个整数,X Y N.

1024: [SCOI2009]生日快乐

暴力题,N<=10,没注意到平均分,读题真是.. 我们对于一个矩形分成两块进行搜.然后求较大值. ans=min(ans,max(dfs(x,y/n*i,i),dfs(x,y/n*(n-i),n-i): 就是分成两块,分别递归的样子. 1 #include<stdio.h> 2 #include<algorithm> 3 #include<string.h> 4 #include<math.h> 5 #include<iostream> 6

bzoj千题计划115:bzoj1024: [SCOI2009]生日快乐

http://www.lydsy.com/JudgeOnline/problem.php?id=1024 枚举横着切还是竖着切,一边儿分多少块 #include<cstdio> #include<algorithm> using namespace std; double S; double dfs(double x,double y,int n) { if(n==1) return max(x,y)/min(x,y); double ans=1e9; for(int i=1;i&

SCOI2009生日快乐

竟然是搜索……囧 还以为是什么神题…… 1 uses math; 2 var x,y:extended; 3 n:longint; 4 function find(x,y:extended;z:longint):extended; 5 var i:longint; 6 r1,r2:extended; 7 begin 8 find:=10000000; 9 if z=1 then 10 begin 11 if x>y then exit(x/y) else exit(y/x); 12 end; 1

矩阵乘法专题1——bzoj 1297 [SCOI2009] 迷路题解

题目链接 题意:给两个长度分别为n和m的序列,现在有两种操作:1.分别选择两个序列的一个非空前缀,切两个前缀的最后一位相同,删除之,得到1分(只累计),消耗e:2.直接删除两个序列,消耗值定于两个序列之前删除的元素个数之和,并且使得得到的分有效(之前没有有效分) 分析: 首先,问题其实就是转化成,进行若干次操作1,然后进行操作2 还要找到一个判别标准,来评判较优的状态(贪心) 每次的消耗值比较大,其实可以计算出最大的删除次数,这个值不是很大 状态表示: 简单的,一个状态可以表示为串A的位置.串B