POJ2185 Milking Grid(KMP)

Every morning when they are milked, the Farmer John‘s cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns.

Help FJ find the rectangular unit of smallest area that can
be repetitively tiled to make up the entire milking grid. Note that the
dimensions of the small rectangular unit do not necessarily need to
divide evenly the dimensions of the entire milking grid, as indicated in
the sample input below.

Input

* Line 1: Two space-separated integers: R and C

* Lines 2..R+1: The grid that the cows form, with an
uppercase letter denoting each cow‘s breed. Each of the R input lines
has C characters with no space or other intervening character.

Output

* Line 1: The area of the smallest unit from which the grid is formed

Sample Input

2 5
ABABA
ABABA

Sample Output

2

Hint

The entire milking grid can be constructed from repetitions of the pattern ‘AB‘.

题意:在字符矩阵中找出一个最小子矩阵,使其多次复制所得的矩阵包含原矩阵

分析:为了找到最小重复的子矩阵,我们需要找到最小重复的宽度和长度.

最小重复的宽度需要满足每一行,所以我们枚举了每种宽度满足的行数.

最后找到最小重复的宽度.

找最小重复的长度的时候,进行在竖直方向上,对满足最小重复宽度的前缀进行KMP的next操作

找到最小重复的长度

贴一下一位讲解详细的大佬:http://blog.sina.com.cn/s/blog_69c3f0410100tyjl.html

代码如下

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
char str[10010][80];
char a[80];
int f[10010];//用来统计最小重复长度是下标长度的行数有多少.
int Next[10010];
int r,c,i,j,p,q,kuan;
void getNext()
{
    int j, k;
    j = 0; k = -1; Next[0] = -1;
    while(j < r)
        if(k == -1 ||!strcmp(str[j],str[k])) //进行多个字符数组之间的KMP操作
            Next[++j] = ++k;
        else
            k = Next[k];

}
int main()
{
    while(scanf("%d%d",&r,&c)!=EOF)
    {
        for(int i=0;i<r;i++)
            scanf("%s",str[i]);
            memset(f,0,sizeof(f));
        for(int i=0;i<r;i++){
           memcpy(a,str[i],sizeof(str[i]));
          for(int j=c;j>0;j--)
          {
            a[j]=‘\0‘;
            for(p=0,q=0;str[i][q];p++,q++)
            {
                if(p==j)p=0;
                if(a[p]!=str[i][q])break;
            }
            if(!str[i][q])f[j]++;//能够匹配到字符串末端 即循环节成立,进行计数
          }
        }
       for(i=1;i<=c;i++)
        {
          if(f[i]==r)  //求得满足所有行数的最小重复长度
          {
              kuan=i;
              break;
          }
        }
       for(i=0;i<r;i++)str[i][kuan]=‘\0‘;// 满足最小重复的宽度的前缀中进行KMP操作
       getNext();
       printf("%d\n",(r-Next[r])*kuan);//长*宽 即为最小的重复子矩阵
    }
    return 0;
}
时间: 2024-10-14 22:52:53

POJ2185 Milking Grid(KMP)的相关文章

poj2185 Milking Grid(KMP运用)

题目链接:http://poj.org/problem?id=2185 Milking Grid Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 6249   Accepted: 2616 Description Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 1

poj2185 Milking Grid (最小覆盖矩阵)

//给定一个由字符组成的矩阵,求出它的面积最小的覆盖矩阵 //可以求出每一行的最小覆盖子串的长度,只要对这些长度求最小公倍数,就可以获得最小覆盖矩阵的宽度. //同理,求出每一列的最小覆盖子串的长度,再求最小公倍数,就可以获得最小覆盖矩阵的高度了. # include <stdio.h> # include <string.h> # include <algorithm> using namespace std; char a[10010][100]; int next

poj 2185 Milking Grid(KMP)

题目链接:poj 2185 Milking Grid 题目大意:给定一个N?M的矩阵,找到一个最小的r?c的矩阵,使得原矩阵可以由若干个小矩阵组成,输出r?c的值. 解题思路:将行和列分别看成字符串,然后hash,对hash后的数组分别求KMP. #include <cstdio> #include <cstring> #include <algorithm> using namespace std; typedef unsigned long long ll; con

POJ 2185 Milking Grid KMP循环节周期

题目来源:id=2185" target="_blank">POJ 2185 Milking Grid 题意:至少要多少大的子矩阵 能够覆盖全图 比如例子 能够用一个AB 组成一个 ABABAB ABABAB 能够多出来 思路:每一行求出周期 总共n个 求这n个周期的最小公倍数 假设大于m 取m 每一列求出周期 总共m个求这个m个周期的最小公倍数 假设大于n取n 答案就是2个最小公倍数的积 #include <cstdio> #include <cst

【kmp算法】poj2185 Milking Grid

先对每行求出所有可能的循环节长度(不需要整除). 然后取在所有行中都出现了的,且最小的长度为宽. 然后将每一行看作字符,对所有行求next数组,将n-next[n](对这些行来说最小的循环节长度)作为长. 最后输出长乘宽即可. #include<cstdio> #include<cstring> using namespace std; bool can[10010][80]; char s[10010][80]; int next[80],n,m,wide,NEXT[10010]

POJ2185 Milking Grid【KMP】

题目链接: http://poj.org/problem?id=2185 题目大意: 有一个N行M列的字符矩阵,这个字符矩阵可以由较小的矩阵重复平铺组成整个矩阵.问: 最小的字符子矩阵的面积为多少. 思路: 对于长度为M的每一行s[i]来说,M-Next[M],M-Next[Next[M]],-都是能通过复制,完 全覆盖字符串的可行串,而M-Next[M]是最小的.遍历每一行,求出对所有s[i]都可行的最 小字符串长度,即每一行M-Next[M]的最小公倍数lcmn.再用类似的方法求出长度为N.

【POJ2185】【KMP + HASH】Milking Grid

Description Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently wri

Milking Grid poj2185

Milking Grid POJ - 2185 时限: 3000MS   内存: 65536KB   64位IO格式: %I64d & %I64u 提交 状态 已开启划词翻译 问题描述 Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns.

POJ 2185 Milking Grid (二维KMP next数组)

Milking Grid Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 6665   Accepted: 2824 Description Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75