CONTINUE...?【构造/分析】

CONTINUE...?
Time Limit: 1 Second      Memory Limit: 65536 KB      Special Judge
DreamGrid has  classmates numbered from  to . Some of them are boys and the others are girls. Each classmate has some gems, and more specifically, the -th classmate has  gems.

DreamGrid would like to divide the classmates into four groups , ,  and  such that:

Each classmate belongs to exactly one group.

Both  and  consist only of girls. Both  and  consist only of boys.

The total number of gems in  and  is equal to the total number of gems in  and .

Your task is to help DreamGrid group his classmates so that the above conditions are satisfied. Note that you are allowed to leave some groups empty.

Input
There are multiple test cases. The first line of input is an integer  indicating the number of test cases. For each test case:

The first line contains an integer  () -- the number of classmates.

The second line contains a string  () consisting of 0 and 1. Let  be the -th character in the string . If , the -th classmate is a boy; If , the -th classmate is a girl.

It is guaranteed that the sum of all  does not exceed .

Output
For each test case, output a string consists only of {1, 2, 3, 4}. The -th character in the string denotes the group which the -th classmate belongs to. If there are multiple valid answers, you can print any of them; If there is no valid answer, output "-1" (without quotes) instead.

Sample Input
5
1
1
2
10
3
101
4
0000
7
1101001
Sample Output
-1
-1
314
1221
3413214

【题意】:https://www.cnblogs.com/bluefly-hrbust/p/8971769.html

本题题意就是把1到n数表示为,两组数之和相等,即能不能1->n划分成两部分(男女分组是干扰的)

graph LR
偶数-->1+8+2+7=3+6+4+5

奇数-->1+3+4+6=2+5+7

偶数: N只需要前后匹配即可

奇数: len/2之前的奇数位和len/2之后的偶数位相加,等于len/2之前的偶数位加len/2的奇数位

【分析】:ACZone+

【出处】:CodeForces - 899C Dividing the numbers

【代码】:

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int main()
{
    int t,n,len;
    char a[100050];
    int  b[100050];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        getchar();
        scanf("%s",&a);
        len=strlen(a);
        if ((n%4)<=2 && n%4!=0)
        {
            printf("-1\n");
        }
        else
        {
            if(n%2==0) //偶数
            {
                for(int i=0; i<n/4; i++)
                {
                    if (a[i]=='1')printf("3");
                    else printf("1");
                }
                for (int i=n/4; i<n-n/4; i++)
                {
                    if (a[i]=='1')printf("4");
                    else printf("2");
                }
                for (int i=n-n/4; i<n; i++)
                {
                    if (a[i]=='1')printf("3");
                    else printf("1");
                }
                printf("\n");
            }
            else //奇数
            {
                for(int i=0; i<n/2; i++)
                {
                    if (a[i]=='1')
                    {
                        if ((i+1)%2==1)printf("3");
                        else printf("4");
                    }
                    else
                    {
                        if ((i+1)%2==1)printf("1");
                        else printf("2");
                    }
                }
                for(int i=n/2; i<len; i++)
                {
                    if (a[i]=='1')
                    {
                        if ((i+1)%2==1)printf("4");
                        else printf("3");
                    }
                    else
                    {
                        if ((i+1)%2==1)printf("2");
                        else printf("1");
                    }
                }
                printf("\n");
            }
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/Roni-i/p/8971993.html

时间: 2024-10-06 14:42:00

CONTINUE...?【构造/分析】的相关文章

LED平板灯构造分析及规划注意事项

面光源的构造首要有以下资料: 1.铝结构 外观构造,及LED散热首要构造--通常运用AL6063,铝挤模,前期本钱投入低,外表处理漂亮,散热作用好,前些日子去看展也有发现有厂商开端做压铸的结构,这么IP等级能够做高一点,且封光好些,全体漂亮,可是前期投入模具费用较高 2.分散板 将导光板的光均匀的散出,还有起到遮挡网点作用--分散板通常运用亚克力2.0的板材或PC料,亚克力的本钱较低且透光率比PC高稍高,亚克力脆抗老化功能弱,PC的报价稍为贵重,但抗老化功能强.分散板在装上今后不能看到网点,且透

Java ArrayList构造分析

1 /** 2 * The array buffer into which the elements of the ArrayList are stored. 3 * The capacity of the ArrayList is the length of this array buffer. 4 */ 5 private transient Object[] elementData; 6 7 /** 8 * The size of the ArrayList (the number of

基于虎书实现LALR(1)分析并生成GLSL编译器前端代码(C#)

基于虎书实现LALR(1)分析并生成GLSL编译器前端代码(C#) 为了完美解析GLSL源码,获取其中的信息(都有哪些in/out/uniform等),我决定做个GLSL编译器的前端(以后简称编译器或FrontEndParser). 以前我做过一个CGCompiler,可以自动生成LL(1)文法的编译器代码(C#语言的).于是我从<The OpenGL ® Shading Language>(以下简称"PDF")找到一个GLSL的文法,就开始试图将他改写为LL(1)文法.等

基于虎书实现LALR(1)分析并生成GLSL编译器前端(C#)

基于虎书实现LALR(1)分析并生成GLSL编译器前端(C#) 为了完美解析GLSL源码,获取其中的信息(都有哪些in/out/uniform等),我决定做个GLSL编译器的前端(以后简称编译器). 以前我做过一个CGCompiler,能自动生成LL(1)文法的编译器代码(C#语言的).于是我从<The OpenGL ® Shading Language>(以下简称"PDF")找到一个GLSL的文法,就开始试图将他改写为LL(1)文法.等到我重写了7次后发现,这是不可能的.

汇编器构造

@import url(http://i.cnblogs.com/Load.ashx?type=style&file=SyntaxHighlighter.css);@import url(/css/cuteeditor.css); 汇编器构造   一.             汇编器简介 前面介绍了编译器构造和静态链接器构造的具体方法,而且我们实现了一个将高级语言转化为汇编语言的编译器,同时又实现了一个将多个目标文件链接为一个可执行文件的链接器.现在需要一个连接这两个模块的功能模块——汇编器,它

codeforces 459C - Pashmak and Buses 【构造题】

题目:codeforces 459C - Pashmak and Buses 题意:给出n个人,然后k辆车,d天时间,然后每天让n个人选择坐一辆车去上学,要去d天不能有任意两个人乘同一辆车,不能的话输出 -1 分类:数学,构造 分析:这个题目首先得分析,我开始想到的是首先用相同的放在一起,比如 7 2 3 这样构造 1 1 1 1 2 2 2 1 1 1 2 2 2 1 1 1 2 2 2 1 1 1 2 2 2 1 1 1 就是需要的天数跟每一行出现次数最多的数的出现次数相等,但是发现还有更优

编译原理:LL(1)文法 语法分析器(预测分析表法)

设计要求:对于任意输入的一个LL(1)文法,构造其预测分析表,并对指定输入串分析其是否为该文法的句子. 思路:首先实现集合FIRST(X)构造算法和集合FOLLOW(A)构造算法,再根据FIRST和FOLLOW集合构造出预测分析表,并对指定的句子打印出分析栈的分析过程,判断是否为该文法的句子. 指定文法: //文法 E->TK K->+TK K->$ T->FM M->*FM M->$ F->i F->(E) 对于输入串i+i*i# ,这里我们先给出实验结果

LL(1),LR(0),SLR(1),LALR(1),LR(1)对比与分析

前言:考虑到这几种文法如果把具体内容讲下来肯定篇幅太长,而且繁多的符号对初学者肯定是极不友好的,而且我相信看这篇博客的人已经对这几个文法已经有所了解了,本篇博客的内容只是对 这几个文法做一下对比,加深大家对这几个文法的理解.更详细的细节,初学者可以看看这个课件https://files-cdn.cnblogs.com/files/henuliulei/%E7%AC%AC5%E7%AB%A0.ppt,或者其他相关的博客. 一:五种文法的演变 1.1 LL(1)文法 LL(1)文法是自上而下的分析方

java反序列化-ysoserial-调试分析总结篇(3)

前言: 这篇文章主要分析commoncollections3,这条利用链如yso描述,这个与cc1类似,只是反射调用方法是用的不是invokeTransformer而用的是InstantiateTransformer,整个调用过程如下图 利用链分析: 如上图所示,入口点还是Annotationinvoationhandler的Entryset 此时将会调用membervalues.get,其中var4位entryset,而membervalues中存储的为lazymap类的实例,即调用lazym