PAT 甲级 1022 Digital Library

https://pintia.cn/problem-sets/994805342720868352/problems/994805480801550336

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID‘s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10?4??) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user‘s search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID‘s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e4 + 10;
int N, M;

struct Node {
    int title;
    string kind; // 1
    string author; // 2
    string keyword; // 3
    string name; // 4
    int year; // 5
    bool flag = false;
}node[maxn];

int main() {
    scanf("%d", &N);

    for(int i = 0; i < N; i ++) {
        string s1, s2, s3, s4;
        int t, n;
        scanf("%d", &t); node[i].title = t;
        cin.ignore();
        getline(cin, s1); node[i].kind = s1;
        getline(cin, s2); node[i].author = s2;
        getline(cin, s3); node[i].keyword = s3;
        getline(cin, s4); node[i].name = s4;
        scanf("%d", &n); node[i].year = n;
    }

    scanf("%d", &M);
    cin.ignore();
    while(M --) {
        vector<int> ans;
        ans.clear();
        string s;
        string rec = "";
        getline(cin, s);
        cout << s << endl;
        int len = s.length();
        for(int i = 3; i < len; i ++)
            rec += s[i];

        if(s[0] == ‘1‘) {
            for(int i = 0; i <= N; i ++) {
                if(node[i].kind == rec)
                    ans.push_back(node[i].title);
            }
        } else if(s[0] == ‘2‘) {
            for(int i = 0; i < N; i ++) {
                if(node[i].author == rec)
                    ans.push_back(node[i].title);
            }
        } else if(s[0] == ‘3‘) {
            for(int i = 0; i < N; i ++) {
                for(int j = 0; j < node[i].keyword.length(); j ++) {
                    if(node[i].keyword[j] != ‘ ‘ && (j == 0 || node[i].keyword[j - 1] == ‘ ‘)) {
                        if(node[i].keyword.substr(j, rec.length()) == rec)
                            {node[i].flag = true; continue;}
                    }
                }
                if(node[i].flag) {
                    ans.push_back(node[i].title);
                    node[i].flag = false;
                }
            }
        } else if(s[0] == ‘4‘) {
            for(int i = 0; i < N; i ++) {
                if(node[i].name == rec)
                    ans.push_back(node[i].title);
            }
        } else {
            int res = 0;
            for(int i = 0; i <= 3; i ++)
                res = res * 10 + (rec[i] - ‘0‘);
            for(int i = 0; i < N; i ++) {
                if(node[i].year == res)
                    ans.push_back(node[i].title);
            }
        }

        if(ans.size()) {
                sort(ans.begin(), ans.end());
                for(int i = 0; i < ans.size(); i ++)
                    printf("%07d\n", ans[i]);
            } else printf("Not Found\n");
    }
    return 0;
}

  在 op == 3 的时候优化一下就不会超时了

FH

原文地址:https://www.cnblogs.com/zlrrrr/p/10366941.html

时间: 2024-08-12 23:37:44

PAT 甲级 1022 Digital Library的相关文章

PAT甲级1022 Digital Library

题目:https://pintia.cn/problem-sets/994805342720868352/problems/994805480801550336 题意: 每一本书有一个id, 书名,作者,至多五个关键字,一个出版社名,出版社年份. 现在根据给定的书名或作者或关键字或出版社名或年份,按照id字典序大小输出符合条件的书. 思路: 对每一个属性都用map维护. 一个坑点是,前面说书的年份一定在1000-3000之间,但是查询的时候的年份不一定满足,而且这里输出的时候也要满足4位.测试点

PAT甲级——A1022 Digital Library

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are s

PAT Advanced 1022 Digital Library (30分)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are s

PAT A 1022. Digital Library (30)【结构体排序检索】

https://www.patest.cn/contests/pat-a-practise/1022 直接模拟, 输入,按id排序,检索 #include <iostream> #include <string> #include <algorithm> using namespace std; struct book //图书结构 { string id; string title; string author; int k; //关键词数量 string key[5

PAT:1022. Digital Library (30) (部分正确,错最后两个)

1 #include<stdio.h> 2 #include<string.h> 3 #include<map> 4 #include<string> 5 #include<set> 6 #include<iostream> 7 using namespace std; 8 int n; //n本书 9 //标题.作者.关键字.出版社.出版年份与ID的映射 10 map<string,set<int>> mpT

pat advanced level1022 digital library

1022 Digital Library (30)(30 分) A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given an

1022. Digital Library (30)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are s

1022. Digital Library (30) -map -字符串处理

题目如下: A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you

1022 Digital Library (30)(30 point(s))

problem A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, y