Conturbatio

Conturbatio

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 234    Accepted Submission(s): 110

Problem Description

There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place.

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook?

Input

The first line of the input is a integer T, meaning that there are T test cases.

Every test cases begin with four integers n,m,K,Q.
K is the number of Rook, Q is the number of queries.

Then K lines follow, each contain two integers x,y describing the coordinate of Rook.

Then Q lines follow, each contain four integers x1,y1,x2,y2 describing the left-down and right-up coordinates of query.

1≤n,m,K,Q≤100,000.

1≤x≤n,1≤y≤m.

1≤x1≤x2≤n,1≤y1≤y2≤m.

Output

For every query output "Yes" or "No" as mentioned above.

Sample Input

2

2 2 1 2

1 1

1 1 1 2

2 1 2 2

2 2 2 1

1 1

1 2

2 1 2 2

Sample Output

Yes

No

Yes

Hint

Huge input, scanf recommended.

题意:给你象棋中所有车的位置,每次询问矩形给你左上角和右上角的点,问这个矩形中的点是否可以被车吃完。

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

#define maxn 110008
int x[maxn], y[maxn];

int main()
{
    int t, n, m, k, q, a, b, x1, x2, y1, y2;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d%d%d", &n, &m, &k, &q);
        memset(x, 0, sizeof(x));
        memset(y, 0, sizeof(y));
        for(int i = 0; i < k; i++)
        {
            scanf("%d%d", &a, &b);
            x[a] = 1;
            y[b] = 1;
        }

        for(int i = 2; i <= n; i++)
            x[i] += x[i-1];
        for(int i = 2; i <= m; i++)
            y[i] += y[i-1];

        for(int w = 0; w < q; w++)
        {
            int i, j;
            scanf("%d%d%d%d", &x1, &y1, &x2, &y2);

            if(x[x2]-x[x1-1] == x2-x1+1 || y[y2]-y[y1-1] == y2-y1+1)  // 每次查询看是否矩形所在的所有行或所有列全部被车吃掉
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
    return 0;
}

  

时间: 2024-10-13 16:44:19

Conturbatio的相关文章

hdu 5480 Conturbatio 线段树 单点更新,区间查询最小值

Conturbatio Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=5480 Description There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place. There are also many quer

hdu 5480|| bestcoder   #57 div 2 Conturbatio(前缀和||树状数组)

Conturbatio Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 211    Accepted Submission(s): 99 Problem Description There are many rook on a chessboard, a rook can attack the row and column it bel

HDU 5480 Conturbatio

区间求和不更新,开个数组记录一下前缀和就可以了 #include<cstdio> #include<cstring> #include<cmath> #include<algorithm> using namespace std; const int maxn=100000+10; int R[maxn],C[maxn]; int sumR[maxn],sumC[maxn]; int main() { int T; scanf("%d",

hdu 5480(维护前缀和+思路题)

Conturbatio Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 786    Accepted Submission(s): 358 Problem Description There are many rook on a chessboard, a rook can attack the row and column it be

树状数组详解(图形学算法)

目录 一.从图形学算法说起 1.Median Filter 概述 2.r pixel-Median Filter 算法 3.一维模型 4.数据结构的设计 5.树状数组华丽登场 二.细说树状数组 1.树 or 数组? 2.结点的含义 3.求和操作 4.更新操作 5.lowbit函数O(1)实现 6.小结 三.树状数组的经典模型 1.PUIQ模型 2.IUPQ模型 3.逆序模型 4.二分模型 5.再说Median Filter 6.多维树状数组模型 四.树状数组题集整理 一.从图形学算法说起 1.M