1043. Is It a Binary Search Tree (25)【二叉树】——PAT (Advanced Level) Practise

题目信息

1043. Is It a Binary Search Tree (25)

时间限制400 ms

内存限制65536 kB

代码长度限制16000 B

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.

The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.

Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7

8 6 5 7 10 8 11

Sample Output 1:

YES

5 7 6 8 11 10 8

Sample Input 2:

7

8 10 11 8 6 7 5

Sample Output 2:

YES

11 8 10 7 5 6 8

Sample Input 3:

7

8 6 8 5 10 9 11

Sample Output 3:

NO

解题思路

分别以最大和最小序建立两棵树,然后比较前序遍历与数据是否一致。注意建树时比较方式要对称

AC代码

#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstring>
using namespace std;
struct Node{
    Node *left, *right;
    int v;
};
Node* create(int v){
    Node *h = new Node();
    h->left = h->right = NULL;
    h->v = v;
    return h;
}
Node* insert1(Node *root, int v){
    if (root == NULL){
        return create(v);
    }else{
        if (v < root->v){
            root->left = insert1(root->left, v);
        }else{
            root->right = insert1(root->right, v);
        }
    }
    return root;
}
Node* insert2(Node *root, int v){
    if (root == NULL){
        return create(v);
    }else{
        if (v >= root->v){
            root->left = insert2(root->left, v);
        }else{
            root->right = insert2(root->right, v);
        }
    }
    return root;
}
void preOrder(Node* root, vector<int> &v){
    v.push_back(root->v);
    if (root->left) preOrder(root->left, v);
    if (root->right) preOrder(root->right, v);
}
void postOrder(Node* root, vector<int> &v){
    if (root->left) postOrder(root->left, v);
    if (root->right) postOrder(root->right, v);
    v.push_back(root->v);
}
int main()
{
    int n, t;
    scanf("%d", &n);
    vector<int> v, v1, v2, rs;
    Node *t1 = NULL, *t2 = NULL;
    for (int i = 0; i < n; ++i){
        scanf("%d", &t);
        v.push_back(t);
        t1 = insert1(t1, t);
        t2 = insert2(t2, t);
    }
    preOrder(t1, v1);
    preOrder(t2, v2);

    if (v == v1){
        printf("YES\n");
        postOrder(t1, rs);
        printf("%d", rs[0]);
        for (int i = 1; i < rs.size(); ++i){
            printf(" %d", rs[i]);
        }
    }else if (v == v2){
        printf("YES\n");
        postOrder(t2, rs);
        printf("%d", rs[0]);
        for (int i = 1; i < rs.size(); ++i){
            printf(" %d", rs[i]);
        }
    }else{
        printf("NO");
    }
    printf("\n");
    return 0;
}
时间: 2024-11-10 00:47:39

1043. Is It a Binary Search Tree (25)【二叉树】——PAT (Advanced Level) Practise的相关文章

PAT 1043. Is It a Binary Search Tree (25)

1043. Is It a Binary Search Tree (25) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a nod

1043 Is It a Binary Search Tree (25 分)

1043 Is It a Binary Search Tree (25 分) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a no

1043. Is It a Binary Search Tree (25)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue (二叉树建立方法) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than th

1043 Is It a Binary Search Tree (25分)(树的插入)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys greate

PAT Advanced 1043 Is It a Binary Search Tree (25分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys greate

【PAT甲级】1043 Is It a Binary Search Tree (25 分)(判断是否为BST的先序遍历并输出后序遍历)

题意: 输入一个正整数N(<=1000),接下来输入N个点的序号.如果刚才输入的序列是一颗二叉搜索树或它的镜像(中心翻转180°)的先序遍历,那么输出YES并输出它的后序遍历,否则输出NO. trick: for(auto it:post) cout<<it<<((it!=post[n-1])?" ":""); 这样输出会使第0,1数据点格式错误...原因未知 cout<<post[0]; for(int i=1;i<

1043 Is It a Binary Search Tree (25分)

1. 题目 2. 思路 如下图 发现规律,对于最左边来说,后面所有的集合都是先小后大或者先大后小,如果小大交错那么不符合 使用1中规律确定是否为镜像,结合二叉排序树的特点,用递归建立树 输出树的后序遍历 3. 注意点 发现规律比较困难 树的题目一般都要用递归 4. 代码 #include<cstdio> #include<algorithm> #include<vector> using namespace std; #define null NULL struct n

pat1043. Is It a Binary Search Tree (25)

1043. Is It a Binary Search Tree (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only

PAT 1043 Is It a Binary Search Tree[二叉树][难]

1043 Is It a Binary Search Tree(25 分) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a nod