Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14724 Accepted Submission(s): 10371
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4 10 20
Sample Output
5 42 627
Author
Ignatius.L
dp[i][j]:用[1,j]里的数组成i的方法种数
dp[i][j]=dp[i][j-1]+dp[i-j][j]
由于dp[i][j-1]里组成i的方法中都是不包含j的
所以把j单独取出,保证所有方法至少含有一个j,
也就是dp[i-j][j]
#include<map> #include<string> #include<cstring> #include<cstdio> #include<cstdlib> #include<cmath> #include<queue> #include<vector> #include<iostream> #include<algorithm> #include<bitset> #include<climits> #include<list> #include<iomanip> #include<stack> #include<set> using namespace std; int dp[200][200]; int dfs(int a,int b) { if(dp[a][b]!=-1) return dp[a][b]; if(b==1) return dp[a][b]=1; if(a<b) return dp[a][b]=dfs(a,a); if(a==b) return dp[a][b]=dfs(a,b-1)+1; return dp[a][b]=dfs(a,b-1)+dfs(a-b,b); } int main() { int n; while(cin>>n) { memset(dp,-1,sizeof(dp)); cout<<dfs(n,n)<<endl; } }