Eddy's picture

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input

3

1.0 1.0

2.0 2.0

2.0 4.0

Sample Output

3.41

题意:给出一些点,求所有点连起来的最短路径,算是最小生成树问题,本题使用Kruskal算法

代码:

#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
#define INF 0x3f3f3f3f
#define MAX 101
double c[MAX][MAX];
double dis[MAX],visit[MAX];
typedef struct point
{
  double x;
  double y;
}Point;
//求两点之间的距离
double getDistance(Point a,Point b)
{
  double len;
  len=sqrt(1.0*(a.x-b.x)*(a.x-b.x)+1.0*(a.y-b.y)*(a.y-b.y));
  return len;
}
int main()
{
  Point p[105];
  int i,j,k,n;
  double sum,l;
  while(cin >> n)
  { //输出坐标点
    for(i=1;i<=n;i++)
    cin >> p[i].x >> p[i].y;
    //初始化所有点之间的距离
    for(i=0;i<=n;i++)
      for(j=0;j<=n;j++)
      {
        if(i==j)c[i][j]=0;
          else c[i][j]=INF;
      }
      //初始化各个点之间的距离
    for(i=1;i<n;i++)
      for(j=i+1;j<=n;j++)
      {
        l=getDistance(p[i],p[j]);
        c[i][j]=c[j][i]=l;
      }
    //初始化起始点到各点的距离
    for(i=1;i<=n;i++)
    {
      dis[i]=c[1][i];
      visit[i]=0;
    }
    //标记1点已经查过
    visit[1]=1;
    sum=0;
    for(i=1;i<n;i++)
    {
      double minlen=1.0*INF;
      //找到与i点到其他点k最短的路径
      for(j=1;j<=n;j++)
        if(visit[j]==0 && dis[j]<minlen)
        {
          minlen=dis[j];
          k=j;
        }
      sum+=minlen;
    //将k点标记查过
      visit[k]=1;
      for(j=1;j<=n;j++)
      if(visit[j]==0 && dis[j]>c[j][k])dis[j]=c[j][k];
    }
    // cout << sum << endl;
    printf("%.2f\n",sum);
  }
  return 0;
}

Eddy's picture

时间: 2024-10-22 21:02:32

Eddy's picture的相关文章

Eddy&#39;s picture(最小生成树)

Eddy's picture Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 228 Accepted Submission(s): 168   Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to become

hdu 1162 Eddy&#39;s picture 最小生成树入门题 Prim+Kruskal两种算法AC

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7428    Accepted Submission(s): 3770 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to

hdu 1162 Eddy&#39;s picture(最小生成树算法)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1162 Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6866    Accepted Submission(s): 3469 Problem Description Eddy begins to like p

【HDU1162】Eddy&#39;s picture(MST基础题)

很基础的点坐标MST,一不留神就AC了, - - !! 1 #include <iostream> 2 #include <cstring> 3 #include <cstdlib> 4 #include <cstdio> 5 #include <cmath> 6 #include <cctype> 7 #include <algorithm> 8 #include <numeric> 9 #include &

HDU 1162 Eddy&#39;s picture【最小生成树,Prime算法+Kruskal算法】

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9334    Accepted Submission(s): 4711 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to

(hdu step 6.1.2)Eddy&#39;s picture(在只给出二维坐标点的情况下,求让n个点连通的最小费用)

题目: Eddy's picture Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 172 Accepted Submission(s): 126   Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to be

hdu 1162 Eddy&#39;s picture

最小生成树裸题,没有初始化都能AC,看来测试数据只有一组 #include<iostream> #include<vector> #include<cmath> #include<cstdio> #define inf 1<<30 #define maxn 105 using namespace std; struct stu { double x,y; }; stu mapp[maxn]; int n; vector<int>roo

hdoj 1162 Eddy&#39;s picture

并查集+最小生成树 Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7669    Accepted Submission(s): 3882 Problem Description Eddy begins to like painting pictures recently ,he is sure of hi

HDU 1162 Eddy&#39;s picture(图论-最小生成树)

题目如下: Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7267    Accepted Submission(s): 3676 Problem Description Eddy begins to like painting pictures recently ,he is sure of himse