HDU 2932 Extraordinarily Tired Students(数学 & 模拟)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2932

Problem Description

When a student is too tired, he can‘t help sleeping in class, even if his favorite teacher is right here in front of him. Imagine you have a class of extraordinarily tired students, how long do you have to wait, before all the students are listening to you
and won‘t sleep any more? In order to complete this task, you need to understand how students behave. When a student is awaken, he struggles for a minutes listening to the teacher (after all, it‘s too bad to sleep all the time). After that, he counts the number
of awaken and sleeping students (including himself). If there are strictly more sleeping students than awaken students, he sleeps for b minutes. Otherwise, he struggles for another a minutes, because he knew that when there is only very few sleeping students,
there is a big chance for them to be punished! Note that a student counts the number of sleeping students only when he wants to sleep again. Now that you understand each student could be described by two integers a and b, the length of awaken and sleeping
period. If there are always more sleeping students, these two periods continue again and again. We combine an awaken period with a sleeping period after it, and call the combined period an awaken-sleeping period. For example, a student with a=1 and b=4 has
an awaken-sleeping period of awaken-sleeping-sleeping-sleeping-sleeping. In this problem, we

need another parameter c (1 ≤ c ≤ a+b) to describe a student‘s initial condition: the initial position in his awaken-sleeping period. The 1st and 2nd position of the period discussed above are awaken and sleeping, respectively.

Now we use a triple (a, b, c) to describe a student. Suppose there are three students (2, 4, 1), (1, 5, 2) and (1, 4, 3), all the students will be awaken at time 18. The details are shown in the table below.

Write a program to calculate the first time when all the students are not sleeping.

Input

The input consists of several test cases. The first line of each case contains a single integer n (1 ≤ n ≤ 10), the number of students. This is followed by n lines, each describing a student. Each of these lines contains three integers a, b, c (1 ≤ a, b ≤ 5),
described above. The last test case is followed by a single zero, which should not be processed.

Output

For each test case, print the case number and the first time all the students are awaken. If it‘ll never happen, output -1.

Sample Input

3
2 4 1
1 5 2
1 4 3
3
1 2 1
1 2 2
1 2 3
0

Sample Output

Case 1: 18
Case 2: -1

Source

2006 Asia Regional Xi-An

题意:

给出每个学生在一个周期内不睡觉和睡觉的分钟数,如果在某一天,学生本来在该睡觉的时间段但是他看见不睡觉的人数大于总人数的一半,那么他就不会睡觉,反之睡觉;

求所有的学生都不睡觉的时间!

PS:

模拟学生的睡觉和不睡觉过程,暴力!

代码如下:

#include<cstdio>
#include<cstring>
const int maxn = 17;
const int MAXN = 100017;

int main()
{
    int n;
    int cas = 0;
    int a[maxn], b[maxn], c[maxn];
    while(scanf("%d",&n)&&n)
    {
        for(int i = 1; i <= n; i++)
            scanf("%d%d%d", &a[i], &b[i], &c[i]);
        int ans;
        int cont = 0;

        for(ans = 1; ans < MAXN; ans++)
        {
            cont = 0;
            for(int i = 1; i <= n; i++)
            {
                if(c[i] <= a[i])//检查位置是否在开始睡觉的时间之前
                    cont++;//没有睡觉的人数
            }
            if(cont == n)   //每个位置都在所给的开始睡觉的时间之前
                break;
            for(int i = 1; i <= n; i++)
            {
                if(c[i] == a[i]+b[i] || (c[i] == a[i] && cont > n-cont))
                {
                    //新的一个循环开始 || 本来应该睡觉但是此时没有睡觉的人数大于一半
                    c[i] = 0;//重新计数
                }
                c[i]++;
            }
        }
        if(ans == MAXN)
            ans = -1;

        printf("Case %d: %d\n", ++cas, ans);
    }
    return 0;
}
时间: 2024-10-12 17:35:22

HDU 2932 Extraordinarily Tired Students(数学 & 模拟)的相关文章

HDU 2932 Extraordinarily Tired Students (暴力+取模还是很强大的)

题目链接:HDU 2932 Extraordinarily Tired Students 题意:给出N个学生的状态,(a,b,c).a表示a分钟这醒着,b表示b分钟睡着,c表示刚开始是重周期(a+b)分钟的第c分钟开始.求第几分钟,所有的学生都没有睡觉.其中每个学生在睡觉前看一下是否睡觉的人数(包括他自己)比醒着的人数大,若是就睡觉,反之则不睡觉. 数据很小,暴力之,假设所有学生都没睡觉的时间不超过1000000,发现还可以更小. AC代码; #include <stdio.h> #inclu

UVA - 12108 Extraordinarily Tired Students(模拟)

Extraordinarily Tired Students Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu Submit Status Description When a student is too tired, he can't help sleeping in class, even if his favorite teacher is right here in front of hi

【模拟】UVa 12108 - Extraordinarily Tired Students

When a student is too tired, he can't help sleeping in class, even if his favorite teacher is right here in front of him. Imagine you have a class of extraordinarily tired students, how long do you have to wait, before all the students are listening

12108 - Extraordinarily Tired Students

When a student is too tired, he can't help sleeping in class, even if his favorite teacher is right here in front of him. Imagine you have a class of extraordinarily tired students, how long do you have to wait, before all the students are listening

Uva 12108 Extraordinarily Tired Students

题意: 课堂上有n个学生(n<=10).每个学生都有一个“清醒-睡眠”周期.其中第i个学生醒 ai 分钟后睡 bi 分钟,然后重复(1<=ai,bi<=5),初始时第i个学生处在他的周期的第 ci 分钟.每个学生在临 睡前会察看全班睡觉人数是否严格大于清醒人数,只有这个条件满足时才睡觉,否则就坚持听课 ai 分钟后再次检查这个条件.问经过多长时间后全班都清醒. 思路: 用优先队列记录每次要更改的时间和对应要更改状态的学生编号,按要更改的时间从小到大排序. cnt记录当前睡觉的人数. 这里

【习题 4-8 UVA - 12108】Extraordinarily Tired Students

[链接] 我是链接,点我呀:) [题意] [题解] 一个单位时间.一个单位时间地模拟就好. 然后对于每个人. 记录它所处的周期下标idx 每个单位时间都会让每个人的idx++ 注意从醒着到睡着的分界线的处理就好. 可以多循环几次..超过上限认为无解 (其他题解也提供了一种方法,就是如果状态和初始的情况相同的话.就无解了即形成了一个环. (可能如果无解一定会形成环? [代码] #include <bits/stdc++.h> #define rep1(i,a,b) for (int i = a;

hdu 5640 King&#39;s Cake(模拟)

Problem Description It is the king's birthday before the military parade . The ministers prepared a rectangle cake of size n×m(1≤n,m≤10000) . The king plans to cut the cake himself. But he has a strange habit of cutting cakes. Each time, he will cut

hdu 4930 Fighting the Landlords (模拟)

Fighting the Landlords Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 160    Accepted Submission(s): 52 Problem Description Fighting the Landlords is a card game which has been a heat for ye

HDU 4405 飞行棋上的数学期望

突然发现每次出现有关数学期望的题目都不会做,就只能找些虽然水但自己还是做不出的算数学期望的水题练练手了 题目大意: 从起点0点开始到达点n,通过每次掷色子前进,可扔出1,2,3,4,5,6这6种情况,扔到几前进几,当然对应飞行通道可以通过x直达一点y,x<y,计算到达n点或超过n 点要扔色子的次数的数学期望 从某一点 i 扔完色子可到达 i+1,i+2,i+3,i+4,i+5,i+6这6个点,令dp[i]为到达末尾的数学期望 那么到达之后6个点的数学期望是一样的,那么dp[i]=dp[i+1]*