【bzoj1014】[JSOI2008]火星人prefix Splay+Hash+二分

题目描述

火星人最近研究了一种操作:求一个字串两个后缀的公共前缀。比方说,有这样一个字符串:madamimadam,我们将这个字符串的各个字符予以标号:序号: 1 2 3 4 5 6 7 8 9 10 11 字符 m a d a m i m a d a m 现在,火星人定义了一个函数LCQ(x, y),表示:该字符串中第x个字符开始的字串,与该字符串中第y个字符开始的字串,两个字串的公共前缀的长度。比方说,LCQ(1, 7) = 5, LCQ(2, 10) = 1, LCQ(4, 7) = 0 在研究LCQ函数的过程中,火星人发现了这样的一个关联:如果把该字符串的所有后缀排好序,就可以很快地求出LCQ函数的值;同样,如果求出了LCQ函数的值,也可以很快地将该字符串的后缀排好序。 尽管火星人聪明地找到了求取LCQ函数的快速算法,但不甘心认输的地球人又给火星人出了个难题:在求取LCQ函数的同时,还可以改变字符串本身。具体地说,可以更改字符串中某一个字符的值,也可以在字符串中的某一个位置插入一个字符。地球人想考验一下,在如此复杂的问题中,火星人是否还能够做到很快地求取LCQ函数的值。

输入

第一行给出初始的字符串。第二行是一个非负整数M,表示操作的个数。接下来的M行,每行描述一个操作。操作有3种,如下所示
1、询问。语法:Qxy,x,y均为正整数。功能:计算LCQ(x,y)限制:1<=x,y<=当前字符串长度。
2、修改。语法:Rxd,x是正整数,d是字符。功能:将字符串中第x个数修改为字符d。限制:x不超过当前字符串长度。
3、插入:语法:Ixd,x是非负整数,d是字符。功能:在字符串第x个字符之后插入字符d,如果x=0,则在字符串开头插入。限制:x不超过当前字符串长度

输出

对于输入文件中每一个询问操作,你都应该输出对应的答案。一个答案一行。

样例输入

madamimadam
7
Q 1 7
Q 4 8
Q 10 11
R 3 a
Q 1 7
I 10 a
Q 2 11

样例输出

5
1
0
2
1



题解

Splay+Hash+二分

求两个字符串的LCP,可以使用Hash+二分的方法。本题由于需要支持插入和修改字符,维护Hash值较为容易,因此采用Hash+二分的方法。

那么现在问题就转变为如何动态维护Hash值,支持插入与修改。需要Splay来完成。

使用Splay维护子树Hash值,然后每次pushup时合并Hash。

查询时二分长度,然后直接比较Hash值大小即可。

时间复杂度$O(n\log^2n)$。

#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 100010
using namespace std;
typedef unsigned long long ull;
ull hash[N] , base[N];
int fa[N] , c[2][N] , si[N] , root , tot;
char s[N] , opt[5] , tmp[5];
void pushup(int x)
{
    int l = c[0][x] , r = c[1][x];
    si[x] = si[l] + si[r] + 1;
    hash[x] = (hash[l] * 233 + s[x]) * base[si[r]] + hash[r];
}
void build(int l , int r , int f)
{
    if(l > r) return;
    int mid = (l + r) >> 1;
    build(l , mid - 1 , mid) , build(mid + 1 , r , mid);
    fa[mid] = f , c[mid > f][f] = mid;
    pushup(mid);
}
void rotate(int &k , int x)
{
    int y = fa[x] , z = fa[y] , l = (c[1][y] == x) , r = l ^ 1;
    if(y == k) k = x;
    else c[c[1][z] == y][z] = x;
    fa[x] = z , fa[y] = x , fa[c[r][x]] = y , c[l][y] = c[r][x] , c[r][x] = y;
    pushup(y) , pushup(x);
}
void splay(int &k , int x)
{
    int y , z;
    while(x != k)
    {
        y = fa[x] , z = fa[y];
        if(y != k)
        {
            if((c[0][y] == x) ^ (c[0][z] == y)) rotate(k , x);
            else rotate(k , y);
        }
        rotate(k , x);
    }
}
int find(int k , int x)
{
    if(x <= si[c[0][k]]) return find(c[0][k] , x);
    else if(x > si[c[0][k]] + 1) return find(c[1][k] , x - si[c[0][k]] - 1);
    else return k;
}
int split(int l , int r)
{
    int a = find(root , l - 1) , b = find(root , r + 1);
    splay(root , a) , splay(c[1][root] , b);
    return c[0][c[1][root]];
}
int main()
{
    int m , i , x , y , l , r , mid , ans;
    ull tx , ty;
    scanf("%s%d" , s + 2 , &m) , tot = strlen(s + 2) + 2;
    base[0] = 1;
    for(i = 1 ; i <= 100000 ; i ++ ) base[i] = base[i - 1] * 233;
    build(1 , tot , 0) , root = (tot + 1) >> 1;
    while(m -- )
    {
        scanf("%s%d" , opt , &x) , x ++ ;
        if(opt[0] == ‘R‘) scanf("%s" , tmp) , x = find(root , x) , splay(root , x) , s[x] = tmp[0] , pushup(x);
        else if(opt[0] == ‘I‘) scanf("%s" , tmp) , s[++tot] = tmp[0] , split(x + 1 , x) , c[0][c[1][root]] = tot , fa[tot] = c[1][root] , pushup(tot) , pushup(fa[tot]) , pushup(root);
        else
        {
            scanf("%d" , &y) , y ++ ;
            l = 1 , r = min(tot - x , tot - y) , ans = 0;
            while(l <= r)
            {
                mid = (l + r) >> 1;
                tx = hash[split(x , x + mid - 1)] , ty = hash[split(y , y + mid - 1)];
                if(tx == ty) ans = mid , l = mid + 1;
                else r = mid - 1;
            }
            printf("%d\n" , ans);
        }
    }
    return 0;
}
时间: 2024-10-13 16:53:14

【bzoj1014】[JSOI2008]火星人prefix Splay+Hash+二分的相关文章

[BZOJ1014][JSOI2008]火星人prefix splay+hash+二分

题目链接:http://www.lydsy.com/JudgeOnline/problem.php?id=1014 先考虑如果没有修改操作和插入操作,是一个静态的字符串,我们可以怎样快速求得题目中的LCQ. 两个字符串判等很容易想到hash.于是我们二分答案并二分判断,就可以在$log_n$时间内得到答案. 现在加上修改和插入操作,其实就是要动态维护子串也就是一段区间的hash值,这种问题很容易就想到用splay来维护. 每个节点记录此节点管辖下子树的hash值h,当前节点的h=左孩子的h+节点

BZOJ 1014 JSOI2008 火星人prefix Splay+Hash+二分

题目大意:给定一个字符串,提供下列操作: 1.查询从x开始的后缀和从y开始的后缀的最长公共前缀长度 2.将x位置的字符修改为y 3.在x位置的字符后面插入字符y 看到这题一开始我先懵住了...这啥..我第一时间想到的是后缀数据结构 但是不会写 而且后缀数据结构也不支持修改操作 后来无奈找了题解才知道是Hash+二分... 太强大了 Hash+二分打爆一切啊 用Splay维护这个字符串的修改和插入操作 每个节点维护子串的Hash值 判断时二分找到最长公共前缀 不过这道题还有一些注意事项 1.此题不

BZOJ 1014: [JSOI2008]火星人prefix( splay + hash )

用splay维护序列, 二分+hash来判断LCQ.. #include<bits/stdc++.h> using namespace std; typedef unsigned long long ull; const int maxn = 100009; const int P = 1000173169; ull K[maxn]; int N; char S[maxn]; struct Node { Node *ch[2], *p; int s, v; ull h; inline void

BZOJ-1014 [JSOI2008]火星人prefix (Splay+二分+hash)

题解: 用splay维护添加修改操作,然后二分hash判断长度. 操作一:对于查询区间[l,r]的hash值,显然将l-1旋到根,将r+1旋到根的右儿子,此时所求区间就是根的右儿子的左儿子了. 操作二:将要修改的位置旋到根,然后直接改就可以了. 操作三:要在x后面添加一个字符,显然将x旋到根,x+1旋到根的右儿子,然后直接加在根的右儿子的左儿子上就可以了. 1 #include<iostream> 2 #include<cstdlib> 3 #include<cstdio&g

[BZOJ1014] [JSOI2008] 火星人prefix (splay &amp; 二分答案)

Description 火星人最近研究了一种操作:求一个字串两个后缀的公共前缀.比方说,有这样一个字符串:madamimadam,我们将这个字符串的各个字符予以标号:序号: 1 2 3 4 5 6 7 8 9 10 11 字符 m a d a m i m a d a m 现在,火星人定义了一个函数LCQ(x, y),表示:该字符串中第x个字符开始的字串,与该字符串中第y个字符开始的字串,两个字串的公共前缀的长度.比方说,LCQ(1, 7) = 5, LCQ(2, 10) = 1, LCQ(4,

【BZOJ-1014】火星人prefix Splay + 二分 + Hash

1014: [JSOI2008]火星人prefix Time Limit: 10 Sec  Memory Limit: 162 MBSubmit: 5852  Solved: 1871[Submit][Status][Discuss] Description 火星人最近研究了一种操作:求一个字串两个后缀的公共前缀.比方说,有这样一个字符串:madamimadam,我们将这个字符串的各个字符予以标号:序号: 1 2 3 4 5 6 7 8 9 10 11 字符 m a d a m i m a d

bzoj千题计划106:bzoj1014 [JSOI2008]火星人prefix

http://www.lydsy.com/JudgeOnline/problem.php?id=1014 两个后缀的最长公共前缀:二分+hash 带修改带插入:splay维护 #include<cstdio> #include<cstring> #include<iostream> #define L 100001 typedef unsigned long long ULL; using namespace std; char s[L+4]; int tot,root

bzoj1014: [JSOI2008]火星人prefix(splay+hash+二分)

题目大意:一个字符串三个操作:①求两个后缀的LCP②插入一个字符③修改一个字符. 前几天刚学了hash+二分求lcp,就看到这题. 原来splay还能这么用?!原来splay模板这么好写?我以前写的splay是假的吧woc splay每个节点代表一个字符,并维护这个子树代表一个子串的哈希值.因为splay旋转不破坏树结构,所以不论怎么旋转这棵splay树都能代表这个字符串. 预处理处理少了调了半天呜呜呜 赶紧跑去更新自己的splay模板 #include<iostream> #include&

bzoj1014: [JSOI2008]火星人prefix Hash+Splay

Splay维护Hash值,每次二分. #include<bits/stdc++.h> #define L(t) (t)->c[0] #define R(t) (t)->c[1] #define Z(t) (L(t)->s+1) #define N 100010 #define M (l+r>>1) typedef unsigned long long ull; ull a[N]; struct node{ int v,s; ull u; node* c[2]; n