hdoj 1686 Oulipo(KMP算法)

Oulipo

http://acm.hdu.edu.cn/showproblem.php?pid=1686

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5903    Accepted Submission(s): 2370

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

华东区大学生程序设计邀请赛_热身赛

//高大上的KMP算法(数据结构P82-83  严蔚敏版)

#include<cstdio>

#include<cmath>

#include<cstring>

#include<algorithm>

using namespace std;

char w[10005];

char t[1000005];

int nextval[10005];

void get_nextval(char s[])//求模式串S的nextval函数值并存入到nextval[]中

{

int i=0,j=-1;

nextval[0]=-1;

while(i<strlen(s))

{

if(j==-1||s[i]==s[j])

{

++i;

++j;

if(s[i]!=s[j])

nextval[i]=j;

else

nextval[i]=nextval[j];

}

else

j=nextval[j];

}

}

int KMP(char s[],char t[])//利用模式串t的nextval函数求t的主串s

{

int ls=strlen(s);

int lt=strlen(t);

int i=0,j=0,len=0;

while(i<=ls&&j<=lt)

{

if(j==-1||s[i]==t[j])//继续比较后继字符

{  ++i;++j; }

else

j=nextval[j]; //  模式串向右移动

if(j==lt)//通过nextval[]求得的j如果和模式串的长度相等就说明模式串在主串中出现了;

{

len++;

j=nextval[j];

}

}

return len;

}

int main()

{

int n;

scanf("%d",&n);

while(n--)

{

scanf("%s",w);

scanf("%s",t);

get_nextval(w);

int len=KMP(t,w);

printf("%d\n",len);

}

return 0;

}

时间: 2024-11-05 06:26:02

hdoj 1686 Oulipo(KMP算法)的相关文章

hdu 1686 Oulipo kmp算法

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1686 题目: Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait

POJ 3461 Oulipo KMP算法题解

本题就是给出很多对字符串,然后问一个字符串在另外一个字符串出现的次数. 就是所谓的Strstr函数啦. Leetcode有这道几乎一模一样的题目. 使用KMP算法加速,算法高手必会的算法了. 另外看见讨论说什么使用KMP还超时,最大可能是没有真正理解next table的含义,写了错误的代码,故此虽然自己运行结果正确,但是却没有真正发挥next table的作用,使得算法退化为暴力法了,所以运行正确,但超时. KMP参考: http://blog.csdn.net/kenden23/articl

[POJ] 3461 Oulipo [KMP算法]

Oulipo Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 23667   Accepted: 9492 Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote

HDU - 1686 Oulipo KMP匹配运用

HDU - 1686 Oulipo Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u Submit Status Description The French author Georges Perec (1936?1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Ouli

POJ3461 Oulipo KMP算法应用

题目描述 给定主串和模式串,问模式串在主串中出现的次数 Sample Input 3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN Sample Output 1 3 0 解题思路:KMP算法是找到一个匹配就跳出,这题是要计数,所以我们把KMP算法稍微改一下即可,在找到一个匹配(即j=模式串长度)时计数器++,再从next[j]开始找就好了.详见代码 #include <cstdio> #include <cstring> void Get

hdoj 1686 Oulipo【kmp】

Oulipo Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other) Total Submission(s) : 80   Accepted Submission(s) : 51 Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without

HDU - 1686 Oulipo (KMP)

Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: Tout avait Pair normal, mais tout s'affirmait faux. Tout avait Fair

hdoj 1686 Oulipo【求一个字符串在另一个字符串中出现次数】

Oulipo Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 7141    Accepted Submission(s): 2835 Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, wit

Hdoj 1686 Oulipo

/* Problem : Status : By wf, */ #include "algorithm" #include "iostream" #include "cstring" #include "cstdio" #include "string" #include "stack" #include "cmath" #include "queue&qu