Cisco路由器与三层交换机OSPF的基本组网应用

OSPF组网基本配置:

1. 三层交换机

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line. End withCNTL/Z.

Switch(config)#vlan 10                                      //创建VLAN

Switch(config-vlan)#interface vlan 10                       // 创建VLAN虚接口

%LINK-5-CHANGED: Interface Vlan10, changed state to up

Switch(config-if)#ip address 192.168.10.254255.255.255.0   // 设置VLAN虚接口地址

Switch(config-if)#interface fa0/1

Switch(config-if)#switchport access vlan 10             // 设置接口VLAN ID

%LINEPROTO-5-UPDOWN: Line protocol on InterfaceVlan10, changed state to up

Switch(config-if)#interface fa0/24                          // 进入接口配置模式

Router(config-if)#no shutdown                               // 启用/打开 接口

Switch(config-if)#no switchport                        // 交换模式改为路由模式

Switch(config-if)#ip address 192.168.20.1255.255.255.0 // 设置接口IP地址

Switch(config-if)#exit

Switch(config)#ip routing                                   //启用路由功能

Switch(config)#router ospf 1                                //创建ospf进程1

Switch(config-router)#network192.168.20.0 0.0.0.255 area 1 // 设置子网号与区域ID

Switch(config-router)#redistribute connected            //将直连链路发布到LSDB中

Switch(config-router)#exit

Switch(config)#exit

Switch#write                        // 保存当前配置到系统配置文件,以便下次启动使用

2. 路由器R0

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End withCNTL/Z.

Router(config)#hostname R1                              // 修改设备名称

R1(config)#interface fastEthernet 0/0                   // 进入接口配置模式

R1(config-if)#ip address 192.168.20.2 255.255.255.0     // 设置接口IP地址

R1(config-if)#no shutdown                               // 启用/打开 接口

R1(config-if)#interface fastEthernet 0/1

R1(config-if)#ip address 192.168.30.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)# router ospf 1                                 // 创建ospf进程1

R1(config-router)#network 192.168.20.0 0.0.0.255area 1   // 设置子网号与区域ID

R1(config-router)#network 192.168.30.0 0.0.0.255area 0   // 设置子网号与区域ID

R1(config-router)#exit

Router(config)#exit

Router#write

3. 路由器R1

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End withCNTL/Z.

Router(config)#hostname R1

R1(config)#interface fastEthernet 0/0

R1(config-if)#ip address 192.168.30.2 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#interface fastEthernet 0/1

R1(config-if)#ip address 192.168.40.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#router ospf 1

R1(config-router)#network 192.168.30.0 0.0.0.255area 0

R1(config-router)#network 192.168.40.0 0.0.0.255area 2

R1(config-router)#exit

R1(config)#exit

R1#write

4. 路由器R2

Router>enable

Router#confiure terminal

Enter configuration commands, one per line. End withCNTL/Z.

Router(config)#hostname R2

R2(config)#interface fastEthernet 0/0

R2(config-if)#ip address 192.168.40.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#interface fastEthernet 0/1

R2(config-if)#ip address 192.168.50.254 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#router ospf 1

R2(config-router)#network 192.168.40.0 0.0.0.255area 2

R2(config-router)#network 192.168.50.0 0.0.0.255area 2

R2(config-router)#exit

R2(config)#exit

R2#write

查看OSPF路由表:

1.三层交换机

Switch#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M- mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA -OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSAexternal type 2

E1 - OSPF external type 1, E2 - OSPF external type 2,E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia- IS-IS inter area

* - candidate default, U - per-user static route, o -ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, Vlan10

C 192.168.20.0/24 is directly connected,FastEthernet0/24

O IA 192.168.30.0/24 [110/2] via 192.168.20.2,00:07:08, FastEthernet0/24

O IA 192.168.40.0/24 [110/3] via 192.168.20.2,00:05:31, FastEthernet0/24

OIA 192.168.50.0/24 [110/4] via 192.168.20.2, 00:03:34, FastEthernet0/24

 

2.路由器R2

R2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M -mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA -OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA externaltype 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E -EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia -IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

O E2 192.168.10.0/24 [110/20] via 192.168.40.1,00:00:39, FastEthernet0/0

O IA 192.168.20.0/24 [110/3] via 192.168.40.1,00:03:57, FastEthernet0/0

O IA192.168.30.0/24 [110/2] via 192.168.40.1, 00:03:57, FastEthernet0/0

C 192.168.40.0/24 is directly connected, FastEthernet0/0

C 192.168.50.0/24 is directlyconnected, FastEthernet0/1

 

网络连通性测试:

时间: 2024-10-18 14:14:17

Cisco路由器与三层交换机OSPF的基本组网应用的相关文章

Cisco路由器的OSPF协议高级配置之“NSSA详解”

由于OSPF网络中末梢区域不允许存在ASBR,所以在一台属于末梢区域的路由器上配置重分发到OSPF区域是无法实现的.在重分发路由时,如果路由器所属区域类型是末梢区域,会有相应的提示出现,一定要注意观察,以免重分发路由失败,提示如下: Mar 1 00:06:58.555: %OSPF-4-ASBR_WITHOUT_VALID_AREA: Router is currently an ASBR while having only one area which is a stub area 解决方法

路由器与三层交换机实验演示 -- 充当两个vlan的网关

路由器与三层交换机实验演示 -- 充当两个vlan的网关 --百家菜  背景:我们到知道路由器有路由功能,那么你知道怎么在一个路由器接口上配置两个网关(比如两个vlan的网关)?注意是在一个接口上而不是两个:我们在有些时候会将三层交换机拿来当路由器使用,那么这个时候我们应该如何配置三层交换机呢?我们以单臂路由为例子来演示一下. 在这里我不多说,直接给大家演示在Packet Tracer6.0上的操作. 环境:windows操作系统,packet  tracer 6.0  实验一:直连路由 单臂路

CIsco路由器实现IPSec 虚拟专用网原理及配置详解

博文大纲:一.虚拟专用网概述:1.虚拟专用网的定义:2.虚拟专用网的模型与类型:(1)虚拟专用网的连接模式:(2)虚拟专用网的类型: 二.虚拟专用网技术:1.加密技术:(1)对称加密算法:(2)非对称加密算法:(3)密钥交换:2.数据报文验证:(1)HMAC功能实现验证功能:(2)MD5和SHA: 三.IPSec 虚拟专用网: 1.IPsec连接:2.ISAKMP/IKE阶段1:3.ISAKMP/IKE阶段2:四.配置实现IPSec 虚拟专用网:五.常用排错的命令: 关于虚拟专用网理论知识较多,

cisco路由器宽带拨号pppoe

(config) # vpdn enable (config) # vpdn-group pppoe (config-vpdn) #accept-dialin (config-vpdn-acc-in) # protocol pppoe (config) # inter f0/0 (config-if) # no ip address (config-if) # pppoe enable (config-if) # pppoe-client dial-pool-number 1 (config-i

Cisco路由器auto secure命令小结

路由器命令auto secure用起来比较方便,而且可以关闭一些不安全的服务和启用一些安全的服务.这里对这个命令做了一个总结.(注:ios版本为:12.3(1)以上才支持使用) 总结如下:     1.关闭一些全局的不安全服务如下: Finger PAD Small Servers Bootp HTTP service Identification Service CDP NTP Source Routing 2.开启一些全局的安全服务如下: PassWord-encryption servic

Cisco路由器的6种模式

Cisco路由器的6种模式 --------------------------------------------------------------------------------------------------------------------------------------------------- 普通模式router>路由器处于用户命令状态,这时用户可以看路由器的连接状态,访问其它网络和主机,但不能看到和更改路由器的设置内容. ---------------------

cisco路由器设置动态pppoe

CISCO上配置 PPPOE拨号 r1(config)#vpdn enable                                     开启虚拟拨号VPDN r1(config)#vpdn-group pppoe                                定义组名(pppoe) r1(config-vpdn)#request-dialin                             这里是请求拨入 r1(config-vpdn-req-in)#pr

Cisco路由器SSH登录

 当我们使用telnet登录到设备时,用户名和密码是采用明文的方式传输的,为了保证数据的安全,建议采用SSH的方式登录设备.以下就是Cisco路由器SSH的配置: 1. 配置hostname和domain-name R1(config)#hostname R1 R1(config)#ip domain-name frame.com 2. 产生密钥,这里产生的是1024位的密钥,密钥长度范围为360-2048 R1(config)#crypto key generate rsa general-k

利用PRTG实现对cisco路由器的cpu负载、端口流量等的监控

一.实验目的及前期准备 用gns3.vmware模拟真实的环境,利用prtg实现对cisco路由器状态的监控 前期准备:GNS3仿真路由软件和VMware虚拟软件,PRTG. 二.实验步骤 1)搭建如下拓扑环境 VMware server有2张网卡,一张(out)桥接到真实主机(Windows7)的网卡,另一张(in)连接到GNS3的R1路由器的e1/0上:R1路由器的e1/1和VMwar winxp的网卡相连. a)VMware安装一个server2003系统和一个xp系统,并虚拟3张虚拟网卡