hdu 4791 Alice's Print Service (DP+离线处理)

Alice‘s Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1163    Accepted Submission(s): 270

Problem Description

Alice is providing print service, while the pricing doesn‘t seem to be reasonable, so people using her print service found some tricks to save money.

For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It‘s easy to figure out that if you want to print 99 pages, the best choice is to print an
extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.

Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.

Input

The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.

Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105 ). The second line contains 2n integers s1, p1 , s2, p2 , ..., sn, pn (0=s1 < s2 <
... < sn≤ 109 , 109 ≥ p1 ≥ p2 ≥ ... ≥ pn ≥ 0).. The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1..n-1). The price
when printing no less than sn pages is pn cents per page. The third line containing m integers q1 .. qm (0 ≤ qi ≤ 109 ) are the queries.

Output

For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.

Sample Input

1
2 3
0 20 100 10
0 99 100

Sample Output

0
1000
1000

题意:给n种方案,打印量≥ si 时,每张纸的打印价格为pi(0≤n≤100000),问打印m次

询问,打印 qi 张时最少需要多少钱(0≤m≤100000)。

思路 : 先将询问都储存起来,然后按需求从小到大排序,依次求出答案,最后再输出。

#include <iostream>
#include <algorithm>
#include <cstdio>
#define ll long long
using namespace std;
const int maxn=100005;

struct node
{
    ll s,p,cost;
}a[maxn];
struct code
{
    int index;
    ll ans,num;
}b[maxn];
int n,m;

bool cmp1(code p,code q)
{
    return p.num<q.num;
}

bool cmp2(code p,code q)
{
    return p.index<q.index;
}

void input()
{
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)  scanf("%I64d%I64d",&a[i].s,&a[i].p);
    for(int i=0;i<m;i++)
    {
         scanf("%I64d",&b[i].num);
         b[i].index=i+1;
    }
    sort(b,b+m,cmp1);
}

void solve()
{
    a[n-1].cost=a[n-1].s*a[n-1].p;
    for(int i=n-2;i>=0;i--)  a[i].cost=min(a[i].s*a[i].p,a[i+1].cost);

    int cnt=0;
    for(int i=0;i<m;i++)
    {
         while(cnt<n && a[cnt].s<=b[i].num)  cnt++;
         if(cnt==n)  b[i].ans=b[i].num*a[n-1].p;
         else  b[i].ans=min(b[i].num*a[cnt-1].p,a[cnt].cost);
    }
    sort(b,b+m,cmp2);
    for(int i=0;i<m;i++)   printf("%I64d\n",b[i].ans);
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        input();
        solve();
    }
    return 0;
}

hdu 4791 Alice's Print Service (DP+离线处理)

时间: 2024-10-14 09:06:18

hdu 4791 Alice's Print Service (DP+离线处理)的相关文章

HDU 4791 Alice&#39;s Print Service 简单DP

连接:http://acm.hdu.edu.cn/showproblem.php?pid=4791 题意:打印问题,n次条件,打印量≥si时,每张纸的打印价格为pi(0≤n≤1e5),问打印m次询问,qi张时最少需要多少钱(0≤m≤1e5). 思路:如果对每次询问进行便利复杂度O(m*n)太大,超时.所以进行离线处理,将询问排序,从小到大依次处理,处理过程O(n+m),但排序过程是O(mlogm),所以总体的复杂度还是O(mlogm). 代码: #include <iostream> #inc

HDU 4791 Alice&#39;s Print Service

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4791 题面: Alice's Print Service Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1596    Accepted Submission(s): 380 Problem Description Alice is pr

HDU 4791 Alice&#39;s Print Service (2013长沙现场赛,二分)

Alice's Print Service Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1855    Accepted Submission(s): 454 Problem Description Alice is providing print service, while the pricing doesn't seem to

HDU 4791 Alice&#39;s Print Service(2013长沙区域赛现场赛A题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4791 解题报告:打印店提供打印纸张服务,需要收取费用,输入格式是s1 p1 s2 p2 s3 p3...表示打印区间s1到s2张纸的单价是p1,打印区间s2 到s3的单价是p2....最后是sn到无穷大的单价是pn,让你求打印k张纸的总费用最少是多少?有m次查询. 因为s1*p1 > s2 * p2 > s3*p3......,很显然,加入k所在的那个区间是第x个区间,那么最低费用要么是k * p

HDU 4791 Alice&#39;s Print Service 水二分

点击打开链接 Alice's Print Service Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1084    Accepted Submission(s): 240 Problem Description Alice is providing print service, while the pricing doesn't

HDU 4791 &amp; ZOJ 3726 Alice&#39;s Print Service (数学 打表)

题目链接: HDU:http://acm.hdu.edu.cn/showproblem.php?pid=4791 ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5072 Problem Description Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her pr

UVAlive 6611 Alice&#39;s Print Service 二分

Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.For example, the price when printing less than 100 pages is 20 cents per page, but when printing not

2013 ACM/ICPC 长沙现场赛 A题 - Alice&#39;s Print Service (ZOJ 3726)

Alice's Print Service Time Limit: 2 Seconds      Memory Limit: 65536 KB Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money. For example, the price when

HDU 6249 Alice’s Stamps(dp)

http://acm.hdu.edu.cn/showproblem.php?pid=6249 题意: 给出n个区间,求选k个区间的最大区间并. 思路: 可能存在左端点相同的多个区间,那么此时我们肯定选右端点最大的那个区间.现在将区间按左端点排序,d[i][j]表示在1-i坐标轴范围内选择j个区间的最大区间并. 状态转移方程如下: dp[i+1][j] = max(dp[i][j],dp[i+1][j]); //不选的话就和上一个一样 dp[i+num][j+1] = max(dp[i][j]+n