Radar Installation

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d
distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is
followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

题解:贪心为找到每个岛屿的最大区间,既在这个区间内任何一点都可以覆盖该岛屿,因为左端点的圆向右移动,高度(y坐标)变大,再一直到右端点达到最小高度,然后判断下一个岛屿的区间是不是和该岛屿有交集,有的话只需要一个,因为在上一个岛屿的区间随意移动都可以包含有交集的岛屿。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>

using namespace std;

struct Point
{
	double x;
	double y;
	bool operator< (Point t) const
	{
		return x < t.x;
	}
};

Point p[1003];

int main()
{
	int n;
	double d;
	int t = 1;
	while(scanf("%d%lf",&n,&d) != EOF && n != 0)
	{
		double a,b;
		bool flag = true;
		for(int i = 0;i < n;i++)
		{
			scanf("%lf%lf",&a,&b);
			if(b > d)
			{
				flag = false;
			}
			double t = sqrt(d * d - b * b);
			p[i].x = a - t;
			p[i].y = a + t;
		}
		printf("Case %d: ",t++);
		if(!flag)
		{
			printf("-1\n");
			continue;
		}
		sort(p,p + n);
		int ans = 1;
		int temp = 0;
		for(int i = 1;i < n;i++)
		{
			if(p[i].y < p[temp].y)  //取小的一个区间,特别注意 ,因为取大的话也许不能覆盖小的了
			{
				temp = i;
			}
			else if(p[i].x > p[temp].y)
			{
				ans++;
				temp = i;
			}
			ans++;
			temp = i;
		}
		printf("%d\n",ans);
	}

	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-14 21:40:19

Radar Installation的相关文章

[POJ1328] Radar Installation

Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, s

贪心 Radar Installation (求最少探测雷达)

Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, s

poj 1328 Radar Installation(贪心+快排)

Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, s

uva-2519 - Radar Installation

反正每一个岛都要有雷达覆盖,放雷达的时候尽可能多覆盖岛...... #include<iostream> #include<algorithm> #include<cstdio> #include<cmath> #include<cstring> using namespace std; struct node { double x,y; }; bool cmp(node a,node b) { return a.x<b.x; } int

B - Radar Installation poj 1328【贪心】

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island

poj 1328 Radar Installation (贪心)

Radar Installation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 52823   Accepted: 11883 Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point loca

POJ 1328、Radar Installation 贪心

jQuery的属性操作非常简单,下面以一个a元素来说明属性的获取/设置/删除操作 <body> <a>jquery.com</a> </body> 添加属性 $('a').attr('href', 'http://www.jquery.com') 添加多个属性 $('a').attr({'href':'http://www.jquery.com', 'title':'jquery.com'}) 获取属性 $('a').attr('href') class属性

[2016-02-04][POJ][1328][Radar Installation]

[2016-02-04][POJ][1328][Radar Installation] Radar Installation Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u Submit Status Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in

UVALive - 2519 Radar Installation 解题心得

原题: Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distanc