I Think I Need a Houseboat










Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 84918   Accepted: 36763

Description

Fred Mapper is considering purchasing some land in
Louisiana to build his house on. In the process of investigating the land, he
learned that the state of Louisiana is actually shrinking by 50 square miles
each year, due to erosion caused by the Mississippi River. Since Fred is hoping
to live in this house the rest of his life, he needs to know if his land is
going to be lost to erosion. 
After doing more research, Fred
has learned that the land that is being lost forms a semicircle. This semicircle
is part of a circle centered at (0,0), with the line that bisects the circle
being the X axis. Locations below the X axis are in the water. The semicircle
has an area of 0 at the beginning of year 1. (Semicircle illustrated in the
Figure.)

Input

The first line of input will be a positive integer
indicating how many data sets will be included (N). Each of the next N lines
will contain the X and Y Cartesian coordinates of the land Fred is considering.
These will be floating point numbers measured in miles. The Y coordinate will be
non-negative. (0,0) will not be given.

Output

For each data set, a single line of output should
appear. This line should take the form of: “Property N: This property will begin
eroding in year Z.” Where N is the data set (counting from 1), and Z is the
first year (start from 1) this property will be within the semicircle AT THE END
OF YEAR Z. Z must be an integer. After the last data set, this should print out
“END OF OUTPUT.”

Sample Input

2
1.0 1.0
25.0 0.0

Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

Hint

1.No property will appear exactly on the semicircle
boundary: it will either be inside or outside. 
2.This problem will be judged automatically. Your answer must match exactly,
including the capitalization, punctuation, and white-space. This includes the
periods at the ends of the lines.  3.All locations are given in
miles.

Codes:


#include<stdio.h>
int main(){
int n,m,j=1;
scanf("%d",&n);
while(n--){
float x,y,s;
scanf("%f%f",&x,&y);
s=3.1415926*(x*x+y*y);
m=(int)s/100.0+1.0;
printf("Property %d: This property will begin eroding in year %d.\n",j++,m);
}
printf("END OF OUTPUT.\n");
}

I Think I Need a Houseboat,布布扣,bubuko.com

时间: 2024-08-26 01:50:21

I Think I Need a Houseboat的相关文章

D - I Think I Need a Houseboat(1.3.1)

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u Submit Status Description Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the s

poj 1005:I Think I Need a Houseboat(水题,模拟)

I Think I Need a Houseboat Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 85149   Accepted: 36857 Description Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land,

HDU 1065.I Think I Need a Houseboat

I Think I Need a Houseboat Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 27   Accepted Submission(s) : 11 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Fred Mappe

POJ 1005 I Think I Need a Houseboat 水

 I Think I Need a Houseboat Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 92807   Accepted: 40360 Description Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the lan

HDU1065 I Think I Need a Houseboat 【数学递推】

I Think I Need a Houseboat Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9530    Accepted Submission(s): 2733 Problem Description Fred Mapper is considering purchasing some land in Louisiana

hdu 1065 I Think I Need a Houseboat 水题,不过看discuss,应该有很多人在PI上栽跟头了

I Think I Need a Houseboat Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10431    Accepted Submission(s): 2927 Problem Description Fred Mapper is considering purchasing some land in Louisiana

I Think I Need a Houseboat ZOJ(几何计算)

I Think I Need a Houseboat Time Limit: 2 Seconds Memory Limit: 65536 KB Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually s

【POJ1005】I Think I Need a Houseboat

说是计算几何,其实是一道水题.直接算半圆面积即可. 1 #include <iostream> 2 #include <cstdlib> 3 #include <cstdio> 4 #include <cstring> 5 #include <cctype> 6 #include <numeric> 7 #include <cmath> 8 #include <algorithm> 9 10 #define P

poj 1005 I Think I Need a Houseboat

1 #include <iostream> 2 using namespace std; 3 const double pi = 3.1415926535; 4 5 int main() 6 { 7 int t,time = 0;; 8 double x,y; 9 cin >> t; 10 while(t--) 11 { 12 ++time; 13 cin >> x >> y; 14 double area = pi*(x*x + y*y); 15 int