hdu 1505

City Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4516    Accepted Submission(s): 1909

Problem Description

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you‘re building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input

The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.

Output

For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output

45
0

乱搞,估计数据比较水

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <string>
#include <vector>
#include <list>
#include <map>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <numeric>
#include <functional>
using namespace std;
#define LL long long
#define DB double
#define N 1005
#define esp 1e-6
const int INF = 0x3f3f3f3f;
const LL INFF = 1LL << 60;
const DB EPS = 1e-9;
const DB OO = 1e15;
const DB PI = acos(-1.0);
char ma[N][N];
int dp[N][N],r[N],dp1[N][N];
int main()
{
    int i,j,k,t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        memset(ma,0,sizeof(ma));
        scanf("%d %d",&n,&m);
        for(i = 1; i <= n ; i++)
        {
            for(j = 1 ; j <= m ; j++)
            {
                cin>>ma[i][j];
            }
        }
        memset(dp,0,sizeof(dp));
        for(i = 1 ; i <= n ; i++)
        {
            for(j = 1 ; j <= m ; j++) r[j] = j+1;
            for(j = m ; j >=1 ; j--){
                if(ma[i][j]==‘F‘)
                {
                    int cur = r[j];
                    while(ma[i][cur]==‘F‘) cur = r[cur];
                    dp[i][j] = cur-j;
                }
            }
        }
        int ans = 0;
        memset(dp1,0,sizeof(dp1));
        for(j = 1 ; j <=m ; j++)
        {
            for(i= 1 ; i <= n ; i++) r[i] = i+1;
            for(i = n ; i>= 1; i--)  {
                if(ma[i][j]==‘F‘)
                {
                    int cur = r[i];
                    while(ma[cur][j] ==‘F‘) cur = r[cur];
                    dp1[i][j] = cur - i;
                }
            }
        }
        for(i = 1 ; i <= n ; i++)
        {
            for(j = 1 ; j <= m ; j++)
            {
                if(dp[i][j]>0&&dp1[i][j]>0&&dp[i][j]*dp1[i][j]>ans)
                {
                    int a = INF;
                    for(k = 0 ; k<dp[i][j] ; k++)
                        a = min(a,dp1[i][j+k]);
                    ans = max(ans,a*dp[i][j]);
                    a = INF;
                    for(k = 0 ; k <dp1[i][j] ; k++)
                        a = min(a,dp[i+k][j]);
                    ans = max(ans,a*dp1[i][j]);
                }
            }
        }
        printf("%d\n",ans*3);
    }
    return 0;
}

hdu 1505,布布扣,bubuko.com

时间: 2024-10-15 05:41:48

hdu 1505的相关文章

HDU 1505 City Game (hdu1506 dp二维加强版)

F - City Game Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1505 Appoint description: Description Bob is a strategy game programming specialist. In his new city building game the gaming enviro

HDU 1505 Largest Rectangle in a Histogram &amp;&amp; HDU 1506 City Game(动态规划)

1506题意:给你连续的直方图(底边边长为1),求连续的矩阵面积. 对每个直方图,分别向左向右进行扩展. #include<cstdio> #include<stdlib.h> #include<string.h> #include<string> #include<map> #include<cmath> #include<iostream> #include <queue> #include <sta

HDU - 1505 City Game(dp)

题意:求由R和F组成的矩阵中,最大的由F组成的矩阵面积. 分析: 1.hdu1506http://www.cnblogs.com/tyty-Somnuspoppy/p/7341431.html与此题相似. 2.将矩阵的每行看成1506中的坐标轴分别处理. 3.算出以该行为坐标轴,坐标轴上,每个由F组成的矩形的高度,与1506的区别是,1506中每个矩形高度已知. 4.按照1506的方法分别算出每个矩形最左边和最右边连续比其高的矩形的下标,通过(r[i][j] - l[i][j] + 1) * h

hdu 1505 City Game 最大矩形面积 单调队列

City Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5106    Accepted Submission(s): 2197 Problem Description Bob is a strategy game programming specialist. In his new city building game t

hdu 1505 City Game (hdu1506加强版)

# include <stdio.h> # include <algorithm> # include <string.h> # include <iostream> using namespace std; char a[1010][1010]; int dd[1010][1010];///宽度 int r[1010],l[1010]; int main() { int t,i,j,n,m,max1; while(~scanf("%d"

HDU 1505 City Game(01矩阵 dp)

Problem Description Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space i

HDU 1505 City Game

题意就是求最大子矩阵. 白书上的例题. 如果暴力枚举 左上角,然后长和宽.时间复杂度为O(m^3*n^3). 可以定义up[][] 为某个格子最大高度, 定义 left[][]为某个格子左扫描最大. 定义 right[][]为右扫描的最大. 最后乘起来. #include<cstdio> #include<cstring> #include<string> #include<queue> #include<algorithm> #include&

hdu 1505(最大子矩阵)

City Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6140    Accepted Submission(s): 2618 Problem Description Bob is a strategy game programming specialist. In his new city building game th

hdu 1505 City Game(hdu1506的二维推广)

1.输入的时候数据的时候要注意 2.1506的二维推广 代码: #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int INF=1<<30; int a[1005][1005]; int L[1005]; int R[1005]; int main() { int t; int m,n; int ans; char s[10]; scanf(&