POJ1505 Copying Books(二分法)

B - 二分

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so calledscribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered ) that may have different number of pages ( ) and you want to make one copy of each of them. Your task is to divide these books among k scribes, . Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers  such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k. At the second line, there are integers  separated by spaces. All these values are positive and less than 10000000.

Output

For each case, print exactly one line. The line must contain the input succession  divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/‘) to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

Sample Output

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

题解:最大值尽量小,让一个包含m个正整数的序列划分成k个非空的连续子序列,是的每个正整数恰好属于一个子序列。设第i个序列的各个数之和为s(i),让所有的是s(i)的最大值尽量小。

每个整数不得超过10的7次方,如果有多解,s(1)应该尽量小,如果仍然有多解,s(2)应该尽量小,依此类推。

解题的关键是找到一个限值,所有的是s(i)均不超过x,从右向左划分,这个x的范围(序列中最大的值~序列所有值的和)

AC代码:

#include <iostream>
#include <cstring>
using namespace std;
int m,k;
int b[502],f[502];
long long total;
int juge(long long x)
{
    total=1;
    long long sum=0;
    memset(f,0,sizeof(f));
    for(int i=m-1;i>=0;i--)
    {
        sum+=b[i];
        if(sum>x)
        {
            total++;
            sum=b[i];
            f[i]=1;
        }
    }
    return total;
}
int main()
{
    int t;
    long long r,l;
    cin>>t;
    while(t--)
    {
        cin>>m>>k;
        l=r=0;
        for(int i=0; i<m; i++)
        {
            cin>>b[i];
            if(b[i]>l)
            {
                l=b[i]; //限值是从序列的最大值到序列所有值的和之间找
            }
            r+=b[i];
        }
        while(l<r)
        {
            int mid=(l+r)/2;
            if(juge(mid)<=k)
                r=mid;
            else
                l=mid+1;
        }
        int total=juge(r);
       // cout<<r;               //输出所找的限值,如过这里对了,基本就过了
        for(int i=0;i<m;i++)
        {
            if(total<k)
                if(!f[i])
                {
                    f[i]=1;
                    total++;
                }
        }
            cout<<b[0];
            for(int i=1;i<m; i++)
            {
                if(f[i-1])  cout<<" /";
                    cout<<‘ ‘<<b[i];
            }
            cout<<endl;
        }
        return 0;
    }
时间: 2024-10-12 07:50:47

POJ1505 Copying Books(二分法)的相关文章

POJ1505:Copying Books 解题心得

原题: Description Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. On

UVa714 Copying Books (二分法,贪心)

链接:http://vjudge.net/problem/UVA-714 分析:二分枚举最小值,用贪心的思想每段序列尽量往右划分,注意:因为要求字典序最小解,输出时还有一个贪心过程,左起S[i]尽量小,相当于右起S[j]尽量大,还有一种情况是剩下的数之和已经小于等于ans,但是此时剩余要分配的组数还有多(remain>1). 1 #include <cstdio> 2 #include <algorithm> 3 #include <cstring> 4 usin

POJ1505&amp;&amp;UVa714 Copying Books(DP)

Copying Books Time Limit: 3000MS Memory Limit: 10000K Total Submissions: 7109 Accepted: 2221 Description Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scri

uva 714 Copying Books (二分)

uva 714 Copying Books Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its co

uva 714 - Copying Books(贪心 最大值最小化 二分)

题目描述开头一大堆屁话,我还仔细看了半天..其实就最后2句管用.意思就是给出n本书然后要分成k份,每份总页数的最大值要最小.问你分配方案,如果最小值相同情况下有多种分配方案,输出前面份数小的,就像字典序输出从小到大一样的意思. 这里用到贪心的方法,定义f(x)为真的条件是满足x为最大值使n本书分成k份,那么就是求x的最小值.如何确定这个x就是用的二分法,x一定大于0小于所有值的合,不断的二分再判断是否成立,成立就取左半边,不成立说明太小了就取右半边,写的时候还是没有把二分法理解透彻,我还怕会丢失

poj 1505 Copying Books

http://poj.org/problem?id=1505 Copying Books Time Limit: 3000MS   Memory Limit: 10000K Total Submissions: 7053   Accepted: 2200 Description Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be r

UVa 714 Copying Books(贪心 二分)

题意  把m数分成k组  使每组数的和的最大值最小  如果有多种分法 靠前的组的和尽量小 关键是找出那个最小的最大值   可以通过二分来找出  开始左端点为m个数中最大的数  右端点为m个数的和  若中点能将m个数分为小于等于k组  比它大的肯定都是可以的  中点变为右端点   否则中点变成左端点 然后就可以贪心逆向模拟了  从后往前每组选择尽量多的数直到剩下的数等于组数 #include <bits/stdc++.h> using namespace std; typedef long lo

POJ 1505 (Copying Books)(经典二分)

Description Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of

UVa 714 - Copying Books 二分答案

题目链接:714 - Copying Books 解题思路 具体处理方法见代码 /************************************************************** Problem: User: youmi Language: C++ Result: Accepted Time: Memory: ****************************************************************/ //#pragma comm