Divideing Jewels

Divideing Jewels

时间限制: 1 Sec  内存限制: 128 MB
提交: 63  解决: 17
[提交][状态]

题目描述

Mary
and Rose own a collection of jewells. They want to split the collection
among themselves so that both receive an equal share of the jewels.
This would be easy if all the jewels had the same value, because then
they could just split the collection in half. But unfortunately, some of
the jewels are larger, or more beautiful than others. So, Mary and Rose
start by assigning a value, a natural number between one and ten, to
each jewel. Now they want to divide the jewels so that each of them gets
the same total value. Unfortunately, they realize that it might be
impossible to divide the jewels in this way (even if the total value of
all jewels is even). For example, if there are one jewel of value 1, one
of value 3 and two of value 4, then they cannot be split into sets of
equal value. So, they ask you to write a program that checks whether
there is a fair partition of the jewels.

输入

Each
line in the input file describes one collection of jewels to be
divided. The lines contain ten non-negative integers n1 , . . . , n10 ,
where ni is the number of jewels of value i. The maximum total number of
jewells will be 10000.
The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line.

输出

For
each collection, output "#k:", where k is the number of the test case,
and then either "Can be divided." or "Can‘t be divided.".
Output a blank line after each test case.

样例输入

1 0 1 2 0 0 0 0 2 0
1 0 0 0 1 1 0 0 0 0
0 0 0 0 0 0 0 0 0 0

样例输出

#1:Can‘t be divided.

#2:Can be divided.

提示

来源

第五届河南省大学生程序设计竞赛

你一定要好好看题,一定先要==||

#include<iostream>
#include<cstdio>

using namespace std;

int sum[15], tot, flag;

void DFS(int q)   // q用来存现在分到的价值
{
      int i;
      if(flag)
          return ;
      if(q == tot)  //如果价值==tot就是可以平分
      {
          flag = 1;
          return ;
      }
      for(i = 10; i > 0; --i)  //从后往前加,后边价值大
      {
          if(sum[i] > 0 && q+i <= tot)  //  i 是价值,sum【i】是i 这个价值的有几个~
          {
              sum[i]--;  //加上一个就减去一个
              DFS(q+i); //看q+i 是否够一半
              if(flag)
                  return ;
          }
      }
}
int main()
{
      int i, t;
 
      for(t = 1; ; t++)  //循环开始
      {
            tot = 0;
            for(i = 1; i <= 10; i++)
            {
                cin >> sum[i];
                tot += sum[i] * i;  // sum【i】是i 这个价值的有几个!!tot总价值
            }

     if(!tot)
                break; // 价值为零,循环结束,程序结束

     if(tot & 1)  //tot是奇数
            {
                  printf("#%d:Can‘t be divided.\n", t);
                  continue;
            }
            tot >>= 1; // >>位运算里边的东西,可以百度一下,这句话意思就是tot /=2;
            flag = false; 
            DFS(0);

     if(flag)
                  printf("#%d:Can be divided.\n", t);
            else printf("#%d:Can‘t be divided.\n", t);
      }
    return 0;
}

sum【i】是i 这个价值的珠宝有几个!!

~~

分享更好链接:

http://www.cnblogs.com/dongsheng/archive/2013/04/22/3036160.html

时间: 2024-10-31 03:25:46

Divideing Jewels的相关文章

Divideing Jewels(nyoj546)(多重背包+二进制优化)

Divideing Jewels 时间限制:1000 ms  |  内存限制:65535 KB 难度:4 描述 Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same

Divideing Jewels【dfs或DP】

Divideing Jewels Time Limit: 1 Sec Memory Limit: 128 MB Submit: 164 Solved: 22 [Submit][Status][Web Board] Description Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share o

nyoj 546——Divideing Jewels——————【dp、多重背包板子题】

Divideing Jewels 时间限制:1000 ms  |  内存限制:65535 KB 难度:4 描述 Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same

nyoj546 Divideing Jewels (动态规划+优化||搜索+剪枝)

题意:给你n个宝珠,然后给宝珠个价值,价值范围[1,10],能不能均分给两个人. 输入的数据:价值分别为1,2,3...10的有多少个. 这道题和队友做了好久最终在结束前5分钟AC..第一次简单的动规结果TLE 不过和队友认为一定是动规.就在想如何优化,想到如果某个价值的个数有偶数个就不判断,奇数个就存入数组. 结果还是wr...我们不放弃啊...为就想着写几组数组,当0 2 0 1 0 0 0 0 0 0 输出结果为不能,显然答案是能的. 还剩下不到20分钟了.这个时候就是靠感觉了,直接就写如

河南省第五届ACM程序设计大赛

D:   遥 控 器 #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> #include<cmath> #include<queue> #include<vector> #include<map> using namespace std; typedef unsigned long long LL; #define

HDU 1044 Collect More Jewels【BFS+DFS+建立距离图】

Collect More Jewels Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6707    Accepted Submission(s): 1556 Problem Description It is written in the Book of The Lady: After the Creation, the cruel

Collect More Jewels(hdu1044)(BFS+DFS)

Collect More Jewels Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6857    Accepted Submission(s): 1592 Problem Description It is written in the Book of The Lady: After the Creation, the cruel

Picking up Jewels

Picking up Jewels There is a maze that has one entrance and one exit. Jewels are placed in passages of the maze. You want to pick up the jewels after getting into the maze through the entrance and before getting out of it through the exit. You want t

codechef Jewels and Stones 题解

Soma is a fashionable girl. She absolutely loves shiny stones that she can put on as jewellery accessories. She has been collecting stones since her childhood - now she has become really good with identifying which ones are fake and which ones are no