(一道模板题) 无源汇有上下界可行流

题目描述

这是一道模板题。

n 个点,m  条边,每条边 e  有一个流量下界 lower(e) 和流量上界 upper(e),求一种可行方案使得在所有点满足流量平衡条件的前提下,所有边满足流量限制。

输入格式

第一行两个正整数 n 、m 。

之后的 m 行,每行四个整数 s 、t 、lower 、upper。

输出格式

如果无解,输出一行 NO

否则第一行输出 YES,之后 m  行每行一个整数,表示每条边的流量。

样例

样例输入 1

4 6
1 2 1 2
2 3 1 2
3 4 1 2
4 1 1 2
1 3 1 2
4 2 1 2

样例输出 1

NO

样例输入 2

4 6
1 2 1 3
2 3 1 3
3 4 1 3
4 1 1 3
1 3 1 3
4 2 1 3

样例输出 2

YES
1
2
3
2
1
1

数据范围与提示

N<=200,M<=10200

分类标签

模板 上下界网络流 网络流

码了一天了懒得再打一下上下界网络流原理来,,,就是一个流量平衡。

#include<bits/stdc++.h>
#define ll long long
#define maxn 1005
#define pb push_back
using namespace std;
const int inf=1<<29;
vector<int> g[maxn];
struct lines{
    int to,flow,cap;
}l[maxn*maxn];
int t=-1,S,T,n,m;
int d[maxn],cur[maxn];
bool v[maxn];

inline void add(int xx,int yy,int zz){
    l[++t]=(lines){yy,0,zz},g[xx].pb(t);
    l[++t]=(lines){xx,0,0},g[yy].pb(t);
}

inline bool bfs(){
    queue<int> q;
    memset(v,0,sizeof(v));
    d[S]=0,v[S]=1,q.push(S);

    int x; lines e;
    while(!q.empty()){
        x=q.front(),q.pop();
        for(int i=g[x].size()-1;i>=0;i--){
            e=l[g[x][i]];
            if(!v[e.to]&&e.flow<e.cap){
                d[e.to]=d[x]+1;
                v[e.to]=1;
                q.push(e.to);
            }
        }
    }

    return v[T];
}

int dfs(int x,int a){
    if(x==T||!a) return a;
    int flow=0,f,sz=g[x].size();
    for(int &i=cur[x];i<sz;i++){
        lines &e=l[g[x][i]];
        if(d[x]==d[e.to]-1&&(f=dfs(e.to,min(a,e.cap-e.flow)))){
            flow+=f,a-=f;
            e.flow+=f,l[g[x][i]^1].flow-=f;
            if(!a) break;
        }
    }

    return flow;
}

inline int max_flow(){
    int an=0;
    while(bfs()){
        memset(cur,0,sizeof(cur));
        an+=dfs(S,inf);
    }
    return an;
}

int low[maxn*50],inflow[maxn],tot=0;
int main(){
    int uu,vv,r;
    scanf("%d%d",&n,&m);
    for(int i=0;i<m;i++){
        scanf("%d%d%d%d",&uu,&vv,low+i,&r);
        add(uu,vv,r-low[i]);
        inflow[vv]+=low[i];
        inflow[uu]-=low[i];
    }

    S=0,T=n+1;
    for(int i=1;i<=n;i++){
        if(inflow[i]>0){
            add(S,i,inflow[i]);
            tot+=inflow[i];
        }
        else if(inflow[i]) add(i,T,-inflow[i]);
    }

    if(tot!=max_flow()) puts("NO");
    else{
        puts("YES");
        for(int i=0;i<m;i++) printf("%d\n",low[i]+l[i<<1].flow);
    }

    return 0;
}

原文地址:https://www.cnblogs.com/JYYHH/p/8361696.html

时间: 2024-10-23 19:17:13

(一道模板题) 无源汇有上下界可行流的相关文章

[loj#115] 无源汇有上下界可行流 网络流

#115. 无源汇有上下界可行流 内存限制:256 MiB时间限制:1000 ms标准输入输出 题目类型:传统评测方式:Special Judge 上传者: 匿名 提交提交记录统计讨论测试数据 题目描述 这是一道模板题. n nn 个点,m mm 条边,每条边 e ee 有一个流量下界 lower(e) \text{lower}(e)lower(e) 和流量上界 upper(e) \text{upper}(e)upper(e),求一种可行方案使得在所有点满足流量平衡条件的前提下,所有边满足流量限

LOJ #115. 无源汇有上下界可行流

#115. 无源汇有上下界可行流 描述 这是一道模板题. n n n 个点,m m m 条边,每条边 e e e 有一个流量下界 lower(e) \text{lower}(e) lower(e) 和流量上界 upper(e) \text{upper}(e) upper(e),求一种可行方案使得在所有点满足流量平衡条件的前提下,所有边满足流量限制. 输入格式 第一行两个正整数 n n n.m m m. 之后的 m m m 行,每行四个整数 s s s.t t t.lower \text{lowe

无源汇有上下界可行流存在定理

H - Reactor Cooling Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu Submit Status Description The terrorist group leaded by a well known international terrorist Ben Bladen is buliding a nuclear reactor to produce plutonium

sgu194 Reactor Cooling【无源汇有上下界可行流】

这是模板题了吧,先建立附加源汇,然后保留每个点的in-out,如果这个值是正的,那么就从附加源先这个点连一个边权为in-out的边,否则从这个点向附加汇连一条相反数的边,剩下题目中的边就用上界-下界连就好了. 1 #include <bits/stdc++.h> 2 #define rep(i, a, b) for (int i = a; i <= b; i++) 3 #define drep(i, a, b) for (int i = a; i >= b; i--) 4 #def

ZOJ 2314 Reactor Cooling(无源汇有上下界可行流)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2314 题目大意: 给n个点,及m根pipe,每根pipe用来流躺液体的,单向的,每时每刻每根pipe流进来的物质要等于流出去的物质,要使得m条pipe组成一个循环体,里面流躺物质. 并且满足每根pipe一定的流量限制,范围为[Li,Ri].即要满足每时刻流进来的不能超过Ri(最大流问题),同时最小不能低于Li. 解题思路: 转自:https://www.cnbl

hdu 4940 无源汇有上下界最大流

题意:给出一个有向强连通图,每条边有两个值分别是破坏该边的代价和把该边建成无向边的代价(建立无向边的前提是删除该边)问是否存在一个集合S,和一个集合的补集T,破坏所有S集合到T集合的边代价和是X,然后修复T到S的边为无向边代价和是Y,满足Y<X:满足输出unhappy,否则输出happy:</span> <span style="font-family: Arial, Helvetica, sans-serif;">分析:无源汇有上下界可行流判定, 原来每

【HDU 4940】Destroy Transportation system(数据水/无源无汇带上下界可行流)

Description Tom is a commander, his task is destroying his enemy’s transportation system. Let’s represent his enemy’s transportation system as a simple directed graph G with n nodes and m edges. Each node is a city and each directed edge is a directe

ZOJ2314 Reactor Cooling 无源汇有上下界最大流

推荐看这里 #include <iostream> #include <cstring> #include <cstdio> #include <queue> using namespace std; int n, m, uu, vv, ww, cc, hea[225], cnt, ss, tt, maxFlow, lev[225], tot, T; const int oo=0x3f3f3f3f; struct Edge{ int too, nxt, ca

ZOJ--2314--Reactor Cooling【无源汇上下界可行流】

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1314 题意:某恐怖组织要建立一个核反应堆,他们需要设计一个冷却系统,n个点由m个管子连接,为使液体循环流动,每个节点的总流入量需要等于总流出量,现告诉你每根管子的最小流量及最大流量及它们连接的两点(有向),问是否存在可行流,如存在,输出每个管子的流量. 有上下界的网络流分为四种:无源汇的上下界可行流.有源汇的上下界可行流.有源汇的上下界最大流.有源汇的上下界最小流,这道