PAT1018

1018. 锤子剪刀布 (20)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

大家应该都会玩“锤子剪刀布”的游戏:两人同时给出手势,胜负规则如图所示:

现给出两人的交锋记录,请统计双方的胜、平、负次数,并且给出双方分别出什么手势的胜算最大。

输入格式:

输入第1行给出正整数N(<=105),即双方交锋的次数。随后N行,每行给出一次交锋的信息,即甲、乙双方同时给出的的手势。C代表“锤子”、J代表“剪刀”、B代表“布”,第1个字母代表甲方,第2个代表乙方,中间有1个空格。

输出格式:

输出第1、2行分别给出甲、乙的胜、平、负次数,数字间以1个空格分隔。第3行给出两个字母,分别代表甲、乙获胜次数最多的手势,中间有1个空格。如果解不唯一,则输出按字母序最小的解。

输入样例:

10
C J
J B
C B
B B
B C
C C
C B
J B
B C
J J

输出样例:

5 3 2
2 3 5
B B
package com.lwh.agrithmatic.paractice;
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
public class Practise13{
  public static void main(String[] args) throws IOException {
    BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
    int n=Integer.parseInt(br.readLine());
    String[] a=new String[n];
    String [] b=new String[n];
    for(int i=0;i<n;i++){
      String input=br.readLine();
      a[i]=input.split(" ")[0];
      b[i]=input.split(" ")[1];
    }
    int awintime=0;
    int bwintime=0;
    int equal=0;
    int ac=0;
    int aj=0;
    int ab=0;
    int bc=0;
    int bj=0;
    int bb=0;
    for(int i=0;i<n;i++){

      if(a[i].equals("C")){
        if(b[i].equals("J"))
        {
          awintime++;
          ac++;
        }else if(b[i].equals("B")){
          bwintime++;
          bb++;
        }else{
          equal++;
        }
      }

      if(a[i].equals("J")){
        if(b[i].equals("B")){
          awintime++;
          aj++;
        }else if(b[i].equals("C")){
          bwintime++;
          bc++;
        }else{
          equal++;
        }
      }
      if(a[i].equals("B")){
        if(b[i].equals("C")){
          awintime++;
          ab++;
        }else if(b[i].equals("J")){
          bwintime++;
          bj++;
        }else{
          equal++;
        }
      }
    }

    System.out.println(awintime+" "+equal+" "+(n-awintime-equal));
    System.out.println(bwintime+" "+equal+" "+(n-bwintime-equal));
    int maxa=ab;
    int maxb=bb;
    String taga="B";
    if(ac>maxa){
      maxa=ac;
      taga="C";
    }
    if(aj>maxa){
      maxa=aj;
      taga="J";
    }
    String tagb="B";
    if(bc>maxb){
      maxb=bc;
      tagb="C";
    }
    if(bj>maxb){
      maxb=bj;
      tagb="J";
    }
   System.out.println(taga+" "+tagb);
  }

}
时间: 2024-10-12 21:56:18

PAT1018的相关文章

PAT1018. Public Bike Management (30)

题目传送门 分析 Dijstra + DFS搜索,难点在于存在多条最短路径,因此需要用vector<int> pre[N] 记录路径. 代码 自己写的有些问题,有两个数据没过,就不放上来了.下面的代码来自于https://www.liuchuo.net/archives/2373 #include <cstdio> #include <algorithm> #include <vector> using namespace std; const int in

PAT1018. Public Bike Management

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world.  One may rent a bike at any station and return it to any other stations in the city. The Public Bike Management Center (PBMC) ke

PAT-1018 Public Bike Management (30)

直接用dijkstra求取,只能拿到22,四个case过不了 #include<stdio.h> #include<stack> using namespace std; int bike_count[510]; int bike_sum[510]; int bike_sum_num[510]; int map[510][510]; bool visited[510]; int d[510]; int pre[510]; int Max=0xffffffff>>1; /

PAT1018. 锤子剪刀布 (20)

大家应该都会玩“锤子剪刀布”的游戏:两人同时给出手势,胜负规则如图所示“ 现给出两人的交锋记录,请统计双方的胜.平.负次数,并且给出双方分别出什么手势的胜算最大. 输入格式: 输入第1行给出正整数N(<=105),即双方交锋的次数.随后N行,每行给出一次交锋的信息,即甲.乙双方同时给出的的手势.C代表“锤子”.J代表“剪刀”.B代表“布”,第1个字母代表甲方,第2个代表乙方,中间有1个空格. 输出格式: 输出第1.2行分别给出甲.乙的胜.平.负次数,数字间以1个空格分隔.第3行给出两个字母,分别

Pat(Advanced Level)Practice--1018(Public Bike Management)

Pat1018代码 题目描述: There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city. The Public Bike Management C