UVA 315 Network

Description:

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input:

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0.

Output:

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input:

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output:

1
2

题意:电话线都是连通的,假如有些接点发生了故障,可能整个系统还是互通的,也可能致使有些地方不能互通,现在需要判断一个电话系统中有几个不能出故障的接点(即连通图求割点)

求割点:
  一个顶点u是割点,当且仅当满足(1)或(2)
 (1) u为树根,且u有多于一个子树。
 (2) u不为树根,且满足存在(u,v)为树枝边(或称 父子边,即u为v在搜索树中的父亲),使得 dfn(u)<=low(v)。
 (也就是说 V 没办法绕过 u 点到达比 dfn[u] 要小的点)
  注:这里所说的树是指,DFS下的搜索树

#include<stdio.h>
#include<algorithm>
#include<vector>
#include<string.h>
#define N 110
using namespace std;
int dfn[N], low[N];
int f[N], vis[N]; //f数组表示父节点,vis数组标记该点是否为割点
int n, Time;
vector<vector<int> >G;
void Init()
{
    G.clear();
    G.resize(n+1);
    memset(dfn, 0, sizeof(dfn));
    memset(low, 0, sizeof(low));
    memset(f, 0, sizeof(f)); //将父节点都初始化为0
    memset(vis, 0, sizeof(vis));
    Time = 0;
}
void Tarjan(int u, int fa)
{
    int i, len, v;
    dfn[u] = low[u] = ++Time;
    f[u] = fa;
    len = G[u].size();
    for (i = 0; i < len; i++)
    {
        v = G[u][i];
        if (!dfn[v])
        {
            Tarjan(v, u);
            low[u] = min(low[u], low[v]);
        }
        else if (v != fa) low[u] = min(low[u], dfn[v]); //这里注意不能写成low[v],如果写成low[v],意味着可以越过该点到比该点更早的点,实际上不一定
    }
}
int main ()
{
    int a, b, son, ans, i, ni;
    char ch;
    while (scanf("%d", &n), n)
    {
        Init();
        son = ans = 0;
        while (scanf("%d", &a), a)
        {
            while (scanf("%d%c", &b, &ch) != EOF)
            {
                G[a].push_back(b);
                G[b].push_back(a);
                if (ch == ‘\n‘) break;
            }
        }
        Tarjan(1, 0);
        for (i = 2; i <= n; i++)
        {
            ni = f[i];
            if (ni == 1) son++;
            else if (dfn[ni] <= low[i]) vis[ni] = 1;
        }
        for (i = 2; i <= n; i++)
            if (vis[i]) ans++;
        if (son > 1) ans++; //如果son>1,则代表根节点有超过1个的子节点,根节点是割点
        printf("%d\n", ans);
    }
    return 0;
}
时间: 2024-10-14 00:55:31

UVA 315 Network的相关文章

UVA - 315 Network 和 UVA - 10199 (求割顶)

链接 :  http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=20837 http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=21278 求割顶的裸题. UVA - 315 #include <algorithm> #include <iostream> #include <sstream> #include <cstrin

uva 315 Network(连通图求割点)

https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=251  Network  A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers

UVA 315 Network(无向图求割点)

题目大意 A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two pl

POJ 1144 &amp; Uva 315 Network 【求割点数目】

Network Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10855   Accepted: 5020 链接:http://poj.org/problem?id=1144 Description A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places

UVA - 315 Network(tarjan求割点的个数)

题目链接:https://vjudge.net/contest/67418#problem/B 题意:给一个无向连通图,求出割点的数量.首先输入一个N(多实例,0结束),下面有不超过N行的数,每行的第一个数字代表后面的都和它存在边,0表示行输入的结束. 题解:简单的求割点模版,所谓割点就是去掉这一个点还有于这个点链接的边之后使得原来的图连通块增加. 由于这是模版题代码会加上注释. #include <iostream> #include <cstring> using namesp

Uva 315 Network 判断割点

模板题,注意输出 #include <stdio.h> #include <string.h> #include <algorithm> #include <math.h> #include <vector> #include <stack> using namespace std; typedef long long LL; const int N = 1e2+5; int head[N],tot,n; struct Edge{ i

无向图求割点 UVA 315 Network

输入数据处理正确其余的就是套强联通的模板了 #include <iostream> #include <cstdlib> #include <cstdio> #include <algorithm> #include <vector> #include <queue> #include <cmath> #include <stack> #include <cstring> using namespa

uva 1267 Network(DFS)

uva 1267 Network Consider a tree network with n nodes where the internal nodes correspond to servers and the terminal nodes correspond to clients. The nodes are numbered from 1 to n . Among the servers, there is an original server S which provides VO

UVA 315 求割点数

题目链接:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=251 测模版: #include <stdio.h> #include <iostream> #include <algorithm> #include <string.h> #include <queue> #includ