动态规划解决杭电OJ1080题——LCS的变种

首先上题目:

Human Gene Functions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2570    Accepted Submission(s): 1451

Problem Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because
these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in
determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes
and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that
the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score
the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned:

AGTGAT-G

-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG

-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence
is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA 

Sample Output

14
21 

题目的意思是:

给定两个字符串a,b;其中两个字符串中的字母两两对应都有一个权值,并且两个字符串可以任意添加空格,使得有更多的字符可以对应,例如Given two genes AGTGATG and GTTAG,可以写成

AGTGAT-G

-GT--TAG

这样的最终对应权值是The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

也可以写成

AGTGATG

-GTTA-G

这样的对应权值之和是(-3)+5+5+(-2)+5+(-1) +5=14,因为空格的加入,可以有很多种不同的权值和,要求的是最大的权值和。

我们看到题首先想到的是LCS,最长公共子序列,下面给个最长公共子序列dp的图以便读者对比:

而对于当前题目就是LCS的变种,是一种带有权值的最长公共子序列,这个权值要求就是满足如下矩阵且使权值和最大:

与上LCS结果状态对比图如下所示:

转移方程就是:dp[i][j]=max(a,b,c);//三个值中的最大值,a,b,c分别由左上,左,上三个方向的值加一数得到;

a=dp[i-1][j-1]+m[s1[i]][s2[j]]; //m[x][y]指x和y对应的值,假如x=A,y=G,则m[x][y]=-2,若x=T,y=‘-‘,则m[x][y]=-1;

b=dp[i][j-1]+m[‘-‘][s2[j]];

c=dp[i-1][j]+m[s1[i][‘-‘];

下面给个C++代码参考:

#include<iostream>
//#include<string>
//#include<algorithm>
//#include<cmath>
//#include<vector>
//#include<stack>
//#include<iomanip>
using namespace std;

#define MAX 105
/*测试数据

*/          

int dp[105][105];
int m[5][5]={//行列顺序都为ACGT-
	{5,-1,-2,-1,-3},
	{-1,5,-3,-2,-4},
	{-2,-3,5,-2,-2},
	{-1,-2,-2,5,-1},
	{-3,-4,-2,-1,-100}
};
int mymap( char x)
{
	if(x=='A')return 0;
	if(x=='C')return 1;
	if(x=='G')return 2;
	if(x=='T')return 3;
	return 4;
}
int getmax(int a,int b,int c)
{
	int mm=a;
	if(b>mm) mm=b;
	if(c>mm) mm=c;
	return mm;
}
int main()
{
   int T,n1,n2;
   int j,i;
   char s1[105],s2[105];

   cin>>T;
   while(T--)
   {
	  cin>>n1>>s1+1;
	  cin>>n2>>s2+1;
	  dp[0][0]=0;
	  s1[0]=s2[0]='-';
	  for(i=1;i<=n1;i++)
		  dp[0][i]=dp[0][i-1]+m[4][mymap(s1[i])];
	  for(i=1;i<=n2;i++)
		  dp[i][0]=dp[i-1][0]+m[mymap(s2[i])][4];
	  for(i=1;i<=n2;i++)
		  for(j=1;j<=n1;j++)
			  dp[i][j]=getmax((dp[i-1][j-1]+m[mymap(s2[i])][mymap(s1[j])]),dp[i-1][j]+m[mymap(s2[i])][4],dp[i][j-1]+m[4][mymap(s1[j])]);

	cout<<dp[n2][n1]<<endl;

   }

	return 0;
}
时间: 2024-10-10 20:15:32

动态规划解决杭电OJ1080题——LCS的变种的相关文章

杭电dp题集,附链接

Robberies 点击打开链接 背包;第一次做的时候把概率当做背包(放大100000倍化为整数):在此范围内最多能抢多少钱  最脑残的是把总的概率以为是抢N家银行的概率之和- 把状态转移方程写成了f[j]=max{f[j],f[j-q[i].v]+q[i].money}(f[j]表示在概率j之下能抢的大洋); 正确的方程是:f[j]=max(f[j],f[j-q[i].money]*q[i].v)  其中,f[j]表示抢j块大洋的最大的逃脱概率,条件是f[j-q[i].money]可达,也就是

acm入门 杭电1001题 有关溢出的考虑

最近在尝试做acm试题,刚刚是1001题就把我困住了,这是题目: Problem Description In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n. Input The input will consist of a series of integers n, one integer per line Output For each case, output SUM(n) in one line

杭电水题

杭电OJ上的水题:C语言程序设计练习 题目如下: 链接: http://acm.hdu.edu.cn/showproblem.php?pid=2001 注:pid=后面可以为2000 - 2050中的任何一个(对应50道题目) 另外也可以做1000之后的(按顺序做,从1000开始把,1000开头的都蛮简单的) 原文地址:https://www.cnblogs.com/wyb666/p/10909202.html

杭电算法题 HDU 1000-1004

h1,h2,h3,h4,h5,h6,p,blockquote { margin: 0; padding: 0 } body { font-family: "Helvetica Neue", Helvetica, "Hiragino Sans GB", Arial, sans-serif; font-size: 13px; line-height: 18px; color: #737373; background-color: white; margin: 10px

Advanced Fruits HDU杭电1503【LCS的保存】

Problem Description The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a

小试牛刀-搜索基础入门(杭电五题)

hdu 1241 Oil Deposits 水题,BFS,判断区域的块数. 代码清单: #include<queue> #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> using namespace std; typedef pair<int,int>P; int m,n; char s[105][105]; int xy[8][2]=

杭电一水题(DFS)Untitled

Problem Description There is an integer a and n integers b1,…,bn. After selecting some numbers from b1,…,bn in any order, say c1,…,cr, we want to make sure that a mod c1 mod c2 mod… mod cr=0 (i.e., a will become the remainder divided by ci each time,

杭电二分题

Description Now, here is a fuction: F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) Can you find the minimum value when x is between 0 and 100. Input The first line of the input contains an integer T(1<=T<=100) which means the number of te

Dijk入门(杭电2544题)

#include<iostream> #include<cstring> using namespace std; #define INF 0x3f3f3f3f int n,m; int map[105][105]; int vis[105]; int stemp[105]; int dijk(){ memset(vis,0,sizeof(vis)); vis[1]=1; //标记第一个已选 memset(stemp,0,sizeof(stemp)); int min; int f