poj 2431

大意:

  有n个加油点,给出每个加油点距离终点的位置和能加多少油,最后一行给出总长度和最初的油量。求最少加几次油能到终点,不能到的话输出-1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

分析:

  一开始打算用dfs搜索,用dis[i]代表到i点时能加的油量,dfs(i,p,l),i代表当前位置,p代表当前油量,l代表总长,当i+p>=l时,这种情况符合条件,得每种能成立情况的加油次数再取最小值就好,但超时.

  于是想到用优先队列,能以目前的油量跑得越远,加油次数越少。所以优先队列里存放油量,用pre代表之前的位置,用rest代表当前油量,dis代表走多远,每走过一个点rest-=dis,把这个点的油量存入优先队列中,当rest<dis时从队列中取元素。没元素可取就意味着不能到终点。

代码:

  

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
struct point
{
    int x,y;
}s[10010];
bool cmp(point a,point b)
{
    return a.x<b.x;
};
int main()
{
    int n;
    cin>>n;
    int i;
    for(i=0;i<n;i++)
        cin>>s[i].x>>s[i].y;
    int l,p;
    cin>>l>>p;
    for(i=0;i<n;i++)
        s[i].x=l-s[i].x;
    sort(s,s+n,cmp);
    s[n].x=l;
    s[n].y=0;
    priority_queue<int>q;
    int rest=p;
    int pre=0;
    int ans=0;
    for(i=0;i<n+1;i++)
    {
        int dis=s[i].x-pre;
        while(rest<dis)
        {
            if(q.empty())
            {
                 ans=-1;
                 break;
            }
            rest+=q.top();
            q.pop();
            ans++;
        }
        if(ans==-1)
            break;
        rest-=dis;
        pre=s[i].x;
        q.push(s[i].y);

    }
    cout<<ans<<endl;
}

  

  

时间: 2024-10-18 09:51:16

poj 2431的相关文章

poj 2431 Expedition (贪心+优先队列)

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 6890   Accepted: 2065 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to

poj 2431 Expedition 贪心+最大堆

当油量不够时从走过的油站中选最大加油量的 #include<iostream> #include<queue> #include<stdlib.h> #include<algorithm> using namespace std; #define MAX_N 10005 struct node{ int dist,fuel; }t[MAX_N]; bool cmp(const node &a,const node &b) { return a

[POJ 2431]Expedition

1.题目连接:http://poj.org/problem?id=2431 2.题目大意:你需要开着一辆卡车行驶L单位距离,最开始卡车有P单位汽油,卡车每开一单位距离需要消耗1单位汽油,如果在中途卡车汽油耗尽,卡车就无法继续前行,到不了终点,在途中一共有n个加油站,告诉你每个加油站距离终点的距离和每个加油站可以加的油量,假设卡车的油箱是无穷大的,问卡车至少要加多少次油才能到达终点?卡车到不了终点输出-1 3.题目思路:使用优先队列+贪心思想完成此题,队列中维护到达目前的加油站之前没有用过的加油站

POJ 2431 Expedition (STL 优先权队列)

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8053   Accepted: 2359 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to

POJ 2431 Ecpedition 最大堆 贪心

题目链接: http://poj.org/problem?id=2431 题目描述: N个加油站 在坐标a[i] 的 加油站上面有油量b[i] , 问车能不能能不能到达终点为L的地方, 车一开始有油量P 解题思路: 可以看做车在没有油的时候就从先前的加油站中拿出一个最多的加油站的油加上, 这里用上了优先队列, 实际上就是大顶堆.....如果我还没有到达终点但是队列已经是空的了, 就说明永远也到达不了终点了, 输出-1 代码: 先存一下自己有问题的代码.....现在有点儿太困了, 自己审题出了毛病

poj - 2431 Expedition (优先队列)

http://poj.org/problem?id=2431 你需要驾驶一辆卡车做一次长途旅行,但是卡车每走一单位就会消耗掉一单位的油,如果没有油就走不了,为了修复卡车,卡车需要被开到距离最近的城镇,在当前位置和城镇之间有n个加油站可以加油. 为了减少危险,需要最少的加油次数,卡车的油箱可以看作无限大,卡车初始距离城镇L单位,自身有P单位的油. 注意输入的距离是与城镇的距离不是与开始点的距离.转换一下就好. 思想:把经过的所有加油站都加入优先队列,当燃料不足时就取出优先队列的最大元素,用来给卡车

poj 2431 Expedition(优先队列)

题目链接 http://poj.org/problem?id=2431 Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9243   Accepted: 2700 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor driver

POJ 2431 Expedition 贪心

题意:一辆汽车由起点开往小镇,总路程为L,路上有N个加油站,第i个加油站距离小镇a[i],最多可为提供b[i]的汽油,汽车开始时有P单位汽油,问汽车内否到达小镇,若能到达输出最小的加油次数. 思路:每经过一个加油站i,汽车就获得了一次在任何时候加油b[i]的权利,当汽车不足以到达下一站时,就加入过往的最大的b值. #include<stdio.h> #include<queue> #include<iostream> #include<algorithm>

POJ 2431 Expedition(探险)

Time Limit: 1000MS   Memory Limit: 65536K [Description] [题目描述] A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's f

Heap:Expedition(POJ 2431)

远征队 题目大意:一部车要从一个地方走到另一个地方,开始的时候车的油箱有P升油,汽车每走1个距离消耗1升油,没有油汽车无法行驶,路上有加油站,可以为汽车加油,设汽车的油缸是无限大小的,问你汽车能否走到终点?如果可以,需要用到最小的加油站的数目是多少? 这一题可以这么理解,因为我们只用最小的加油站数目,那么我们可以只用每次都加最大油量就可以了,我们可以认为汽车经过的加油站都像势能一样储存起来,随时可以加油 那么这样过后,我们只用维护一个最大堆就可以了,也算是一个贪婪算法吧 1 #include <