[ACM] POJ 2000 Gold Coins

Gold Coins

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 20913   Accepted: 13098

Description

The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each
of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments
will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer.

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).

Input

The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing
the number of days. The end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given
number of days, starting with Day 1.

Sample Input

10
6
7
11
15
16
100
10000
1000
21
22
0

Sample Output

10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98

Source

Rocky Mountain 2004

解题思路:

题意为 第一天获得1个硬币,后两天每天获得两个硬币,后三天每天获得三个硬币:如前6天每天获得的硬币数为 1 2 2 3 3 3

问第n天一共获得多少硬币。思路为判断第n天包括几个连续的时间段(比如获得1硬币的一天 获得2硬币的两天 获得3硬币的三天)以及多出来不是一个完整的时间段的那几天,代码中用extra,并记录下多出来的这几天是第几个连续时间段。总金币= 完整时间段获得的+ 余下的天数获得的

代码:

#include <queue>
#include <iostream>
#include <string.h>
#include <stack>
#include <iomanip>
#include <cmath>
using namespace std;

int cnt(int n)
{
    int totalday=0;
    int get=0;
    int i;
    int extra;//不是一个完整的连续i天的那几天,比如1 2 2 3,extra则为1,获得3个硬币的那一天
    for(i=1;i<=n;i++)
    {
        totalday+=i;
        if(totalday>n)
        {
            extra=n-(totalday-i);
            break;
        }
        get+=i*i;
    }
    get+=extra*i;
    return get;
}

int main()
{
    int n;
    while(cin>>n&&n)
    {
        cout<<n<<" "<<cnt(n)<<endl;
    }
    return 0;
}

[ACM] POJ 2000 Gold Coins

时间: 2024-10-17 19:41:39

[ACM] POJ 2000 Gold Coins的相关文章

POJ 2000 Gold Coins

题目描述 国王用付给他忠诚的骑士金币.在服役的第一天,骑士收到了一枚金币.在之后两天的每一天(服役的第二第三天),骑士收到两枚金币.在之后三天的每一天(服役的第四五六天),骑士收到三枚金币.这种支付模式将不限期地继续下去:在连续的 n 天每天收到 n 枚金币之后,骑士将会在接下来的 n+1 天每天收到 n+1 枚金币,这里 n 是一个任意的正整数. 你的程序要判定在任意给定的天数骑士累计收到了多少枚金币(从第一天开始). 输入 输入包含至少一,但是至多二十一行.输入的每行(除了最后一行)包含问题

poj 2000

Gold Coins Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 20802   Accepted: 13018 Description The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days

[ACM] POJ 3259 Wormholes (bellman-ford最短路径,判断是否存在负权回路)

Wormholes Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 29971   Accepted: 10844 Description While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way p

[ACM] POJ 2409 Let it Bead (Polya计数)

Let it Bead Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 4434   Accepted: 2916 Description "Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is b

[ACM] POJ 2442 Sequence (堆的性质)

Sequence Time Limit: 6000MS   Memory Limit: 65536K Total Submissions: 7011   Accepted: 2262 Description Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's

HDU2401 Baskets of Gold Coins【水题】【推理】

Baskets of Gold Coins Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1648    Accepted Submission(s): 966 Problem Description You are given N baskets of gold coins. The baskets are numbered fro

[ACM] poj 2096 Collecting Bugs (概率DP,期望)

Collecting Bugs Time Limit: 10000MS   Memory Limit: 64000K Total Submissions: 2026   Accepted: 971 Case Time Limit: 2000MS   Special Judge Description Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material st

[ACM] POJ 2506 Tiling (递推,大数)

Tiling Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7487   Accepted: 3661 Description In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? Here is a sample tiling of a 2x17 rectangle. Input Input is a sequence of lines,

[ACM] POJ 1753 Flip Game (枚举,BFS,位运算)

Flip Game Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 29921   Accepted: 12975 Description Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the