poj3080Blue Jeans

题目链接:

啊哈哈,点我点我

题意是:

给n个字符串然后找出n个字符串里面最长的公共字串。。

这道题目最开始以为是dp,后来又以为是kmp,但是kmp貌似没看到过这么多字符串相匹配的,后来就搜题解,太弱了,只能看别人题解。。

思路是:

首先看数据大小,最多只有10个串,那么把第一个串当作母串,然后逐个去枚举母串中的子串,然后根据字串去其他n-1个DNA序列中检测,看是否这些子串在其他DNA序列中存在,然后把第一个母串中所有的的字串进行枚举,得到所有字符串都满足的最长公共字串,如果存在相同的子串,那么选取字典序最小的那个。。这样这题就已暴力的方式得到了解决。。然后就是找枚举的字串在其他DNA序列中不需要像BF算法那样一个个好,然后回溯,因为cstring头文件里面有一个神器 strstr。。这回真是开了眼界了。。。

题目:

Blue Jeans

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12149   Accepted: 5266

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences
of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

Source

South Central USA 2006

代码为:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int len=60;

char DNA[10+10][len+1];
char ans[len+1],Copy[len+1];
int ans_length,length;

int main()
{
    int t,n,pd,flag,i,j,k,count;
    scanf("%d",&t);
    while(t--)
    {
        count=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%s",DNA[i]);
        ans_length=-1;
        length=1;
        for(i=0;;i++)
        {
            flag=1;
            pd=i;
            if(pd+length>len)//判断序列是否越界
            {
                length++;
                i=-1;
                if(length>len)
                    break;
                continue;
            }
            for(j=0;j<length;j++)
                Copy[j]=DNA[1][pd++];
            Copy[j]='\0';
            for(k=2;k<=n;k++)
            {
                if(!strstr(DNA[k],Copy))//str函数是c语言自带的一个函数,意思是Copy数组是否在DNA[K]中出现过,其实这个可以用kmp来判断,但是我们有这么方便的函数,和乐而不为呢??
                {
                    flag=0;
                    break;
                }
            }
            if(flag)
            {
                if(length==ans_length)
                {
                    if(strcmp(ans,Copy)>0)
                        strcpy(ans,Copy);
                }
                if(length>ans_length)
                {
                    ans_length=length;
                    strcpy(ans,Copy);
                }
            }
        }
        if(ans_length<3)
            printf("no significant commonalities\n");
        else
            printf("%s\n",ans);
    }
    return 0;
}

poj3080Blue Jeans,布布扣,bubuko.com

时间: 2024-10-25 16:35:55

poj3080Blue Jeans的相关文章

poj3080--Blue Jeans(字符串匹配)

Blue Jeans Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 12233   Accepted: 5307 Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousa

POJ3080-Blue Jeans(KMP,水)

大致题意: 就是求k个长度为60的字符串的最长连续公共子串,2<=k<=10 规定: 1.  最长公共串长度小于3不输出 2.  若出现等长的最长的子串,则输出字典序最小的串 思路:和POJ-3450-Corporate Identity一样二分+枚举,但是直接暴力也0ms //192 KB 0 ms 题目太水,我就把POJ3450的代码改了几句话 #include<iostream> #include<cstdio> #include<cstring> #

poj--3080Blue Jeans KMP的简单应用

穷举第一个字符串的所有子串,然后再判断其是否是其它字符串的子串. 然后注意输出字典序最小的答案. 判断枚举的子串是不是其它字符串子串时可以使用KMP,其实也可以直接暴力,因为题目数据范围不大. 学到一个技巧:可以使用memset(str,'\0',sizeof(str)将字符数组清空. 还有一点需要注意的是在自己组合的字符串后面一定要记得加上字符串结束标志'\0'. 代码如下: #include<iostream> #include<cstdio> #include<cstr

Poj--3080Blue Jeans+KMP水题

题目链接:点击进入 大概的题意就是给n个字符串,然后让我们找出他们的最长的公共子串. 因为题目的数据比较小,我们可以枚举第一个串的所有子串,然后再用KMP判断一下这个子串是否出现在其它字符串中. 代码如下: #include<iostream> #include<cstdio> #include<cstring> using namespace std; const int maxn=100; ///x是模式串,m是长度,next是模式串对应的next数组 void k

poj - 3080-Blue Jeans

Blue Jeans Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 17434   Accepted: 7728 Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousa

POJ 3080--Blue Jeans【KMP &amp;&amp; 暴力枚举】

Blue Jeans Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 14316   Accepted: 6374 Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousa

poj3080(Blue Jeans)kmp求多个串公共子串

题意:给出1-10个长度为60的字符串,求出最长的公共子串(长度不能小于3),如果有多个一样长的,输出字典序最短的. 解法:想到kmp时,自己第一反应枚举第一个串的所有子串,在其他所有串中走一遍kmp,复杂度为10*60*60*60,但是发现只需枚举第一个串后缀就可以,每次枚举记录在所有串能走最远中走的最短的那个长度.这样复杂度就成了10*60*60,0ms AC. 代码: /**************************************************** * autho

POJ 题目3080 Blue Jeans(KMP+暴力)

Blue Jeans Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 14303   Accepted: 6367 Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousa

POJ3080——Blue Jeans(暴力+字符串匹配)

Blue Jeans DescriptionThe Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. As an IBM researcher, you hav