UVA1152 4Values whose Sum is 0

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) $ \in$AxBxCxD are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
1

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题解:不超时最好。。先枚举a,b,然后检查-(c+d)的值,还是二分优化。

AC代码:

#include <algorithm>
#include <iostream>
using namespace std;
const int Max = 4000 + 10;
int a[Max],b[Max],c[Max],d[Max];
int ab[17000000];
int total;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        for(int i=0; i<n; i++)
        {
            cin>>a[i]>>b[i]>>c[i]>>d[i];
        }
        int k=0;
        for(int i=0;i<n; i++)
        {
            for(int j=0;j<n; j++)
            {
                ab[k]=a[i]+b[j];
                k++;
            }
        }
        sort(ab,ab+k);
        total=0;
        int s,l,r,mid;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
            {
                int x=-c[i]-d[j];
                l=0,r=k-1;
                while(l<=r)
                {
                    mid=(l+r)/2;
                    if(ab[mid]>x)
                        r=mid-1;
                    else if(ab[mid]<x)
                        l=mid+1;
                    else
                    {
                        for(s=mid;s>=0;s--)
                        {
                            if(ab[s]==x)
                                total++;
                            else
                               break;
                        }
                        for(s=mid+1; s<k; s++)
                        {
                            if(ab[s]==x)
                                total++;
                            else
                               break;
                        }
                        break;
                    }
                }
            }
        }
        cout<<total<<endl;
        if(t>0)
            cout<<endl;
    }
    return 0;
}
时间: 2024-10-12 18:31:15

UVA1152 4Values whose Sum is 0的相关文章

UVa 1152 4Values whose Sum is 0

题意  从4个n元集中各挑出一个数  使它们的和为零有多少种方法 直接n^4枚举肯定会超时的  可以把两个集合的元素和放在数组里  然后排序 枚举另外两个集合中两元素和  看数组中是否有其相反数就行了  复杂度为n^2*logn #include <bits/stdc++.h> #define l(i) lower_bound(s,s+m,i) #define u(i) upper_bound(s,s+m,i) using namespace std; const int N = 4005;

POJ 2785 4 Values whose Sum is 0(折半枚举)

4 Values whose Sum is 0 Time Limit: 15000MS   Memory Limit: 228000K Total Submissions: 17088   Accepted: 4998 Case Time Limit: 5000MS Description The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how

PHPExcel SUM 返回0

使用PHPExcel 导出Excel最后的代码是: $objWriter = PHPExcel_IOFactory::createWriter($this->excel, 'Excel2007'); //force user to download the Excel file without writing it to server's HD $objWriter->save('php://output'); 导出的Excel的"=SUM(A1:A10)"的和还是0,解决

POJ 2785 4 Values whose Sum is 0

4 Values whose Sum is 0 Time Limit: 15000MS   Memory Limit: 228000K Total Submissions: 22691   Accepted: 6869 Case Time Limit: 5000MS Description The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how

4 Values whose Sum is 0(二分)

4 Values whose Sum is 0 Time Limit: 15000MS   Memory Limit: 228000K Total Submissions: 21370   Accepted: 6428 Case Time Limit: 5000MS Description The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how

[poj2785]4 Values whose Sum is 0(hash或二分)

4 Values whose Sum is 0 Time Limit: 15000MS Memory Limit: 228000K Total Submissions: 19322 Accepted: 5778 Case Time Limit: 5000MS Description The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how man

POJ-2785 4 Values whose Sum is 0(折半枚举 sort + 二分)

题目链接:http://poj.org/problem?id=2785 题意是给你4个数列.要从每个数列中各取一个数,使得四个数的sum为0,求出这样的组合的情况个数. 其中一个数列有多个相同的数字时,把他们看作不同的数字. 做法是把前两个数列和的值存在一个数组(A)中 , 后两个数列的和存在另一个数组(B)中 , 数组都为n^2 . 然后将B数组sort一下 , 将A数组遍历 , 二分查找一下B数组中与A数组元素和为0的个数 . 有个注意的点是万一A数组都是0 , 而B数组都为0的情况(还有其

POJ 2785 4 Values whose Sum is 0 (对半分解 二分搜索)

4 Values whose Sum is 0 Time Limit: 15000MS   Memory Limit: 228000K Total Submissions: 17658   Accepted: 5187 Case Time Limit: 5000MS Description The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how

K - 4 Values whose Sum is 0(中途相遇法)

K - 4 Values whose Sum is 0 Crawling in process... Crawling failed Time Limit:9000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Practice UVA 1152 Appoint description: System Crawler (2015-03-12) Description The SUM problem can