ACM-计算几何之Lifting the Stone——hdu1115

Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5026    Accepted Submission(s): 2102

Problem Description

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly
and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly
to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed
by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the
neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.

Output

Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal
point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.

Sample Input

2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11

Sample Output

0.00 0.00
6.00 6.00

Source

Central Europe 1999

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1115

这道题是求多边形重心的题目,可以做个模板。

该题目中的点顺序是按逆时针顺序给的。

求多边形重心分两种情况:

①质量集中在顶点上。n个顶点坐标为(xi,yi),质量为mi,则重心

  X = ∑( xi×mi ) / ∑mi

  Y = ∑( yi×mi ) / ∑mi

  特殊地,若每个点的质量相同,则

  X = ∑xi / n

  Y = ∑yi / n

②质量分布均匀。这个题就是这一类型,算法和上面的不同。

  特殊地,质量均匀的三角形重心:

  X = ( x0 + x1 + x2 ) / 3

  Y = ( y0 + y1 + y2 ) / 3

所以,这道题解法:

1.以一个点为顶点,做多个三角形,然后求每个三角形的重心与质量。

2.然后用每个三角形的重心为顶点再构成一个多边形。

3.这个多边形就属于上述的第一种情况了,质量在顶点上的多边形面积。

4.套公式就OK拉~

PS:注意几点:

由于三角形质量与面积成正比(WHY?因为质量分布均匀~。~),所以质量可用面积来代替。

再者用叉积求三角形面积要算正负情况(正负号要保留),

此举是为了防止多边形为凹多边形的情况,三角形面积会在多边形外。

OK~翠花,上模板~,此模板也会更新在我整理的 计算几何模板
 中哟~~~

/**************************************
***************************************
*        Author:Tree                  *
*From:  http://blog.csdn.net/lttree   *
* Title : Lifting the Stone           *
*Source: hdu 1115                     *
* Hint  : 多边形重心                 *
***************************************
**************************************/

#include <stdio.h>
struct point
{
    double x,y;
}pnt[1000001];
point bcenter( int n)
{
    point p,s;
    int i;
    double tp,area=0,tpx=0,tpy=0;
    p.x=pnt[0].x;p.y=pnt[0].y;
    for( i=1;i<=n;++i )
    {
        if( i==n )  s.x=pnt[0].x,s.y=pnt[0].y;
        else    s.x=pnt[i].x,s.y=pnt[i].y;
        tp = ( p.x*s.y - p.y*s.x );
        area+=tp/2.0;
        tpx+=(p.x+s.x)*tp;
        tpy+=(p.y+s.y)*tp;
        p.x=s.x;p.y=s.y;
    }
    s.x=tpx/( 6*area );
    s.y=tpy/( 6*area );
    return s;
}
int main()
{
    int test,n,i;
    point zx;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d",&n);
        for(i=0;i<n;++i)
            scanf("%lf%lf",&pnt[i].x,&pnt[i].y);
        zx=bcenter(n);
        // 注意输出格式呀~
        printf("%.2lf %.2lf\n",zx.x,zx.y);
    }
    return 0;
}
时间: 2024-08-28 05:19:20

ACM-计算几何之Lifting the Stone——hdu1115的相关文章

Lifting the Stone(hdu1115)多边形的重心

Lifting the Stone Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5370 Accepted Submission(s): 2239 Problem Description There are many secret openings in the floor which are covered by a big heavy

HDU 1115 Lifting the Stone

Lifting the Stone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5440    Accepted Submission(s): 2278 Problem Description There are many secret openings in the floor which are covered by a big

Lifting the Stone(hdoj1115)

Lifting the Stone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6104    Accepted Submission(s): 2546 Problem Description There are many secret openings in the floor which are covered by a big

Lifting the Stone(求任意多边形的重心)

Lifting the Stone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5432    Accepted Submission(s): 2273 Problem Description There are many secret openings in the floor which are covered by a big

hdu 1115 Lifting the Stone (数学几何)

Lifting the Stone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5203    Accepted Submission(s): 2155 Problem Description There are many secret openings in the floor which are covered by a big

HDOJ 1115 Lifting the Stone 多边形重心

来自:http://blog.csdn.net/tiaotiaoyly/article/details/2087498 1,质量集中在顶点上.n个顶点坐标为(xi,yi),质量为mi,则重心 X = ∑( xi×mi ) / ∑mi Y = ∑( yi×mi ) / ∑mi 特殊地,若每个点的质量相同,则 X = ∑xi  / n Y = ∑yi  / n 2,质量分布均匀.这个题就是这一类型,算法和上面的不同. 特殊地,质量均匀的三角形重心: X = ( x0 + x1 + x2 ) / 3

(hdu step 7.1.3)Lifting the Stone(求凸多边形的重心)

题目: Lifting the Stone Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 168 Accepted Submission(s): 98   Problem Description There are many secret openings in the floor which are covered by a big he

[ACM] hdu 4248 A Famous Stone Collector (DP+组合)

A Famous Stone Collector Problem Description Mr. B loves to play with colorful stones. There are n colors of stones in his collection. Two stones with the same color are indistinguishable. Mr. B would like to select some stones and arrange them in li

Lifting the Stone

我们需要把一块石头平稳的从地板上拿起来.石头的底面是多边形且各个部分的高度都一样,我们需要找出石头的重心. input 测试案例  T; 每组第一行给出N,表示定点数. 接下来N行,每行连个数,表示坐标.定点按顺时针或逆时针给出. output 重心坐标.两个数中间一个空格,每个数保留两位小数. 思路 把多变形分成N-2个三角形,求出重心,重心的质量.(其实是质心) 根据   x=Σ(xi*mi)/Σmi,有因为mi 正比于体积 正比于 面积. 所以利用叉乘求面积. 1 #include"ios