zoj2059 The Twin Towers (dp)

Description

Twin towers we see you standing tall, though a building’s lost our faith will never fall.

Twin towers the world hears your call, though you’re gone it only strengthens our resolve.

We couldn’t make it through this without you Lord, through hard times we come together more. …

Twin Towers - A Song for America

In memory of the tragic events that unfolded on the morning of September 11, 2001, five-year-old Rosie decids to rebuild a tallest Twin Towers by using the crystals her brother has collected for years. Will she succeed in building the two towers of the same height?

Input

There are mutiple test cases.

One line forms a test case. The first integer N (N < 100) tells you the number of crystals her brother has collected. Then each of the next N integers describs the height of a certain crystal.

A negtive N indicats the end.

Note that all crytals are in cube shape. And the total height of crystals is smaller than 2000.

Output

If it is impossible, you would say “Sorry”, otherwise tell her the height of the Twin Towers.

Sample Input

4 11 11 11 11

4 1 11 111 1111

-1

Sample Output

22

Sorry

给你一些东西的高度。。然后问你用这些可不可以组成两个高度一样的塔。。

dp[a][b] 第a个石头,,两塔的高度差。。不断地去维护低塔。。

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<stack>
#pragma comment(linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define EPS 1e-6
#define INF (1<<24)
using namespace std;
int dp[105][2005];
int a[105];
int main()
{
    int n;
    while(scanf("%d",&n),n>0)
    {
        int i,j;
        for(i=1;i<=n;i++) scanf("%d",&a[i]);
        memset(dp,-1,sizeof(dp));
        dp[0][0]=0;
        for(i=1;i<=n;i++)
        {
            memcpy(dp[i],dp[i-1],sizeof(dp[i-1]));//不放i,i-1的情况全是i的情况
            for(j=0;j<2001;j++)  //高度
            {
                if(dp[i-1][j]!=-1)
                {
                    if(a[i]<j)
                    {
                        dp[i][j-a[i]]=max(dp[i][j-a[i]],dp[i-1][j]+a[i]);//放到低塔上
                        dp[i][j+a[i]]=max(dp[i][j+a[i]],dp[i-1][j]);//放到高塔上
                    }
                    else
                    {
                        dp[i][a[i]-j]=max(dp[i][a[i]-j],dp[i-1][j]+j); //放到低塔上
                        dp[i][j+a[i]]=max(dp[i][j+a[i]],dp[i-1][j]);//放到高塔上
                    }
                }
            }
        }
       if(dp[n][0]) printf("%d\n",dp[n][0]);
       else printf("Sorry\n");
    }
    return 0;
}

后来又发现了可以再优化。。。。。

用滚动数组优化内存(虽然并没有什么卵用)(给自己提个醒,有这个用法吧)

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<stack>
#pragma comment(linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define EPS 1e-6
#define INF (1<<24)
using namespace std;
int dp[2005];  //dp[j]==高度相差j的矮塔的高度
int t[2005];   //滚动数组,记录相当于dp[i]
int a[105];
int main()
{
    int n;
    while(scanf("%d",&n),n>0)
    {
        int i,j;
        for(i=1;i<=n;i++) scanf("%d",&a[i]);
        memset(dp,-1,sizeof(dp));
        memset(t,-1,sizeof(t));
        dp[0]=t[0]=0;
        for(i=1;i<=n;i++)
        {
            memcpy(dp,t,sizeof(t));//不放i,i-1的情况全是i的情况
            for(j=0;j<2001;j++)
            {
                if(dp[j]!=-1)
                {
                    if(a[i]<j)
                    {
                        t[j-a[i]]=max(t[j-a[i]],dp[j]+a[i]);//放到低塔上
                        t[j+a[i]]=max(t[j+a[i]],dp[j]);//放到高塔上
                    }
                    else
                    {
                        t[a[i]-j]=max(t[a[i]-j],dp[j]+j); //放到低塔上
                        t[j+a[i]]=max(t[j+a[i]],dp[j]);//放到高塔上
                    }
                }
            }
            memcpy(dp,t,sizeof(t));//滚动数组,传递数据
        }
       if(dp[0])    printf("%d\n",dp[0]);
       else printf("Sorry\n");
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-08-25 17:22:14

zoj2059 The Twin Towers (dp)的相关文章

uva--10066The Twin Towers +dp

其实就是求两个序列的最长公共子序列 代码如下: #include<iostream> #include<cstdio> #include<cstring> using namespace std; int main() { int n1,n2,Case=0; while(scanf("%d%d",&n1,&n2)&&n1) { int a[110],b[110]; int dp[110][110],i,j; memse

UVa 10066 Twin Towers (DP 最长公共子序列)

题意  求两串数字最长公共子序列的长度 裸的lcs没啥说的 #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int maxn=105; int a[maxn],b[maxn],d[maxn][maxn],na,nb; void lcs() { memset(d,0,sizeof(d)); for(int i=1; i<=na; ++i) for(in

LightOJ1126 Building Twin Towers(DP)

题目 Source http://www.lightoj.com/volume_showproblem.php?problem=1126 Description Professor Sofdor Ali is fascinated about twin towers. So, in this problem you are working as his assistant, and you have to help him making a large twin towers. For this

ZOJ 2059 The Twin Towers(双塔DP)

The Twin Towers Time Limit: 2 Seconds      Memory Limit: 65536 KB Twin towers we see you standing tall, though a building's lost our faith will never fall. Twin towers the world hears your call, though you're gone it only strengthens our resolve. We

uva 10066 The Twin Towers (最长公共子)

uva 10066 The Twin Towers 标题效果:最长公共子. 解题思路:最长公共子. #include<stdio.h> #include<string.h> #include<stdlib.h> #include<algorithm> using namespace std; int a[105], b[105], dp[105][105]; int main() { int n, m, Case = 1; while (scanf(&quo

uva 10066 The Twin Towers (最长公共子序列)

uva 10066 The Twin Towers 题目大意:最长公共子序列. 解题思路:最长公共子序列. #include<stdio.h> #include<string.h> #include<stdlib.h> #include<algorithm> using namespace std; int a[105], b[105], dp[105][105]; int main() { int n, m, Case = 1; while (scanf(

UVa 10066 The Twin Towers(最长公共子序列)

The Twin Towers Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu Description Once upon a time, in an ancient Empire, there were two towers of dissimilar shapes in two different cities. The towers were built by putting circula

UVA 10066 The Twin Towers

DP,题目很长,题意就是求LCS. #include<cstdio> #include<cstring> #include<string> #include<queue> #include<algorithm> #include<map> #include<stack> #include<iostream> #include<list> #include<set> #include<

UVA - 10066The Twin Towers(LIS)

题目:UVA - 10066The Twin Towers(LIS) 题目大意:求两个整数序列的最长公共子序列. 解题思路:和uva10405同样的思路.注意每组输出后面要输出空行,不然会WA. 代码: #include <cstdio> #include <cstring> const int N = 105; int s1[N], s2[N]; int l[N][N]; int l1, l2; void init () { memset (l, 0, sizeof (l));