Problem Description
有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。
Input
输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。
Output
对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。
Sample Input
2
1 2
3 6
Sample Output
1
3
Author
lcy
Source
思路
很基础的一道递推题目,因为方向只能向右,所以对于第N个蜂房,只能从第N-1或者第N-2来,所以
递推式为:\(f[i] = f[i-1] + f[i-2]\)
初始条件为:\(f[1] = 1; f[2] = 2\)
注:f[n]中的n表示蜂房ab之间的差值
代码
#include<bits/stdc++.h>
using namespace std;
__int64 f[51];
int main()
{
int t;
f[0] = 0; f[1] = 1; f[2] = 2; f[3] = 3;
for(int i=4;i<=50;i++)
f[i] = f[i-1] + f[i-2];
cin >> t;
while(t--)
{
int l,r;
cin >> l >> r;
cout << f[r-l] << endl;
}
return 0;
}
原文地址:https://www.cnblogs.com/MartinLwx/p/9781334.html
时间: 2024-11-05 19:35:26