POJ 3349 - Snowflake Snow Snowflakes - [hash]

题目链接:http://poj.org/problem?id=3349

Time Limit: 4000MS Memory Limit: 65536K

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

题意:

给出 $n$ 个六元组代表 $n$ 个雪花,第 $i$ 个雪花的 $a_i = \left( {a_{i,1} ,a_{i,2} ,a_{i,3} ,a_{i,4} ,a_{i,5} ,a_{i,6} } \right)$,代表雪花的六个角的长度,

对于某两个雪花,若满足从它们各自的某一个角出发,顺时针或者逆时针旋转记录长度,能得到相同的两个六元组,则认为两个雪花形状相同,

现在求在这 $n$ 个雪花中,是否存在两个雪花是形状相同的。

题解:

构造哈希函数 $H\left( {a_i } \right) = \left( {\sum\limits_{j = 1}^6 {a_{i,j} } + \prod\limits_{j = 1}^6 {a_{i,j} } } \right)\bmod P$,其中 $P$ 是一个和 $N$ 接近的质数,

显然,对于两个形状相同的雪花,其哈希函数函数值应当是相同的,建立hash表(邻接表式),若某个链表表头下领着两个及以上节点,就说明有形状形同的雪花。

时间复杂度:暴力枚举 $n$ 个雪花,每一次都进入hash表中的某个链表查询,链表规模 $O\left( {\frac{n}{P}} \right)$(随机数据),总时间复杂度 $O\left( {\frac{{n^2 }}{P}} \right)$,当 $P$ 是一个和 $N$ 接近的质数时,时间复杂度接近 $O\left( n \right)$。

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;

const int maxn=100000+10;
const int P=99991;

int n;

struct SF{
    int a[6];
}table[maxn];
int tot,head[maxn],next[maxn];

int H(const SF &sf)
{
    int sum=0,mul=1;
    for(int k=0;k<6;k++)
    {
        sum=(sum+sf.a[k])%P;
        mul=((ll)mul*sf.a[k])%P;
    }
    return (sum+mul)%P;
}

bool isSame(const SF &A,const SF &B)
{
    bool ok;
    for(int i=0;i<6;i++)
    {
        for(int j=0;j<6;j++)
        {
            ok=1;
            for(int k=0;k<6;k++) if(A.a[(i+k)%6]!=B.a[(j+k)%6]) ok=0;
            if(ok) return 1;
            ok=1;
            for(int k=0;k<6;k++) if(A.a[(i+k)%6]!=B.a[(j-k+6)%6]) ok=0;
            if(ok) return 1;
        }
    }
    return 0;
}

bool Insert(const SF &sf)
{
    int has=H(sf);
    for(int i=head[has];i;i=next[i]) if(isSame(table[i],sf)) return 1;

    table[++tot]=sf;
    next[tot]=head[has];
    head[has]=tot;
    return 0;
}

int main()
{
    tot=0;
    memset(head,0,sizeof(head));

    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        SF sf;
        for(int k=0;k<6;k++) scanf("%d",&sf.a[k]);
        if(Insert(sf))
        {
            printf("Twin snowflakes found.\n");
            return 0;
        }
    }
    printf("No two snowflakes are alike.\n");
}

用vector写邻接表被卡了……老老实实改用数组模拟……

原文地址:https://www.cnblogs.com/dilthey/p/9682886.html

时间: 2024-10-15 12:59:09

POJ 3349 - Snowflake Snow Snowflakes - [hash]的相关文章

hash应用以及vector的使用简介:POJ 3349 Snowflake Snow Snowflakes

今天学的hash.说实话还没怎么搞懂,明天有时间把知识点总结写了,今天就小小的写个结题报告吧! 题意: 在n (n<100000)个雪花中判断是否存在两片完全相同的雪花,每片雪花有6个角,每个角的长度限制为1000000 两片雪花相等的条件: 雪花6个角的长度按顺序相等(这个顺序即可以是顺时针的也可以是逆时针的) 解题思路: hash:连加求余法 求key 值,链地址法解决冲突,连加求余法 求key 值挺简单,关于链地址法解决冲突可以通过c++中,vector容器可以较为方便的实现. 下面先介绍

POJ 3349 Snowflake Snow Snowflakes (哈希表)

题意:每片雪花有六瓣,给出n片雪花,六瓣花瓣的长度按顺时针或逆时针给出,判断其中有没有相同的雪花(六瓣花瓣的长度相同) 思路:如果直接遍历会超时,我试过.这里要用哈希表,哈希表的关键码key用六瓣花瓣的长度的和取余一个数得到,表中为雪花的存储位置address(即在snowflakes数组中的位置) 代码: #include<iostream> #include<vector> using namespace std; const int maxn=100000+100;//雪花最

POJ 3349 Snowflake Snow Snowflakes(哈希表)(转)

题意:判断有没有两朵相同的雪花.每朵雪花有六瓣,比较花瓣长度的方法看是否是一样的,如果对应的arms有相同的长度说明是一样的.给出n朵,只要有两朵是一样的就输出有Twin snowflakes found.,如果任何两个都是不一样的输出No two snowflakes are alike.n=100,000. 思路:最 简单的就是枚举每两片雪花,判断他们是否相同.时间复杂度为O(n*n),显然效果不理想.有没有更好的算法呢?hash:每读进一片雪花,将雪花 hash,判断hash表里是否有相同

poj 3349:Snowflake Snow Snowflakes(哈希查找,求和取余法+拉链法)

Snowflake Snow Snowflakes Time Limit: 4000MS   Memory Limit: 65536K Total Submissions: 30529   Accepted: 8033 Description You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Y

哈希—— POJ 3349 Snowflake Snow Snowflakes

相应POJ题目:点击打开链接 Snowflake Snow Snowflakes Time Limit: 4000MS   Memory Limit: 65536K Total Submissions: 33595   Accepted: 8811 Description You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is

[ACM] POJ 3349 Snowflake Snow Snowflakes(哈希查找,链式解决冲突)

Snowflake Snow Snowflakes Time Limit: 4000MS   Memory Limit: 65536K Total Submissions: 30512   Accepted: 8024 Description You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Y

POJ - 3349 Snowflake Snow Snowflakes (哈希)

题意:给定n(0 < n ≤ 100000)个雪花,每个雪花有6个花瓣(花瓣具有一定的长度),问是否存在两个相同的雪花.若两个雪花以某个花瓣为起点顺时针或逆时针各花瓣长度依次相同,则认为两花瓣相同. 分析: 1.按雪花各花瓣长度之和对MOD取余哈希.对各雪花,算出哈希值,在哈希表中查询是否有与之相同的花瓣. 2.每个花瓣以某个花瓣为起点顺时针或逆时针共有12种表示方法. 3.注意哈希表中只需保存雪花输入时给定的那组长度值即可. 在哈希表中查询时,再算出该组长度值所对应的12种表示,并一一比较,若

POJ 3349 Snowflake Snow Snowflakes 哈希(链式解决冲突)

题意:n个数列 每个数列6个元素a[i],a[i]<=1e7,两个数列只要,经过若干次循环移动能相等则定义为相似.n<=1e5,问n个数列中 是否存在两个数列相似? 每个数列只有6个数,则相似的最多12种,对每个数列算出其hash值 相同hash值插入同一个链表中.查看新输入的数列插入时是否产生冲突即可 O(n*12) #include <iostream> #include <cstdio> #include <cstring> #include <

POJ 3349 Snowflake Snow Snowflakes

题意:一个长度为6的序列表示一片雪花的六个胳膊(?)的长度,给出n个雪花,问存不存在两片一样的,一样的就是两个雪花旋转或者翻转后胳膊的长度是一样的…… 解法:哈希.以前并没有做过对数字序列哈希……先用map搞了搞,然后T了……百度了一下,只要将序列元素和进行哈希就可以了,对于索引的选取,一开始选了10n+7,然而T了……不是说越大哈希完了越分散么……想了想觉得是因为用vector搞的初始化太耗时……于是把索引减小吧……5003是个不错的选择……嗯?我怎么知道的?哈哈哈哈当然是我过于机智……嗯?你