指针练习:输出Hello

指针练习:输出Hello

内存限制: 
65536kB
描述

下面程序片段的输出结果是 Hello ,请填空

#include <iostream>
using namespace std;
int main() {
	char s[] = "Hello";
	char * p;
	for(
// 在此处补充你的代码
)
		cout << * p ;
	return 0;
}
输入
输出
Hello
样例输入
样例输出
Hello
来源
Guo Wei
源代码:

for(p=s;*p!=‘\0‘;p++)

时间: 2024-10-28 21:27:04

指针练习:输出Hello的相关文章

指针练习:输出Tesla

指针练习:输出Tesla 总时间限制:  1000ms 内存限制:  65536kB 描述 下面程序输出结果是 Tesla Tes 请填空 #include <iostream> using namespace std; void Print(const char * p1, const char * p2) { for( // 在此处补充你的代码 ) cout << * p1; } int main() { const char * s = "Tesla123"

编程题:用指针变量输出字符串

#include<stdio.h> void main() {  char *string="Hello"; printf("%s\n",string); } 字符串指针变量的介绍: 运行结果: 编程题:用指针变量输出字符串,布布扣,bubuko.com

二维数组的输出--(指针输出 和 指针数组输出)

当我第一次看见数组指针和指针数组这两个名字的时候,我以为是一个东西呢,当看到英文解释就知道这两个是不一样的了. 指针数组:array of pointers,用于存储指针的数组,也就是数组元素都是指针 数组指针:a pointer to an array,指向数组的指针,数组可以是任意维的 下面举例说明: int a[3][4]   --->这个无需多说,就是一个二维数组. int (*p)[4]   --->就相当于int p[][4],它是一个二维数组的指针,可以指向一个第二维度为4的二维

【c语言】用指针变量输出一维数组中的数据

#include<stdio.h>void main(){    int i,*m,a[5];    printf("数组:"); //普通方式输出数组的元素    for(i=0;i<5;i++){        a[i]=rand()%100;            printf("%-4d",a[i]);    }    printf("\n");    m=&a; //指针变量输出数组的元素    for(i=0

c语言:通过指向结构体变量的指针变量输出结构体变量中成员的信息

通过指向结构体变量的指针变量输出结构体变量中成员的信息. 解:程序: #include<stdio.h> #include<string.h> int main() { struct Student { long int num; char name[20]; char sex[10]; float score; }; struct Student stu_1;//定义struct Student类型的变量stu_1 struct Student *p; p = &stu_

Objc中2维指针作为输出参数时由ARC及@autoreleasepool引发的血案

先看下面一个例子 #import <UIKit/UIKit.h> #import "AppDelegate.h" @interface Something : NSObject - (void)doWithError:(NSError **)outError; @end @implementation Something - (void)doWithError:(NSError **)outError { @autoreleasepool { *outError = [NS

C语言:返回两个数组中第一个元素的指针,并输出这个值

// //  main.c //  Pointer_search // //  Created by ma c on 15/8/2. //  Copyright (c) 2015年 bjsxt. All rights reserved. //  要求:通过指针查找,实现比较两个有序数组中的元素,输出两个数组中的第一个相同的元素值. #include <stdio.h> int *searchSameElement(int *a,int *b,int len1,int len2); int ma

C++刷题——2736: 指针练习--输出最大值

Description 采用指针法,输出10个整型数中的最大值和最小值 Input 10个整数 Output 最大值和最小值 Sample Input 2 6 3 8 1 5 7 0 4 9 Sample Output max=9 min=0 /* Copyright (c) 2014, 烟台大学计算机学院 * All rights reserved. * 文件名称:test.cpp * 作者:陈丹妮 * 完成日期:2015年 6 月 1 日 * 版 本 号:v1.0 */ #include <

C语言:指针实现输出梯形字符串

用指针实现,实现过程无需将子串复制到一个新的字符串中.(10分) 题目内容: 用指针实现,实现过程无需将子串复制到一个新的字符串中. 输入格式: 字符串 输出格式: 子串 输入样例: computer 输出样例: computer omputer mputer puter uter ter er r code #include "stdio.h" int main() { char s[30]; char * p =s; scanf("%s",p); int i;

C语言:通过指针函数输出二维数组中每个学生的成绩

// //  main.c //  Pointer_function // //  Created by ma c on 15/8/2. //  Copyright (c) 2015年 bjsxt. All rights reserved. //  要求:通过指针函数,输入学生学号时,在控制台上显示对应的学生成绩. #include <stdio.h> float *search(float(*p)[4],int n)//float(*p)[4]是数组指针,指向有4个float元素的二位数组的