HDOJ 5399 Too Simple

每一个函数都必须是一个排列,经过连续的一段确定函数后数字不能少.

满足上面的条件的话,只要有一个-1函数特别的排列一下就可以满足要求,剩下的可以随意填

没有-1的话特判

Too Simple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 789    Accepted Submission(s): 267

Problem Description

Rhason Cheung had a simple problem, and asked Teacher Mai for help. But Teacher Mai thought this problem was too simple, sometimes naive. So she ask you for help.

Teacher Mai has m functions f1,f2,?,fm:{1,2,?,n}→{1,2,?,n}(that
means for all x∈{1,2,?,n},f(x)∈{1,2,?,n}).
But Rhason only knows some of these functions, and others are unknown.

She wants to know how many different function series f1,f2,?,fm there
are that for every i(1≤i≤n),f1(f2(?fm(i)))=i.
Two function series f1,f2,?,fm and g1,g2,?,gm are
considered different if and only if there exist i(1≤i≤m),j(1≤j≤n),fi(j)≠gi(j).

Input

For each test case, the first lines contains two numbers n,m(1≤n,m≤100).

The following are m lines.
In i-th
line, there is one number ?1 or n space-separated
numbers.

If there is only one number ?1,
the function fi is
unknown. Otherwise the j-th
number in the i-th
line means fi(j).

Output

For each test case print the answer modulo 109+7.

Sample Input

3 3
1 2 3
-1
3 2 1

Sample Output

1

Hint

The order in the function series is determined. What she can do is to assign the values to the unknown functions.

Author

xudyh

Source

2015 Multi-University Training Contest 9

/* ***********************************************
Author        :CKboss
Created Time  :2015年08月19日 星期三 10时25分44秒
File Name     :HDOJ5399.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

typedef long long int LL;
const LL mod=1e9+7LL;
const int INF=50000000;

int n,m;
int f[110][110];

int cn;
int color[110];

bool COLOR(int x,int c)
{
	if(color[x]==c) return false;
	color[x]=c; cn++;
	return true;
}

LL QuickPow(LL a,LL n)
{
	LL e=1;
	while(n)
	{
		if(n&1) e=(a*e)%mod;
		a=(a*a)%mod;
		n/=2;
	}
	return e%mod;
}

bool used[110];

LL jc(LL n)
{
	LL ret=1;
	for(int i=2;i<=n;i++)
		ret=(ret*i)%mod;
	return ret%mod;
}

bool check_P(int x,int L=1,int R=m)
{
	if(used[x]==true) return false;
	int nx=x;
	for(int i=R;i>=L;i--)
	{
		nx=f[i][nx];
	}
	if(nx==x)
	{
		if(used[x]==false)
		{
			used[x]=true;
			return true;
		}
		else return false;
	}
	return false;
}

bool check_Range(int L,int R)
{
	memset(used,false,sizeof(used));
	bool flag=true;
	for(int i=1;i<=n&&flag;i++)
	{
		int nx=i;
		for(int j=R;j>=L;j--)
		{
			nx=f[j][nx];
		}
		if(used[nx]==true) return false;
		else used[nx]=true;
	}
	return true;
}

int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);

	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int nig=0;
		bool check=true;
		memset(color,0,sizeof(color));

		for(int i=1;i<=m;i++)
		{
			scanf("%d",&f[i][1]);
			if(f[i][1]==-1) nig++;
			else
			{
				cn=0;
				check=COLOR(f[i][1],i);
				for(int j=2;j<=n;j++)
				{
					scanf("%d",&f[i][j]);
					check=COLOR(f[i][j],i);
				}
				if(cn!=n) check=false;
			}
		}

		if(check==false)
		{
			puts("0");
		}
		else if(check&&nig==0)
		{
			/// tePan
			memset(used,false,sizeof(used));
			bool flag=true;
			for(int i=1;i<=n&&flag;i++)
			{
				if(check_P(i)==false) flag=false;
			}
			if(flag==true) puts("1");
			else puts("0");
		}
		else
		{
			//// (n!^(nig-1))
			bool flag=true;
			int Left=INF,Right=-INF;
			f[m+1][1]=-1;
			for(int i=1;i<=m+1&&flag;i++)
			{
				if(f[i][1]==-1)
				{
					if(Left!=INF&&Right!=-INF)
					{
						/// check;
						flag=check_Range(Left,Right);
					}
					Left=INF; Right=-INF;
				}
				else
				{
					Left=min(Left,i); Right=max(Right,i);
				}
			}
			if(flag==false) puts("0");
			else printf("%lld\n",QuickPow(jc(n),nig-1)%mod);
		}
	}

    return 0;
}

版权声明:来自: 码代码的猿猿的AC之路 http://blog.csdn.net/ck_boss

时间: 2024-10-14 04:08:09

HDOJ 5399 Too Simple的相关文章

构造 HDOJ 5399 Too Simple

题目传送门 /* 题意:首先我是懂了的,然后我觉得很难讲清楚就懒得写了,关键理解f1(f2(fm(i)))=i,不懂的戳这里 构造:如果fi(j)不是一一映射到(1~n),重复或者不在范围内的肯定无解,还有没有-1的情况,模拟一下若不能满足f1(f2(fm(i)))=i 也是不行的.除此之外,那么有k个-1,那么方案数是(n!) ^ (k - 1),因为k-1个可以随便排列,最后一个由于之前的确定 */ /*********************************************

hdoj 5399 Tpp simple

WA了一下午.... 1WA:T了,因为阶乘没打表所以时间超了.. 2WA,3WA:runtime error,检查的value数组开小了,应该是MAXN.. 4WA.5WA.6WA:改了改对cnt的处理,该加Mod的加Mod 7WA:complication error,调试函数忘了删.. 8WA:所有的int改成了long long 9WA.10WA:改了下最后的思路和对于 m = 1 的处理 11WA:加了两个*1LL 12WA.13WA:发现输入有问题,中间有-1的时候会跳出 14WA:

【HDOJ 5399】Too Simple

[HDOJ 5399]Too Simple 函数映射问题 给出m函数 里面有0~m个函数未知(-1) 问要求最后1~n分别对应仍映射1~n 有几种函数写法(已给定的函数不可变 只可更改未知的函数的映射) 如果映射过程中出现多对一 即入度n出度小于n 的函数 必定冲突 即最后必有落单 映射失败 为0 如果映射完整 已知的连续函数可压缩成一个函数 中间出入度可忽略 因此可压缩为-1 f -1 -1 f -1 -1 f这种形态 进一步深入可发现中间的f仅仅起到通道作用 即可压缩为连续的-1之间的映射

hdoj 4971 A simple brute force problem. 【最大闭合权 --&gt; 最小割】

题目:hdoj 4971 A simple brute force problem. 题意:给出 n 个任务和 m 项技术,完成某个任务需要其中几项技术,完成某个任务有奖金,学习某个技术需要钱,技术之间有父子关系,某项技术可能需要先学习其他技术,然后问你选择做那些任务获得收益最大? 分析:看题意的黑体字部分,就是一个标准的闭合权问题,这个题目的关键忽悠点在于技术之间的关系,导致很多人想到了dp以及树形dp. 其实就是一个闭合权问题模板,官方题解说如果技术之间存在相互的关系需要缩点,其实不用缩点也

HDOJ 4974 A simple water problem

A simple water problem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 173    Accepted Submission(s): 112 Problem Description Dragon is watching competitions on TV. Every competition is held be

HDOJ 4972 A simple dynamic programming problem

找规律...数据可能不合法...输出0 A simple dynamic programming problem Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 85    Accepted Submission(s): 31 Problem Description Dragon is watching NBA. He loves Ja

【HDOJ】2451 Simple Addition Expression

递推,但是要注意细节.题目的意思,就是求s(x) = i+(i+1)+(i+2),i<n.该表达中计算过程中CA恒为0(包括中间值)的情况.根据所求可推得.1-10: 31-100: 3*41-1000: 3*4*41-10000: 3*4*4*41-10^n: 3*4^(n-1).并且需要注意,一旦发现某一位大于3,则应立即跳出累加的循环.比如,f(133) = 24,f(143) = 24.同时,单独讨论个位的情况.28行的break处理该种情况. 1 #include <cstdio&g

hdoj 4975 A simple Gaussian elimination problem. 【最大流唯一性判断】

题目:hdoj 4975 A simple Gaussian elimination problem. 这个题目跟hdoj 4888 一样,只是数据加强了一点,这个题目确实出的不好,尤其数据,争议比较大,但是同时也说明优化有时候还是很有用的. 不懂的可以看这个讲解:点击 这个题目只是加了一点优化,就是判断的时候加入是行和为0,或者满的话,就跳出不用判断,然后就300ms过了.真心牛 AC代码: #include <cstdio> #include <cstring> #includ

HDOJ 4888 Redraw Beautiful Drawings &amp;&amp; HDOJ 4975 A simple Gaussian elimination problem

解题思路: 这两道题题目大致相同,都是已知一个矩阵每一行的和和每一列的和,并且每个点的数小于K  还原原矩阵并判断答案是否唯一.建图方式相同,新建一个原点S 和一个汇点T ,S到行连边,容量为该行之和,列到T连边,容量为该列之和, 对于每一个点 i 和 j ,i 行向 j 列连边 , 容量为K , 求一遍最大流.并且通过判断是否存在环来判断是否唯一. 区别在于 第二道题N 与 M 均扩大,找环需要采用更高效的算法,这里采用Tarjan 算法来找环. HDOJ 4888 #include <ios